summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornovenary2021-04-04 17:06:12 +0300
committernovenary2021-04-04 17:06:12 +0300
commit2997c057dcc451a3e8defbe2f8e5f20b4c640a4d (patch)
tree47e697e0e84703914510988de9ec3525bfcbe20b
parent2c45f224ef5255d02ac54a2a1bb5dca1dd718d4f (diff)
downloadaur-2997c057dcc451a3e8defbe2f8e5f20b4c640a4d.tar.gz
Re-enable XIM support, fix font change not resizing
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--font-resize.patch13
3 files changed, 21 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9aaaf81e60b1..345383e0c233 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rxvt-unicode-intensityfix
pkgdesc = A unicode enabled rxvt-clone terminal emulator (urxvt) (opinionated build)
pkgver = 9.22
- pkgrel = 15
+ pkgrel = 16
url = http://software.schmorp.de/pkg/rxvt-unicode.html
arch = i686
arch = x86_64
@@ -17,6 +17,7 @@ pkgbase = rxvt-unicode-intensityfix
source = http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-9.22.tar.bz2
source = intensity.patch
source = background-img-use-color.patch
+ source = font-resize.patch
source = font-width-fix.patch
source = line-spacing-fix.patch
source = sgr-mouse-mode.patch
@@ -26,6 +27,7 @@ pkgbase = rxvt-unicode-intensityfix
md5sums = 93782dec27494eb079467dacf6e48185
md5sums = 9e2ccfa07aafa6aeaf1dbdd005437af7
md5sums = d8377a6ec47a7913636fbc368aded94b
+ md5sums = 4f6c9f1b51f28645ef5f114c04da27e6
md5sums = fef588d6bfe52304bf80e8f1771577b6
md5sums = 9f3248bc397ee76b008375f2ab0f201a
md5sums = f8325b0a33999db4d5d1eeac4f320156
diff --git a/PKGBUILD b/PKGBUILD
index 8089f5c02abf..93d4fba6eac3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-intensityfix
pkgver=9.22
-pkgrel=15
+pkgrel=16
pkgdesc='A unicode enabled rxvt-clone terminal emulator (urxvt) (opinionated build)'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
@@ -15,6 +15,7 @@ source=(
"http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2"
'intensity.patch'
'background-img-use-color.patch'
+ 'font-resize.patch'
'font-width-fix.patch'
'line-spacing-fix.patch'
'sgr-mouse-mode.patch'
@@ -25,6 +26,7 @@ source=(
md5sums=('93782dec27494eb079467dacf6e48185'
'9e2ccfa07aafa6aeaf1dbdd005437af7'
'd8377a6ec47a7913636fbc368aded94b'
+ '4f6c9f1b51f28645ef5f114c04da27e6'
'fef588d6bfe52304bf80e8f1771577b6'
'9f3248bc397ee76b008375f2ab0f201a'
'f8325b0a33999db4d5d1eeac4f320156'
@@ -37,6 +39,7 @@ prepare() {
patch -p0 -i ../intensity.patch
patch -p0 -i ../background-img-use-color.patch
+ patch -p0 -i ../font-resize.patch
# From https://aur.archlinux.org/packages/rxvt-unicode-patched/
patch -p0 -i ../font-width-fix.patch
@@ -82,7 +85,7 @@ build() {
--enable-wide-glyphs \
--enable-wtmp \
--enable-xft \
- --disable-xim \
+ --enable-xim \
--disable-xterm-scroll \
--enable-pixbuf \
--enable-frills
diff --git a/font-resize.patch b/font-resize.patch
new file mode 100644
index 000000000000..439615a5c253
--- /dev/null
+++ b/font-resize.patch
@@ -0,0 +1,13 @@
+--- src/main.C
++++ src/main.C
+@@ -876,9 +876,8 @@
+ #endif
+ }
+
+- if (parent)
+ {
++ resize_all_windows (szHint.width, szHint.height, 1);
+- resize_all_windows (0, 0, 0);
+ scr_remap_chars ();
+ scr_touch (true);
+ }