summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Elkouby2018-04-30 21:09:00 +0300
committerDan Elkouby2018-04-30 21:09:00 +0300
commit37d4af86602e3c585a0a5a2b8cc39a1fec8d7d77 (patch)
tree1b1949fa2079d0faf24181a632291003f133dfd7
parent8cb2f613b1fb9698e1b1b7cb7829fc3cac79079b (diff)
downloadaur-37d4af86602e3c585a0a5a2b8cc39a1fec8d7d77.tar.gz
Add background image patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--background-img-use-color.patch21
3 files changed, 28 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7936dbc0de0..14867b12f957 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rxvt-unicode-intensityfix
pkgdesc = A unicode enabled rxvt-clone terminal emulator (urxvt), with various fixes
pkgver = 9.22
- pkgrel = 8
+ pkgrel = 9
url = http://software.schmorp.de/pkg/rxvt-unicode.html
arch = i686
arch = x86_64
@@ -20,6 +20,7 @@ pkgbase = rxvt-unicode-intensityfix
source = urxvtc.desktop
source = urxvt-tabbed.desktop
source = intensity.patch
+ source = background-img-use-color.patch
source = font-width-fix.patch
source = line-spacing-fix.patch
source = https://gist.githubusercontent.com/alexoj/df5bae7a4825cb596581/raw/75a1e75c2ae1ec5c0db68a29f8a6821e9e3d87a5/sgr-mouse-mode.patch
@@ -29,6 +30,7 @@ pkgbase = rxvt-unicode-intensityfix
md5sums = fac55f0a8404c86dad3e702146762332
md5sums = 8a5599197568c63720e282b9722a7990
md5sums = 9e2ccfa07aafa6aeaf1dbdd005437af7
+ md5sums = d8377a6ec47a7913636fbc368aded94b
md5sums = fef588d6bfe52304bf80e8f1771577b6
md5sums = 9f3248bc397ee76b008375f2ab0f201a
md5sums = f8325b0a33999db4d5d1eeac4f320156
diff --git a/PKGBUILD b/PKGBUILD
index e78b383ccef7..c14935453b65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-intensityfix
pkgver=9.22
-pkgrel=8
+pkgrel=9
pkgdesc='A unicode enabled rxvt-clone terminal emulator (urxvt), with various fixes'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
@@ -18,6 +18,7 @@ source=(
'urxvtc.desktop'
'urxvt-tabbed.desktop'
'intensity.patch'
+ 'background-img-use-color.patch'
'font-width-fix.patch'
'line-spacing-fix.patch'
'https://gist.githubusercontent.com/alexoj/df5bae7a4825cb596581/raw/75a1e75c2ae1ec5c0db68a29f8a6821e9e3d87a5/sgr-mouse-mode.patch'
@@ -28,6 +29,7 @@ md5sums=('93782dec27494eb079467dacf6e48185'
'fac55f0a8404c86dad3e702146762332'
'8a5599197568c63720e282b9722a7990'
'9e2ccfa07aafa6aeaf1dbdd005437af7'
+ 'd8377a6ec47a7913636fbc368aded94b'
'fef588d6bfe52304bf80e8f1771577b6'
'9f3248bc397ee76b008375f2ab0f201a'
'f8325b0a33999db4d5d1eeac4f320156'
@@ -37,6 +39,7 @@ prepare() {
cd $_pkgname-$pkgver
patch -p0 -i ../intensity.patch
+ patch -p0 -i ../background-img-use-color.patch
# From https://aur.archlinux.org/packages/rxvt-unicode-patched/
patch -p0 -i ../font-width-fix.patch
diff --git a/background-img-use-color.patch b/background-img-use-color.patch
new file mode 100644
index 000000000000..dbd41d9ef0b6
--- /dev/null
+++ b/background-img-use-color.patch
@@ -0,0 +1,21 @@
+--- src/rxvtimg.C
++++ src/rxvtimg.C
+@@ -770,9 +770,15 @@
+
+ if (repeat == RepeatNone)
+ {
+- XRenderColor rc = { 0, 0, 0, 0 };
++ rgba bg = GET_R->pix_colors[Color_bg];
++ XRenderColor rc = {
++ (unsigned short)(bg.r * bg.a / 65535),
++ (unsigned short)(bg.g * bg.a / 65535),
++ (unsigned short)(bg.b * bg.a / 65535),
++ GET_R->depth == 32 ? bg.a : 65535
++ };
+ XRenderFillRectangle (cc.dpy, PictOpSrc, cc.dst, &rc, 0, 0, w, h);//TODO: split into four fillrectangles
+- XRenderComposite (cc.dpy, PictOpSrc, cc.src, None, cc.dst, 0, 0, 0, 0, x, y, ref->w, ref->h);
++ XRenderComposite (cc.dpy, PictOpOver, cc.src, None, cc.dst, 0, 0, 0, 0, x, y, ref->w, ref->h);
+ }
+ else
+ XRenderComposite (cc.dpy, PictOpSrc, cc.src, None, cc.dst, -x, -y, 0, 0, 0, 0, w, h);
+