summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Elkouby2018-04-30 19:13:53 +0300
committerDan Elkouby2018-04-30 19:13:53 +0300
commit8cb2f613b1fb9698e1b1b7cb7829fc3cac79079b (patch)
tree806e2e5d8aeba70a229a7970263ea9958492bd17
parentb4ce23cf3ced95305fcf1200bf84567927d305e7 (diff)
downloadaur-8cb2f613b1fb9698e1b1b7cb7829fc3cac79079b.tar.gz
Add SGR mouse patch and enable pixbuf support
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1074ece58efa..c7936dbc0de0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Sep 3 20:15:57 UTC 2017
pkgbase = rxvt-unicode-intensityfix
- pkgdesc = A unicode enabled rxvt-clone terminal emulator (urxvt), patched to avoid intense colors on 256 color escape codes and to fix font spacing
+ pkgdesc = A unicode enabled rxvt-clone terminal emulator (urxvt), with various fixes
pkgver = 9.22
- pkgrel = 7
+ pkgrel = 8
url = http://software.schmorp.de/pkg/rxvt-unicode.html
arch = i686
arch = x86_64
@@ -11,6 +9,7 @@ pkgbase = rxvt-unicode-intensityfix
depends = libxft
depends = perl
depends = startup-notification
+ depends = gdk-pixbuf2
optdepends = gtk2-perl: to use the urxvt-tabbed
provides = rxvt-unicode
provides = rxvt-unicode-terminfo
@@ -23,6 +22,7 @@ pkgbase = rxvt-unicode-intensityfix
source = intensity.patch
source = font-width-fix.patch
source = line-spacing-fix.patch
+ source = https://gist.githubusercontent.com/alexoj/df5bae7a4825cb596581/raw/75a1e75c2ae1ec5c0db68a29f8a6821e9e3d87a5/sgr-mouse-mode.patch
source = 256color.patch
md5sums = 93782dec27494eb079467dacf6e48185
md5sums = fec94dc986fa37ec380079d81de3e0b2
@@ -31,6 +31,7 @@ pkgbase = rxvt-unicode-intensityfix
md5sums = 9e2ccfa07aafa6aeaf1dbdd005437af7
md5sums = fef588d6bfe52304bf80e8f1771577b6
md5sums = 9f3248bc397ee76b008375f2ab0f201a
+ md5sums = f8325b0a33999db4d5d1eeac4f320156
md5sums = fb78c2ecf87626962734320cc2bb7ab1
pkgname = rxvt-unicode-intensityfix
diff --git a/.gitignore b/.gitignore
index 3265816c5b6a..afcf6e33e91e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@
/pkg/
rxvt-unicode-*.bz2
*.pkg.tar*
+sgr-mouse-mode.patch
diff --git a/PKGBUILD b/PKGBUILD
index 7a13c7c15bbf..e78b383ccef7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-intensityfix
pkgver=9.22
-pkgrel=7
-pkgdesc='A unicode enabled rxvt-clone terminal emulator (urxvt), patched to avoid intense colors on 256 color escape codes and to fix font spacing'
+pkgrel=8
+pkgdesc='A unicode enabled rxvt-clone terminal emulator (urxvt), with various fixes'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
license=('GPL')
-depends=('libxft' 'perl' 'startup-notification')
+depends=('libxft' 'perl' 'startup-notification' 'gdk-pixbuf2')
optdepends=('gtk2-perl: to use the urxvt-tabbed')
provides=('rxvt-unicode' 'rxvt-unicode-terminfo')
conflicts=('rxvt-unicode' 'rxvt-unicode-terminfo')
@@ -20,6 +20,7 @@ source=(
'intensity.patch'
'font-width-fix.patch'
'line-spacing-fix.patch'
+ 'https://gist.githubusercontent.com/alexoj/df5bae7a4825cb596581/raw/75a1e75c2ae1ec5c0db68a29f8a6821e9e3d87a5/sgr-mouse-mode.patch'
'256color.patch'
)
md5sums=('93782dec27494eb079467dacf6e48185'
@@ -29,6 +30,7 @@ md5sums=('93782dec27494eb079467dacf6e48185'
'9e2ccfa07aafa6aeaf1dbdd005437af7'
'fef588d6bfe52304bf80e8f1771577b6'
'9f3248bc397ee76b008375f2ab0f201a'
+ 'f8325b0a33999db4d5d1eeac4f320156'
'fb78c2ecf87626962734320cc2bb7ab1')
prepare() {
@@ -39,6 +41,7 @@ prepare() {
# From https://aur.archlinux.org/packages/rxvt-unicode-patched/
patch -p0 -i ../font-width-fix.patch
patch -p0 -i ../line-spacing-fix.patch
+ patch -p0 -i ../sgr-mouse-mode.patch
# From https://aur.archlinux.org/packages/rxvt-unicode-256xresources/
patch -p0 -i ../256color.patch
@@ -74,7 +77,7 @@ build() {
--enable-xft \
--enable-xim \
--enable-xterm-scroll \
- --disable-pixbuf \
+ --enable-pixbuf \
--enable-frills
make
}