summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Hahler2016-12-22 21:08:56 +0100
committerDaniel Hahler2016-12-22 21:24:40 +0100
commit283fefc186597f3bdf2b92ea7eed04018889b59c (patch)
tree065556ddc20a85f19cc164788b6f731eb9990afc
parentb71dc65ca03086cab86bb62bf85676cdb12a9598 (diff)
downloadaur-283fefc186597f3bdf2b92ea7eed04018889b59c.tar.gz
--enable-smart-resize with upstream patch (can be dropped in 9.22+)
-rw-r--r--PKGBUILD7
-rw-r--r--fix-smart-resize-with-x11-frame-borders.patch54
2 files changed, 58 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 773260fd66ef..51287054ba1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,6 +25,7 @@ source=(http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
'font-width-fix.patch'
'line-spacing-fix.patch'
'https://gist.githubusercontent.com/alexoj/df5bae7a4825cb596581/raw/75a1e75c2ae1ec5c0db68a29f8a6821e9e3d87a5/sgr-mouse-mode.patch'
+ 'fix-smart-resize-with-x11-frame-borders.patch' # will be in 9.22+
)
sha1sums=('e575b869782fbfed955f84f48b204ec888d91ba1'
'b5a4507f85ebb7bac589db2e07d9bc40106720d9'
@@ -33,7 +34,7 @@ sha1sums=('e575b869782fbfed955f84f48b204ec888d91ba1'
'01ee8f212add79a158dcd4ed78d0ea1324bdc59b'
'b7fde1c46af45e831828738874f14b092b1e795f'
'dfbc8729c545105eff21e20ef3a4a3841a68a192'
- '59f5c5838c6f49521527146053eb439d96a25179')
+ '6dfa49a211c48193c8d87fb9993ed459b2b4387b')
prepare() {
cd $_pkgname-$pkgver
@@ -41,12 +42,12 @@ prepare() {
patch -p0 -i ../font-width-fix.patch
patch -p0 -i ../line-spacing-fix.patch
patch -p0 -i ../sgr-mouse-mode.patch
+ patch -p1 -i ../fix-smart-resize-with-x11-frame-borders.patch
}
build() {
cd $_pkgname-$pkgver
- # we disable smart-resize (FS#34807)
# do not specify --with-terminfo (FS#46424)
./configure \
--prefix=/usr \
@@ -64,7 +65,7 @@ build() {
--enable-rxvt-scroll \
--enable-selectionscrolling \
--enable-slipwheeling \
- --disable-smart-resize \
+ --enable-smart-resize \
--enable-startup-notification \
--enable-transparency \
--enable-unicode3 \
diff --git a/fix-smart-resize-with-x11-frame-borders.patch b/fix-smart-resize-with-x11-frame-borders.patch
new file mode 100644
index 000000000000..9311f9d70d8d
--- /dev/null
+++ b/fix-smart-resize-with-x11-frame-borders.patch
@@ -0,0 +1,54 @@
+commit bec3f19
+Author: Emanuele Giaquinta <e.giaquinta@glauco.it>
+Date: Tue Jun 28 21:56:17 2016 +0000
+
+ Fix invalid moves when smart resize is enabled and the wm uses X11 borders for the frame windows.
+
+ Patch by Uli Schlachter.
+---
+ src/main.C | 25 +++++++++++++++++++++++--
+ 1 file changed, 23 insertions(+), 2 deletions(-)
+
+diff --git a/src/main.C b/src/main.C
+index 39aa5ec..5fa605e 100644
+--- a/src/main.C
++++ b/src/main.C
+@@ -1054,6 +1054,25 @@ rxvt_term::alias_color (int dst, int src)
+ pix_colors[dst].set (this, rs[Rs_color + dst] = rs[Rs_color + src]);
+ }
+
++#ifdef SMART_RESIZE
++static unsigned int
++get_parent_bw (Display *dpy, Window w)
++{
++ int idummy;
++ unsigned int udummy;
++ Window wdummy, parent;
++ Window *children;
++ unsigned int nchildren, border_width;
++
++ XQueryTree (dpy, w, &wdummy, &parent, &children, &nchildren);
++ XFree (children);
++ XGetGeometry (dpy, parent, &wdummy, &idummy, &idummy,
++ &udummy, &udummy, &border_width, &udummy);
++
++ return border_width;
++}
++#endif
++
+ /* -------------------------------------------------------------------- *
+ * - WINDOW RESIZING - *
+ * -------------------------------------------------------------------- */
+@@ -1098,8 +1117,10 @@ rxvt_term::resize_all_windows (unsigned int newwidth, unsigned int newheight, in
+ */
+ if (x1 != x || y1 != y)
+ {
+- x -= x1;
+- y -= y1;
++ unsigned int border_width = get_parent_bw (dpy, parent);
++
++ x -= x1 + border_width;
++ y -= y1 + border_width;
+ }
+
+ x1 = (DisplayWidth (dpy, display->screen) - old_width ) / 2;