summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Gedda2020-09-15 18:03:06 +0200
committerEmil Gedda2020-09-15 18:03:06 +0200
commit2207ba116e429875338fec566a3313f93cf19d3f (patch)
tree83511871dcae63e8cc9a31386b583f6858983696
parenta20fcf40ef7c182a2a221fdc93144de65bd09d13 (diff)
downloadaur-2207ba116e429875338fec566a3313f93cf19d3f.tar.gz
fix https://bugs.archlinux.org/task/67691
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
-rw-r--r--fix-perl-segfault.patch32
3 files changed, 41 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 459e4fbd7c88..d798367f04fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,6 +25,7 @@ pkgbase = rxvt-unicode-patched-with-scrolling
source = secondaryWheel.patch
source = enable-wide-glyphs.patch
source = 24-bit-color.patch
+ source = fix-perl-segfault.patch
sha1sums = e575b869782fbfed955f84f48b204ec888d91ba1
sha1sums = b5a4507f85ebb7bac589db2e07d9bc40106720d9
sha1sums = 62c4ffecfce6967def394dd4d418b68652372ea2
@@ -37,6 +38,8 @@ pkgbase = rxvt-unicode-patched-with-scrolling
sha1sums = e50503f786deb6d6c2b6b8bcf486bf509c14af71
sha1sums = d9f3b52b273d13fbd4089a7869ab2e70bf190bc9
sha1sums = 9f5db305863b17175e72f9e2d4a78d0d7f25fd34
+ sha1sums = 949900e5acff1fa0682900c282ff9d1cdfd292b8
+
pkgname = rxvt-unicode-patched-with-scrolling
diff --git a/PKGBUILD b/PKGBUILD
index a514be87eaa1..dae532386dfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-patched-with-scrolling
pkgver=9.22
-pkgrel=11
+pkgrel=12
pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing and scrolling in pages'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
@@ -30,7 +30,8 @@ source=(http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
'clear.patch'
'secondaryWheel.patch'
'enable-wide-glyphs.patch'
- '24-bit-color.patch')
+ '24-bit-color.patch'
+ 'fix-perl-segfault.patch')
sha1sums=('e575b869782fbfed955f84f48b204ec888d91ba1'
'b5a4507f85ebb7bac589db2e07d9bc40106720d9'
'62c4ffecfce6967def394dd4d418b68652372ea2'
@@ -42,7 +43,8 @@ sha1sums=('e575b869782fbfed955f84f48b204ec888d91ba1'
'fc77f75bd2d51baa4abef81983dab044d7f498ce'
'e50503f786deb6d6c2b6b8bcf486bf509c14af71'
'd9f3b52b273d13fbd4089a7869ab2e70bf190bc9'
- '9f5db305863b17175e72f9e2d4a78d0d7f25fd34')
+ '9f5db305863b17175e72f9e2d4a78d0d7f25fd34'
+ '949900e5acff1fa0682900c282ff9d1cdfd292b8')
prepare() {
cd $_pkgname-$pkgver
@@ -55,6 +57,7 @@ prepare() {
patch -p1 -i ../clear.patch
patch -p1 -i ../secondaryWheel.patch
patch -p1 -i ../enable-wide-glyphs.patch
+ patch -p1 -i ../fix-perl-segfault.patch
}
build() {
diff --git a/fix-perl-segfault.patch b/fix-perl-segfault.patch
new file mode 100644
index 000000000000..776d1677a26e
--- /dev/null
+++ b/fix-perl-segfault.patch
@@ -0,0 +1,32 @@
+--- a/src/rxvtperl.h
++++ b/src/rxvtperl.h
+@@ -51,7 +51,9 @@
+ {
+ char **perl_environ;
+
++ #if 0 // see rxvtperl.xs
+ ~rxvt_perl_interp ();
++ #endif
+
+ void init ();
+ void init (rxvt_term *term);
+--- a/src/rxvtperl.xs
++++ b/src/rxvtperl.xs
+@@ -372,6 +372,9 @@
+
+ static PerlInterpreter *perl;
+
++#if 0 /* we are not a library anymore, so doing this is just not worth it */
++/*THINK/TODO: this has the side effect of, of course, not calling destructors. */
++/* but therse are not guaranteed anyway... */
+ rxvt_perl_interp::~rxvt_perl_interp ()
+ {
+ if (perl)
+@@ -381,6 +384,7 @@
+ PERL_SYS_TERM ();
+ }
+ }
++#endif
+
+ void
+ rxvt_perl_interp::init ()