summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAloxaf2023-05-17 09:39:15 +0800
committerAloxaf2023-05-17 09:39:15 +0800
commit6cc6997c442fce362899b3242589f1743ec39038 (patch)
tree5a6ed392835959a1a0ada3621acd7cb175b6c9c3
downloadaur-6cc6997c442fce362899b3242589f1743ec39038.tar.gz
initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05b79f813d8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = rxxr2-git
+ pkgdesc = regular expression static analyzer
+ pkgver = r34.0eea5e9
+ pkgrel = 1
+ arch = x86_64
+ makedepends = ocaml
+ makedepends = opam
+ source = rxxr2-git::git+https://github.com/superhuman/rxxr2.git
+ sha256sums = SKIP
+
+pkgname = rxxr2-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50ba47808e82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Aloxaf <aloxafx@gmail.com>
+
+pkgname=rxxr2-git
+pkgver=r34.0eea5e9
+pkgrel=1
+pkgdesc='regular expression static analyzer'
+license=()
+arch=('x86_64')
+makedepends=('ocaml' 'opam')
+source=("${pkgname}::git+https://github.com/superhuman/rxxr2.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+
+build() {
+ cd "${pkgname}/code"
+ ./build.sh
+}
+
+package() {
+ install -D "${pkgname}/code/scan.bin" "$pkgdir/usr/bin/rxxr2"
+}