summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasukaminato2023-04-26 20:22:32 +0900
committerasukaminato2023-04-26 20:22:32 +0900
commit29f66a15e581592a063ec6577468afbe3c2be6bb (patch)
tree28a7ed8052373ea08d43f2ec18e1b95ad712608f
parent4dbf06bd7ccd588bfd985b4f23285fb1ea773b40 (diff)
downloadaur-29f66a15e581592a063ec6577468afbe3c2be6bb.tar.gz
add deps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adf250e6bef8..3a6a5d12c246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rye-git
pkgdesc = an experimental alternative to poetry/pip/pipenv/venv/virtualenv/pdm/hatch/…
- pkgver = r7.4d13663
+ pkgver = r52.4103bf3
pkgrel = 1
url = https://github.com/mitsuhiko/rye
arch = any
@@ -11,7 +11,10 @@ pkgbase = rye-git
depends = openssl
depends = glibc
depends = gcc-libs
+ depends = libxcrypt-compat
provides = rye
+ conflicts = rye
+ conflicts = rye-bin
source = git+https://github.com/mitsuhiko/rye.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 78bcdf56a83c..103e5e752e7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Your Name <youremail@domain.com>
pkgname=rye-git
-pkgver=r7.4d13663
+pkgver=r52.4103bf3
pkgrel=1
epoch=
pkgdesc="an experimental alternative to poetry/pip/pipenv/venv/virtualenv/pdm/hatch/…"
@@ -13,12 +13,14 @@ arch=(any)
url="https://github.com/mitsuhiko/rye"
license=('MIT')
groups=()
-depends=(zlib openssl glibc gcc-libs)
+depends=(zlib openssl glibc gcc-libs
+ libxcrypt-compat # https://github.com/mitsuhiko/rye/issues/15
+)
makedepends=(cargo git)
checkdepends=()
optdepends=()
provides=(rye)
-conflicts=()
+conflicts=(rye rye-bin)
replaces=()
backup=()
options=()
@@ -51,7 +53,7 @@ build() {
check() {
cd rye
export RUSTUP_TOOLCHAIN=stable
- # cargo test --frozen --all-features
+ cargo test --frozen --all-features
}
package() {