summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasukaminato2023-04-23 18:55:03 +0900
committerasukaminato2023-04-23 18:55:03 +0900
commit4dbf06bd7ccd588bfd985b4f23285fb1ea773b40 (patch)
treed23cb67457efddd0af47875c2487d268a186ebf2
downloadaur-4dbf06bd7ccd588bfd985b4f23285fb1ea773b40.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD61
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adf250e6bef8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rye-git
+ pkgdesc = an experimental alternative to poetry/pip/pipenv/venv/virtualenv/pdm/hatch/…
+ pkgver = r7.4d13663
+ pkgrel = 1
+ url = https://github.com/mitsuhiko/rye
+ arch = any
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ depends = zlib
+ depends = openssl
+ depends = glibc
+ depends = gcc-libs
+ provides = rye
+ source = git+https://github.com/mitsuhiko/rye.git
+ sha256sums = SKIP
+
+pkgname = rye-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3705ffbff2b2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.zst
+rye
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78bcdf56a83c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=rye-git
+pkgver=r7.4d13663
+pkgrel=1
+epoch=
+pkgdesc="an experimental alternative to poetry/pip/pipenv/venv/virtualenv/pdm/hatch/…"
+arch=(any)
+url="https://github.com/mitsuhiko/rye"
+license=('MIT')
+groups=()
+depends=(zlib openssl glibc gcc-libs)
+makedepends=(cargo git)
+checkdepends=()
+optdepends=()
+provides=(rye)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/mitsuhiko/rye.git")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "rye"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+prepare() {
+ cd rye
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd rye
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+
+check() {
+ cd rye
+ export RUSTUP_TOOLCHAIN=stable
+ # cargo test --frozen --all-features
+}
+
+package() {
+ cd rye
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/rye"
+ install -Dm644 LICENSE* -t $pkgdir/usr/share/licenses/$pkgname/
+}