summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspikecodes2020-10-22 19:58:40 -0700
committerspikecodes2020-10-22 19:58:40 -0700
commitecbb1f6b2f00c3dd1366aaff8c775a9e1828e9b0 (patch)
tree55bd3eb976cbd550563fabc6338d37c0231c0dcb
downloadaur-ecbb1f6b2f00c3dd1366aaff8c775a9e1828e9b0.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ce2be2e3a80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rymfony-git
+ pkgdesc = A work-in-progress CLI tool built in Rust to mimic the Symfony CLI binary
+ pkgver = r185.751e78b
+ pkgrel = 1
+ url = https://github.com/Orbitale/Rymfony
+ arch = x86_64
+ license = AGPL-3.0
+ makedepends = git
+ makedepends = cargo
+ provides = rymfony
+ conflicts = rymfony
+ source = rymfony::git+https://github.com/Orbitale/Rymfony
+ sha256sums = SKIP
+
+pkgname = rymfony-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caeae88cdf27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: spikecodes <19519553+spikecodes@users.noreply.github.com>
+pkgname=rymfony-git
+_pkgname=${pkgname%-git}
+pkgver=r185.751e78b
+pkgrel=1
+pkgdesc="A work-in-progress CLI tool built in Rust to mimic the Symfony CLI binary"
+arch=('x86_64')
+url="https://github.com/Orbitale/Rymfony"
+license=("AGPL-3.0")
+makedepends=("git" "cargo")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("${_pkgname}::git+${url}")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm755 "target/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}