summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2023-02-09 12:09:31 +0100
committerMarco Rubin2023-02-09 12:09:31 +0100
commit198dc778c5216bbc600aef4b85fda2edcafd24d3 (patch)
tree3b5041788d65c0b7ff9977205ea0c10892a7a38e
parent29042c1c71b2079264cae14c735fea922877bd4f (diff)
downloadaur-198dc778c5216bbc600aef4b85fda2edcafd24d3.tar.gz
Style
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd3ec012da1a..e5ad21589ec3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ryujinx
pkgdesc = Experimental Nintendo Switch Emulator written in C#
pkgver = 1.1.614
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Ryujinx/Ryujinx
arch = x86_64
license = MIT
@@ -12,8 +12,6 @@ pkgbase = ryujinx
conflicts = Ryujinx
options = !strip
source = git+https://github.com/Ryujinx/Ryujinx#commit=5f38086f9494a4ffbcb4b0ce4b7727ad8ac18b3e
- source = https://github.com/Ryujinx/Ryujinx/wiki/Changelog
- b2sums = SKIP
b2sums = SKIP
pkgname = ryujinx
diff --git a/PKGBUILD b/PKGBUILD
index 616ab93ffba4..b4adf04cfd36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name=Ryujinx
pkgname=ryujinx
pkgver=1.1.614
_commit=5f38086f9494a4ffbcb4b0ce4b7727ad8ac18b3e
-pkgrel=1
+pkgrel=2
pkgdesc="Experimental Nintendo Switch Emulator written in C#"
arch=(x86_64)
url="https://github.com/Ryujinx/Ryujinx"
@@ -14,15 +14,15 @@ makedepends=('dotnet-sdk' 'git')
provides=($_name)
conflicts=($_name)
options=(!strip)
-source=("git+$url#commit=$_commit" "$url/wiki/Changelog")
-b2sums=('SKIP' 'SKIP')
-
-pkgver() {
- cd $_name
- _commit_msg=$(git log -1 --pretty=%B | awk '{$NF=""}1') # remove PR number in parentheses
- # Changelog is $url/wiki/Changelog
- html2text ../Changelog | grep -B 4 "${_commit_msg::length - 1}" | head -n 1 | awk '{print $2}'
-}
+source=("git+$url#commit=$_commit")
+b2sums=('SKIP')
+
+# pkgver() {
+# cd $_name
+# # changelog is $url/wiki/Changelog, needs python-html2text
+# _commit_msg=$(git log -1 --pretty=%B | awk '{$NF=""}1') # remove PR number in parentheses
+# html2text ../Changelog | grep -B 4 "${_commit_msg::length - 1}" | head -n 1 | awk '{print $2}'
+# }
build() {
cd $_name