summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-04-19 06:45:43 +0000
committerxiota2024-04-19 06:45:43 +0000
commite1a995dbe09f6abb99a0f258280f110404f637d4 (patch)
treebbece5fcbf2da2a62916276d9cd7f95a1126059c
parentdc9a750a38eb16b6d56ddda010bd958f2b54170c (diff)
downloadaur-e1a995dbe09f6abb99a0f258280f110404f637d4.tar.gz
1.1.1284
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90f870563fe6..bb38b6469777 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = ryujinx
pkgdesc = Experimental Nintendo Switch Emulator written in C#
- pkgver = 1.1.1244
+ pkgver = 1.1.1284
pkgrel = 1
url = https://github.com/Ryujinx/Ryujinx
install = ryujinx.install
arch = x86_64
license = MIT
makedepends = desktop-file-utils
- makedepends = dotnet-sdk>=8.0.3.sdk202
+ makedepends = dotnet-sdk>=8.0.4.sdk204
options = !strip
options = !debug
- source = ryujinx-1.1.1244.tar.gz::https://github.com/Ryujinx/Ryujinx/archive/1.1.1244.tar.gz
+ source = ryujinx-1.1.1284.tar.gz::https://github.com/Ryujinx/Ryujinx/archive/1.1.1284.tar.gz
sha256sums = SKIP
pkgname = ryujinx
diff --git a/PKGBUILD b/PKGBUILD
index 3a8c7781b3bc..81ab0e8d0be5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Marco Rubin <marco.rubin@protonmail.com>
## options
-if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ] ; then
+if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ]; then
: ${_autoupdate:=false}
else
: ${_autoupdate:=true}
@@ -16,7 +16,7 @@ unset _pkgtype
## basic info
_pkgname="ryujinx"
pkgname="$_pkgname${_pkgtype:-}"
-pkgver=1.1.1244
+pkgver=1.1.1284
pkgrel=1
pkgdesc="Experimental Nintendo Switch Emulator written in C#"
url="https://github.com/Ryujinx/Ryujinx"
@@ -27,13 +27,13 @@ arch=(x86_64)
_main_package() {
makedepends=(
'desktop-file-utils'
- 'dotnet-sdk>=8.0.3.sdk202' # AUR: dotnet-core-bin
+ 'dotnet-sdk>=8.0.4.sdk204' # AUR: dotnet-core-bin
)
options=('!strip' '!debug')
install="$_pkgname.install"
- if [ "${_build_git::1}" != "t" ] ; then
+ if [ "${_build_git::1}" != "t" ]; then
_main_stable
else
_main_git
@@ -68,7 +68,7 @@ _main_git() {
pkgver() {
cd "$_pkgsrc"
- git describe --long --tags --abbrev=8 --exclude='*[a-zA-Z][a-zA-Z]*' \
+ git describe --long --tags --abbrev=7 --exclude='*[a-zA-Z][a-zA-Z]*' \
| sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
}
}
@@ -110,10 +110,10 @@ package() {
ln -s "/opt/ryujinx/Ryujinx.Gtk3" "$pkgdir/usr/bin/ryujinx.gtk"
# .desktop
- install -Dm644 distribution/linux/Ryujinx.desktop "$pkgdir/usr/share/applications/ryujinx.desktop"
+ install -Dm644 distribution/linux/Ryujinx.desktop "$pkgdir/usr/share/applications/ryujinx.desktop"
# icon
- install -Dm644 distribution/misc/Logo.svg "$pkgdir/usr/share/pixmaps/ryujinx.svg"
+ install -Dm644 distribution/misc/Logo.svg "$pkgdir/usr/share/pixmaps/ryujinx.svg"
# mimetype
install -Dm644 distribution/linux/mime/Ryujinx.xml "$pkgdir/usr/share/mime/packages/ryujinx.xml"
@@ -141,7 +141,7 @@ package() {
_update_version() {
: ${_pkgver:=${pkgver%%.r*}}
- if [[ "${_autoupdate::1}" != "t" ]] ; then
+ if [[ "${_autoupdate::1}" != "t" ]]; then
return
fi
@@ -155,7 +155,7 @@ _update_version() {
local _pkgver_new="${_tag#v}"
# update _pkgver
- if [ "$_pkgver" != "${_pkgver_new:?}" ] ; then
+ if [ "$_pkgver" != "${_pkgver_new:?}" ]; then
_pkgver="${_pkgver_new:?}"
fi
}