summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPitBall2015-10-16 16:19:36 +0200
committerPitBall2015-10-16 16:19:36 +0200
commit3a1076440030f517a42c07987d7018a8dfee6a07 (patch)
tree93527fbde3ab435784acf01dc4de3ad08b9cecec
downloadaur-3a1076440030f517a42c07987d7018a8dfee6a07.tar.gz
Initial import
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD67
-rw-r--r--install11
-rw-r--r--ryzom.sh9
4 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17d899d10d9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = ryzom-client
+ pkgdesc = Ryzom is a Free to Play MMORPG . This version is for playing on an official
+ pkgver = r6270.84b22d898cac
+ pkgrel = 1
+ url = http://www.ryzom.com/
+ install = install
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ makedepends = mercurial
+ makedepends = cpptest
+ makedepends = cmake
+ makedepends = bison
+ makedepends = mesa
+ depends = curl
+ depends = freealut
+ depends = libvorbis
+ depends = libjpeg
+ depends = rrdtool
+ depends = boost
+ depends = luabind
+ depends = libsquish
+ depends = libxrandr
+ depends = libxcursor
+ depends = hicolor-icon-theme
+ provides = libnel
+ provides = ryzom
+ provides = ryzomcore
+ conflicts = ryzom-client-latest-hg
+ conflicts = ryzom-client-hg
+ source = hg+https://bitbucket.org/ryzom/ryzomcore#branch=compatibility-develop
+ source = hg+http://hg.kervala.net/libwww
+ source = ryzom.sh
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = a5ca7dfae7b9073f78cd1b0b7380755f
+
+pkgname = ryzom-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42c3261d2585
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: PitBall
+
+pkgname=ryzom-client
+pkgver=r6270.84b22d898cac
+pkgrel=1
+pkgdesc="Ryzom is a Free to Play MMORPG . This version is for playing on an official"
+arch=('i686' 'x86_64')
+url="http://www.ryzom.com/"
+license=('AGPL3')
+depends=('curl' 'freealut' 'libvorbis' 'libjpeg' 'rrdtool' 'boost'
+ 'luabind' 'libsquish' 'libxrandr' 'libxcursor' 'hicolor-icon-theme')
+conflicts=('ryzom-client-latest-hg' 'ryzom-client-hg') #lua51
+makedepends=('mercurial' 'cpptest' 'cmake' 'bison' 'mesa')
+provides=('libnel' 'ryzom' 'ryzomcore')
+_hg_name='ryzomcore'
+install=install #branch=compatibility
+source=( "hg+https://bitbucket.org/ryzom/${_hg_name}#branch=compatibility-develop"
+ 'hg+http://hg.kervala.net/libwww'
+ 'ryzom.sh')
+md5sums=('SKIP' 'SKIP' 'a5ca7dfae7b9073f78cd1b0b7380755f')
+
+
+pkgver() {
+ cd "$_hg_name"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+prepare() {
+ cd $srcdir/$_hg_name/code
+
+
+
+}
+build() {
+ cd $srcdir/libwww
+ ./autogen.sh || true
+ sed -i 's|\${CC-cc}|${CC-cc} -O2 |g' ./configure
+ LDFLAGS="" CFLAGS="$CFLAGS -fPIC" ./configure --with-ssl=no \
+ --with-zlib --with-expat --prefix=$srcdir/w3c
+ make -j1
+ make install
+ ln -sf ../wwwconf.h $srcdir/w3c/include/w3c-libwww/wwwconf.h
+
+ mkdir -p $srcdir/$_hg_name/build
+ cd $srcdir/$_hg_name/build
+
+ PATH="$srcdir/w3c/bin:$PATH" \
+ cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release \
+ -DWITH_RYZOM_SERVER=OFF -DWITH_RYZOM_CLIENT=ON \
+ -DWITH_NEL_TOOLS=OFF -DWITH_NEL_TESTS=OFF -DWITH_PCH=OFF \
+ -DWITH_NEL_SAMPLES=OFF -DLIBWWW_LIBRARIES=$srcdir/w3c/lib \
+ -DLIBWWW_INCLUDE_DIR=$srcdir/w3c/include/w3c-libwww -DWITH_LIBWWW_STATIC=ON \
+ -DWITH_RYZOM_TOOLS=OFF -DCMAKE_INSTALL_PREFIX=/usr \
+ -DRYZOM_ETC_PREFIX=/etc/ryzom -DRYZOM_SHARE_PREFIX=/usr/share/ryzom \
+ -DRYZOM_BIN_PREFIX=/usr/bin -DRYZOM_GAMES_PREFIX=/usr/bin \
+ -DLUA_INCLUDE_DIR=/usr/include/lua5.1 ../code
+ make
+
+}
+
+package() {
+ cd "$srcdir/$_hg_name/build"
+ make DESTDIR="$pkgdir/" install
+ sed 's/\/usr\/bin\/ryzom_client/ryzom/' \
+ -i ${pkgdir}/usr/share/applications/ryzom_client.desktop
+ install -Dm755 ${srcdir}/ryzom.sh ${pkgdir}/usr/bin/ryzom
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..cdf5fd48105e
--- /dev/null
+++ b/install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/ryzom.sh b/ryzom.sh
new file mode 100644
index 000000000000..e3cff2c64971
--- /dev/null
+++ b/ryzom.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+if groups | grep games > /dev/null 2>&1 ; then
+ ryzom_sync
+ exec ryzom_client
+
+else
+ echo "you need to be in games group to run ryzom"
+ exit 1
+fi