summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPitBall2015-10-19 20:08:37 +0200
committerPitBall2015-10-19 20:28:51 +0200
commit90de1c39dff7945807c91a4e6f87bcc7f98ce13e (patch)
tree77737229744e7a79658e7954ff33d2bf2dba7359
parent6cc0a60ba307c37d69103af496c9fe9aca44993c (diff)
downloadaur-90de1c39dff7945807c91a4e6f87bcc7f98ce13e.tar.gz
A change in the numbering version
From now it is like this: $NEL_VERSSION.r$RYZOMCORE_REVISION
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17d899d10d9e..d4b2619c8a79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ryzom-client
- pkgdesc = Ryzom is a Free to Play MMORPG . This version is for playing on an official
- pkgver = r6270.84b22d898cac
+ pkgdesc = Ryzom is a Free to Play MMORPG .This version is for playing on an official server
+ pkgver = 0.12.0.r6270
pkgrel = 1
url = http://www.ryzom.com/
install = install
@@ -12,6 +12,7 @@ pkgbase = ryzom-client
makedepends = cmake
makedepends = bison
makedepends = mesa
+ depends = ryzom-data
depends = curl
depends = freealut
depends = libvorbis
diff --git a/PKGBUILD b/PKGBUILD
index cdc345b3bf9a..9fcb8d5594f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: PitBall
pkgname=ryzom-client
-pkgver=r6270.84b22d898cac
+pkgver=0.12.0.r6270
pkgrel=1
-pkgdesc="Ryzom is a Free to Play MMORPG . This version is for playing on an official"
+pkgdesc="Ryzom is a Free to Play MMORPG .This version is for playing on an official server"
arch=('i686' 'x86_64')
url="http://www.ryzom.com/"
license=('AGPL3')
@@ -22,7 +22,14 @@ md5sums=('SKIP' 'SKIP' 'a5ca7dfae7b9073f78cd1b0b7380755f')
pkgver() {
cd "$_hg_name"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ printf "%s.%s.%s.r%s" \
+ "$(grep -o -P "NL_VERSION_MAJOR [0-9]+" code/CMakeLists.txt | \
+ awk '{print $2}' | head -n 1)" \
+ "$(grep -o -P "NL_VERSION_MINOR [0-9]+" code/CMakeLists.txt | \
+ awk '{print $2}' | head -n 1)" \
+ "$(grep -o -P "NL_VERSION_PATCH [0-9]+" code/CMakeLists.txt | \
+ awk '{print $2}' | head -n 1)" \
+ "$(hg identify -n)"
}
build() {