summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLahfa Samy2022-04-24 01:50:37 +0200
committerLahfa Samy2022-04-24 01:50:37 +0200
commite0bab0f32b3e750021258a4d6231f22adddeae7b (patch)
tree6457a29b02a814d5d8bc0064391ceb2304190e37
parent63005f759707fc1767d498cf1bf1e1fcd84b68c9 (diff)
downloadaur-e0bab0f32b3e750021258a4d6231f22adddeae7b.tar.gz
Fix PKGBUILD sources & remove jupyter unused dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c3268cd6f83..6c722cc53185 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rz-cutter-git
pkgdesc = A Qt and C++ GUI for rizin reverse engineering framework (originally named Iaito)
- pkgver = 2.0.2.r13.g2d05ae25
+ pkgver = 2.0.4.r44.gd2243006
pkgrel = 1
url = https://cutter.re/
arch = i686
@@ -18,7 +18,6 @@ pkgbase = rz-cutter-git
depends = qt5-webengine
depends = icu
depends = python
- depends = jupyter
depends = pyside2
depends = python-shiboken2
depends = graphviz
@@ -30,8 +29,8 @@ pkgbase = rz-cutter-git
conflicts = rizin
conflicts = rz-cutter
source = rizin::git+https://github.com/rizinorg/rizin
- source = cutter::git://github.com/rizinorg/cutter.git
- source = git://github.com/rizinorg/cutter-translations.git
+ source = cutter::git+https://github.com/rizinorg/cutter
+ source = git+https://github.com/rizinorg/cutter-translations
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ce2164860c20..648ced8daf0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#!/hint/bash
# Maintainer: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
+# Maintainer: bartus <'arch-user-repo' at the domain 'bartus.33mail.com'>
+# Co-Maintainer: Lahfa Samy (AkechiShiro) <'samy' at the domain 'lahfa.xyz'>
# shellcheck disable=SC2015
((DISABLE_BUNDLED_RIZIN)) && {
@@ -17,20 +19,20 @@
_name=cutter
pkgname=rz-${_name}-git
-pkgver=2.0.2.r13.g2d05ae25
+pkgver=2.0.4.r44.gd2243006
pkgrel=1
pkgdesc="A Qt and C++ GUI for rizin reverse engineering framework (originally named Iaito)"
url="https://cutter.re/"
arch=('i686' 'x86_64')
license=('GPL')
-depends+=('capstone' 'qt5-base' 'qt5-svg' 'qt5-webengine' 'icu' 'python' 'jupyter'
- 'pyside2' 'python-shiboken2' 'graphviz' 'gcc-libs' 'syntax-highlighting')
+depends+=('capstone' 'qt5-base' 'qt5-svg' 'qt5-webengine' 'icu' 'python' 'pyside2'
+ 'python-shiboken2' 'graphviz' 'gcc-libs' 'syntax-highlighting')
makedepends=('git' 'cmake' 'ninja' 'shiboken2' 'qt5-tools' 'meson')
provides+=('rz-cutter')
conflicts+=('rz-cutter')
optdepends=('rz-ghidra: ghidra decompiler plugin')
-source+=("${_name}::git://github.com/rizinorg/cutter.git"
- "git://github.com/rizinorg/cutter-translations.git")
+source+=("cutter::git+https://github.com/rizinorg/cutter"
+ "git+https://github.com/rizinorg/cutter-translations")
sha512sums+=('SKIP'
'SKIP')
b2sums+=('SKIP'