summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Ellithorpe2017-05-05 23:42:50 -0700
committerJosh Ellithorpe2017-05-05 23:42:50 -0700
commit3b936d6f0714592d87ced4566f4d6c903f60e987 (patch)
tree7e5a2d07ab0b1fa06ecbd2feb6f4d2f7399bbabe
parent4a87faadf78a7c7743e6dc42df93f56eb352f374 (diff)
downloadaur-3b936d6f0714592d87ced4566f4d6c903f60e987.tar.gz
Actually use release tarball and not go get
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4b2af13a203..eca913c4b169 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat May 6 04:00:17 UTC 2017
+# Sat May 6 06:42:06 UTC 2017
pkgbase = s
pkgdesc = Web search from the terminal. Supports over 50 providers including google, github, and stackoverflow.
pkgver = 0.5.10
- pkgrel = 0
+ pkgrel = 1
url = http://github.com/zquestz/s
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = s
options = !strip
options = !emptydirs
source = https://github.com/zquestz/s/archive/v0.5.10.tar.gz
- sha256sums = 7dba775f7fdf6c8dc28ace8795e8f57c0b7dd6148f14fe4b17c5a4eb46b675ec
+ sha256sums = 8a5ba823d02f495dd1bb150882ddccd2bb082efff4c996b9b43e4cd5599d3df2
pkgname = s
diff --git a/PKGBUILD b/PKGBUILD
index eb530a230342..86a802aef018 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=s
pkgver=0.5.10
-pkgrel=0
+pkgrel=1
pkgdesc="Web search from the terminal. Supports over 50 providers including google, github, and stackoverflow."
arch=('i686' 'x86_64')
url="http://github.com/zquestz/s"
@@ -15,17 +15,21 @@ sha256sums=('8a5ba823d02f495dd1bb150882ddccd2bb082efff4c996b9b43e4cd5599d3df2')
_gourl="github.com/zquestz/${pkgname}"
build() {
- cd "${pkgname}-${pkgver}"
- export GOPATH="${srcdir}"
- export GOBIN="${srcdir}/bin"
- go get -v ${_gourl}
+ cd "$pkgname-$pkgver"
+
+ go build .
}
package() {
- install -Dm 775 "${srcdir}/bin/${pkgname}" \
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm 775 "$pkgname-$pkgver" \
"${pkgdir}/usr/bin/${pkgname}"
- install -Dm 644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" \
+ install -Dm 644 "LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${pkgname}-${pkgver}/autocomplete/s-completion.bash" \
+ install -Dm 644 "autocomplete/s-completion.bash" \
"${pkgdir}/usr/share/bash-completion/completions/s"
}