summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2018-10-05 22:13:02 +0200
committerGFdevelop2018-10-05 22:13:02 +0200
commitd24241f96411968fc1766cad9744fbd72e27af96 (patch)
tree5afa20dba257413f18301b1455d0117fcdc8e14e
downloadaur-d24241f96411968fc1766cad9744fbd72e27af96.tar.gz
renamed package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..880004838657
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = s2argv-execs-git
+ pkgdesc = s2argv converts a command string into an argv array for execv*, execs is like execv taking a string instead of an argv
+ pkgver = r34.c51c856
+ pkgrel = 1
+ url = https://github.com/rd235/s2argv-execs
+ arch = any
+ groups = view-os
+ license = GPL2
+ provides = s2argv-execs
+ replaces = libs2argv-execs
+ source = git+https://github.com/rd235/s2argv-execs.git
+ md5sums = SKIP
+
+pkgname = s2argv-execs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecbe1ad971ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+# Contributor: Antonio Cardace <antonio@cardace.it>
+
+_pkgname="s2argv-execs"
+
+pkgname="$_pkgname-git"
+pkgver=r34.c51c856
+pkgrel=1
+pkgdesc="s2argv converts a command string into an argv array for execv*, execs is like execv taking a string instead of an argv"
+arch=('any')
+url="https://github.com/rd235/$_pkgname"
+license=('GPL2')
+groups=('view-os')
+#~ depends=('')
+provides=("$_pkgname")
+replaces=("lib$_pkgname")
+source=("git+https://github.com/rd235/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ autoreconf -if
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}