summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrice Aneche2018-01-18 11:48:44 -0500
committerFabrice Aneche2018-01-18 11:48:44 -0500
commit940a57bfed307df31a597862afcd07279efd6c0d (patch)
treea28db5ff0b80695efdab1d90b2b311f654ce4822
downloadaur-940a57bfed307df31a597862afcd07279efd6c0d.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cddc74d4e74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = s2geometry-git
+ pkgdesc = Computational geometry and spatial indexing on the sphere
+ pkgver = r136
+ pkgrel = 1
+ url = https://s2geometry.io/
+ arch = i686
+ arch = x86_64
+ license = APACHE2
+ makedepends = git
+ makedepends = cmake
+ depends = openssl-1.0
+ depends = gflags
+ depends = google-glog
+ depends = python
+ source = git+https://github.com/google/s2geometry.git
+ sha256sums = SKIP
+
+pkgname = s2geometry-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a18062380a06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Fabrice aneche <akh at nobugware dot com>
+
+pkgname=s2geometry-git
+pkgver=r136
+pkgrel=1
+pkgdesc="Computational geometry and spatial indexing on the sphere"
+arch=('i686' 'x86_64')
+url="https://s2geometry.io/"
+license=('APACHE2')
+depends=('openssl-1.0' 'gflags' 'google-glog' 'python')
+makedepends=('git' 'cmake')
+source=("git+https://github.com/google/s2geometry.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/s2geometry"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd "$srcdir/s2geometry"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DOPENSSL_INCLUDE_DIR="/usr/include/openssl-1.0" -DOPENSSL_SSL_LIBRARY="/usr/lib/openssl-1.0/libssl.so" -DOPENSSL_CRYPTO_LIBRARY="/usr/lib/openssl-1.0/libcrypto.so" ..
+ make
+}
+
+package() {
+ cd "$srcdir/s2geometry/build"
+ make DESTDIR="$pkgdir/" install
+ SITE_PACKAGE=`python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())"`
+ mkdir -p "$pkgdir/$SITE_PACKAGE"
+ install -m 644 python/pywraps2.py "$pkgdir/$SITE_PACKAGE/pywraps2.py"
+ install -m 644 python/_pywraps2.so "$pkgdir/$SITE_PACKAGE/_pywraps2.so"
+ rm $pkgdir/usr/share/python/pywraps2.py
+ rm $pkgdir/usr/share/python/_pywraps2.so
+ rmdir $pkgdir/usr/share/python
+ rmdir $pkgdir/usr/share
+}
+