summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrice Aneche2018-05-13 11:17:20 -0400
committerFabrice Aneche2018-05-13 11:17:20 -0400
commiteff854b04424e285922cea41e41aeb09eb7ffd20 (patch)
tree8d2c1ba26f271245212e0a3ae479f2827dc65201
parent940a57bfed307df31a597862afcd07279efd6c0d (diff)
downloadaur-eff854b04424e285922cea41e41aeb09eb7ffd20.tar.gz
get rid of openssl-1.0 dep, update to recent commits
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a18062380a06..c9637c04d30c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Fabrice aneche <akh at nobugware dot com>
pkgname=s2geometry-git
-pkgver=r136
+pkgver=r233
pkgrel=1
pkgdesc="Computational geometry and spatial indexing on the sphere"
arch=('i686' 'x86_64')
url="https://s2geometry.io/"
license=('APACHE2')
-depends=('openssl-1.0' 'gflags' 'google-glog' 'python')
+depends=('openssl' 'python' 'gtest')
makedepends=('git' 'cmake')
source=("git+https://github.com/google/s2geometry.git")
sha256sums=('SKIP')
@@ -21,7 +21,7 @@ build() {
cd "$srcdir/s2geometry"
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DOPENSSL_INCLUDE_DIR="/usr/include/openssl-1.0" -DOPENSSL_SSL_LIBRARY="/usr/lib/openssl-1.0/libssl.so" -DOPENSSL_CRYPTO_LIBRARY="/usr/lib/openssl-1.0/libcrypto.so" ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}