summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-08 11:05:18 +0300
committerDimitris Kiziridis2020-04-08 11:05:18 +0300
commit03f5fbccd5269a21eb796034b29f4671620d2192 (patch)
tree3b103493545e09e9f75233c458c73e8cc5c278a8
downloadaur-03f5fbccd5269a21eb796034b29f4671620d2192.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d84743f1e26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = s3-edit-bin
+ pkgdesc = Edit directly a file on Amazon S3 in CLI
+ pkgver = 0.0.13
+ pkgrel = 1
+ url = https://github.com/tsub/s3-edit
+ arch = x86_64
+ license = MIT
+ provides = s3-edit
+ source = https://github.com/tsub/s3-edit/releases/download/v0.0.13/s3-edit_0.0.13_linux_amd64.tar.gz
+ md5sums = e6717f9c2c905f376d6450fad4979d33
+
+pkgname = s3-edit-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d92340ca5c8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=s3-edit-bin
+pkgver=0.0.13
+pkgrel=1
+pkgdesc='Edit directly a file on Amazon S3 in CLI'
+arch=('x86_64')
+url="https://github.com/tsub/s3-edit"
+license=('MIT')
+provides=('s3-edit')
+source=("${url}/releases/download/v${pkgver}/s3-edit_${pkgver}_linux_amd64.tar.gz")
+md5sums=('e6717f9c2c905f376d6450fad4979d33')
+
+package() {
+ install -Dm755 "${srcdir}"/s3-edit "${pkgdir}/usr/bin/s3-edit"
+ install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/s3-edit/LICENSE"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file