summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2024-03-30 02:50:59 +0700
committerKonstantin Shalygin2024-03-30 02:50:59 +0700
commit6e504a9308e09075817aeda2b8829608462635df (patch)
tree42efa7c133ac40f2b9500a2052e8712656361314
parent3a4f27a8f71bd5ea9713407f805bfd82352e59e8 (diff)
downloadaur-6e504a9308e09075817aeda2b8829608462635df.tar.gz
Fixes for compat with latest go/makepkg packages
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cca00e41fbae..4e1873b4476f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = s3_exporter
pkgdesc = Exports Prometheus metrics about S3 buckets and objects
pkgver = 0.6.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/qaoru/s3_exporter
arch = x86_64
arch = aarch64
license = Apache 2.0
makedepends = go
- options = !lto
backup = etc/conf.d/prometheus-s3-exporter
source = https://github.com/qaoru/s3_exporter/archive/refs/tags/v0.6.1.tar.gz
source = prometheus-s3-exporter
diff --git a/PKGBUILD b/PKGBUILD
index e56b1cd27700..7de39eba205d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,9 @@
pkgbase='s3_exporter'
pkgname='prometheus-s3-exporter'
pkgver='0.6.1'
-pkgrel='4'
+pkgrel='5'
pkgdesc='Exports Prometheus metrics about S3 buckets and objects'
arch=('x86_64' 'aarch64')
-options=(!lto)
_uri='github.com/qaoru'
url="https://${_uri}/${pkgbase}"
license=('Apache 2.0')
@@ -38,12 +37,12 @@ build() {
-trimpath \
-mod="readonly" \
-modcacherw \
- -ldflags "-linkmode external -extldflags ${LDFLAGS} \
+ -ldflags "-linkmode external -extldflags '${LDFLAGS}' \
-X github.com/prometheus/common/version.Version=${pkgver} \
-X github.com/prometheus/common/version.Revision=${pkgrel} \
-X github.com/prometheus/common/version.Branch=tarball \
-X github.com/prometheus/common/version.BuildUser=$(whoami)@$(hostnamectl hostname) \
- -X github.com/prometheus/common/version.BuildDate=$(date -d@"$SOURCE_DATE_EPOCH" +%Y%m%d-%H:%M:%S)"
+ -X github.com/prometheus/common/version.BuildDate=$(date -u '+%Y%m%d-%H:%M:%S' --date=@${SOURCE_DATE_EPOCH})"
}
package() {