summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam J. Bowman2016-04-29 11:47:50 -0400
committerWilliam J. Bowman2016-04-29 11:47:50 -0400
commit22d1a3bd84057ffbe73768038de06cbe9eed5f67 (patch)
tree253525c73e4043df28e960e19db0d8951835ce74
downloadaur-22d1a3bd84057ffbe73768038de06cbe9eed5f67.tar.gz
Adapted s3ql PKGBUILD to build from source
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0aa2e0eeac56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Fri Apr 29 15:47:20 UTC 2016
+pkgbase = s3ql-hg
+ pkgdesc = A full-featured file system for online data storage.
+ pkgver = r2760.bd156222419a
+ pkgrel = 2
+ url = https://bitbucket.org/nikratio/s3ql/overview
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc
+ makedepends = cython
+ makedepends = python-sphinx
+ depends = python
+ depends = python-apsw
+ depends = python-crypto
+ depends = python-defusedxml
+ depends = python-dugong>=3.2
+ depends = python-llfuse>=0.43
+ depends = python-requests
+ provides = s3ql
+ conflicts = s3ql
+ source = s3ql::hg+https://bitbucket.org/nikratio/s3ql
+ md5sums = SKIP
+
+pkgname = s3ql-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea726f64b4fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: William J. Bowman <aur@williamjbowman.com>
+
+_pkgname=s3ql
+pkgname=s3ql-hg
+pkgver=r2760.bd156222419a
+pkgrel=2
+pkgdesc="A full-featured file system for online data storage."
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/nikratio/s3ql/overview"
+license=('GPL3')
+depends=('python' 'python-apsw' 'python-crypto' 'python-defusedxml' 'python-dugong>=3.2'
+ 'python-llfuse>=0.43' 'python-requests')
+makedepends=('gcc' 'cython' 'python-sphinx')
+source=(s3ql::hg+https://bitbucket.org/nikratio/s3ql)
+md5sums=('SKIP')
+provides=('s3ql')
+conflicts=('s3ql')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ python setup.py build_cython
+ python setup.py build_ext --inplace
+ python setup.py build_sphinx
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -d -m 755 "$pkgdir/usr/share/doc/$_pkgname"
+ install -m 744 doc/manual.pdf "$pkgdir/usr/share/doc/$_pkgname/manual.pdf"
+
+ # Install the text versions of the docs and contrib. These can be recursive, so
+ # `install' isn't particularly useful.
+ cp -r contrib rst "$pkgdir/usr/share/doc/$_pkgname/"
+ chown -R root:root "$pkgdir/usr/share/doc/$_pkgname/"
+ find "$pkgdir/usr/share/doc/$_pkgname" -type f -exec chmod 'g-w,g+r,o-w,o+r' '{}' ';'
+}