summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Petrescu2017-09-20 17:42:43 -0400
committerAdrian Petrescu2017-09-20 17:43:04 -0400
commit14e9415a505a763e4464af044f730b1614d8e7b8 (patch)
treef561e720fe055c2308424e48234dccd8655c03c9
downloadaur-14e9415a505a763e4464af044f730b1614d8e7b8.tar.gz
Initial PKGBUILD for Sabaki 0.31.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--sabaki.desktop11
-rw-r--r--sabaki.install12
-rw-r--r--sabaki.xml58
5 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6407262bb372
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sabaki
+ pkgdesc = An elegant SGF editor for the game of Go
+ pkgver = 0.31.3
+ pkgrel = 1
+ url = http://sabaki.yichuanshen.de/
+ install = sabaki.install
+ arch = any
+ license = MIT
+ makedepends = npm
+ source = https://github.com/yishn/Sabaki/archive/v0.31.3.tar.gz
+ source = sabaki.desktop
+ source = sabaki.xml
+ md5sums = cf374e056f2763585821c9535eef9f61
+ md5sums = b39f3b91292cb3983124bd38035fbd8e
+ md5sums = efbd547e892c7781a5ece702d389dd9e
+
+pkgname = sabaki
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b80e4f65728
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Adrian Petrescu <apetresc@gmail.com>
+# Maintainer: Adrian Petrescu <apetresc@gmail.com>
+
+pkgname=sabaki
+pkgver=0.31.3
+pkgrel=1
+pkgdesc='An elegant SGF editor for the game of Go'
+arch=('any')
+url='http://sabaki.yichuanshen.de/'
+license=('MIT')
+makedepends=('npm')
+install=${pkgname}.install
+source=("https://github.com/yishn/Sabaki/archive/v${pkgver}.tar.gz"
+ "${pkgname}.desktop"
+ 'sabaki.xml')
+md5sums=('cf374e056f2763585821c9535eef9f61'
+ 'b39f3b91292cb3983124bd38035fbd8e'
+ 'efbd547e892c7781a5ece702d389dd9e')
+
+build() {
+ cd $srcdir/Sabaki-$pkgver
+
+ npm install --cache "${srcdir}/npm-cache"
+ npm run build
+}
+
+check() {
+ cd $srcdir/Sabaki-$pkgver
+ npm test
+}
+
+package() {
+ mkdir $pkgdir/opt
+
+ cp -r $srcdir/Sabaki-$pkgver/dist/linux-unpacked $pkgdir/opt/Sabaki
+ install -Dm644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -Dm644 ${srcdir}/${pkgname}.xml ${pkgdir}/usr/share/mime/packages/${pkgname}.xml
+}
diff --git a/sabaki.desktop b/sabaki.desktop
new file mode 100644
index 000000000000..2f3d34c5a2f2
--- /dev/null
+++ b/sabaki.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Sabaki
+GenericName=SGF Editor (Go)
+Comment=An elegant Go/Baduk/Weiqi board and SGF editor for a more civilized age.
+Exec=/opt/Sabaki/sabaki %U
+Terminal=false
+Type=Application
+Icon=sabaki
+Categories=Game;
+MimeType=application/x-go-sgf;
+
diff --git a/sabaki.install b/sabaki.install
new file mode 100644
index 000000000000..ece70b0199e4
--- /dev/null
+++ b/sabaki.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database /usr/share/mime > /dev/null 2>&1
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/sabaki.xml b/sabaki.xml
new file mode 100644
index 000000000000..fc3449cf4df3
--- /dev/null
+++ b/sabaki.xml
@@ -0,0 +1,58 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-go-sgf">
+
+ <comment>SGF record</comment>
+ <comment xml:lang="ar">تسجيلة SGF</comment>
+ <comment xml:lang="be@latin">Zapisanaja hulnia SGF</comment>
+ <comment xml:lang="bg">Запис — SGF</comment>
+ <comment xml:lang="ca">registre SGF</comment>
+ <comment xml:lang="cs">nahrávka SGF</comment>
+ <comment xml:lang="da">SGF-optagelse</comment>
+ <comment xml:lang="de">SGF-Aufzeichnung</comment>
+ <comment xml:lang="el">Εγγραφή SGF</comment>
+ <comment xml:lang="en_GB">SGF record</comment>
+ <comment xml:lang="es">grabación SGF</comment>
+ <comment xml:lang="eu">SGF erregistroa</comment>
+ <comment xml:lang="fi">SGF-nauhoitus</comment>
+ <comment xml:lang="fo">SGF met</comment>
+ <comment xml:lang="fr">partie SGF</comment>
+ <comment xml:lang="ga">taifead SGF</comment>
+ <comment xml:lang="gl">Grabación SGF</comment>
+ <comment xml:lang="he">הקלטת SGF</comment>
+ <comment xml:lang="hr">SGF zapis</comment>
+ <comment xml:lang="hu">SGF pontszám</comment>
+ <comment xml:lang="ia">Partita SGF</comment>
+ <comment xml:lang="id">Catatan SGF</comment>
+ <comment xml:lang="it">Registrazione SGF</comment>
+ <comment xml:lang="ja">SGF レコード</comment>
+ <comment xml:lang="kk">SGF жазбасы</comment>
+ <comment xml:lang="ko">SGF 기록 파일</comment>
+ <comment xml:lang="lt">SGF įrašas</comment>
+ <comment xml:lang="lv">SGF ieraksts</comment>
+ <comment xml:lang="nb">SGF-oppføring</comment>
+ <comment xml:lang="nl">SGF-record</comment>
+ <comment xml:lang="nn">SGF-logg</comment>
+ <comment xml:lang="oc">partida SGF</comment>
+ <comment xml:lang="pl">Zapis gry SGF</comment>
+ <comment xml:lang="pt">gravação SGF</comment>
+ <comment xml:lang="pt_BR">Gravação SGF</comment>
+ <comment xml:lang="ro">Înregistrare SGF</comment>
+ <comment xml:lang="ru">запись SGF</comment>
+ <comment xml:lang="sk">Záznam SGF</comment>
+ <comment xml:lang="sl">Datoteka shranjene igre SGF</comment>
+ <comment xml:lang="sq">Regjistrim SGF</comment>
+ <comment xml:lang="sr">СГФ запис</comment>
+ <comment xml:lang="sv">SGF-protokoll</comment>
+ <comment xml:lang="tr">SGF kaydı</comment>
+ <comment xml:lang="uk">запис SGF</comment>
+ <comment xml:lang="vi">Mục ghi SGF</comment>
+ <comment xml:lang="zh_CN">SGF 记录</comment>
+ <comment xml:lang="zh_TW">SGF 紀錄</comment>
+ <acronym>SGF</acronym>
+ <expanded-acronym>Smart Game Format</expanded-acronym>
+ <generic-icon name="text-x-generic"/>
+ <glob pattern="*.sgf"/>
+ <sub-class-of type="text/plain"/>
+ </mime-type>
+</mime-info>