summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-09 00:59:17 +0800
committerzxp198210052023-09-09 00:59:17 +0800
commitaf5e1c4b0c40ffa208e60d3674d40e0795a756ca (patch)
tree814eb2f0549cc4f5f5023d451fd50e51198a4c68
downloadaur-af5e1c4b0c40ffa208e60d3674d40e0795a756ca.tar.gz
update to 2.1.0
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD29
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..802fe63c1cd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = saberfy
+ pkgdesc = Application for match and import your Spotify favorite songs to BeatSaber
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/LoliE1ON/Saberfy
+ arch = x86_64
+ license = MIT
+ makedepends = gendesk
+ makedepends = npm>=8
+ makedepends = nodejs>=16
+ depends = mesa
+ depends = nss
+ depends = libx11
+ depends = glib2
+ depends = gdk-pixbuf2
+ depends = dbus
+ depends = at-spi2-core
+ depends = libxrandr
+ depends = libxext
+ depends = libxcb
+ depends = libxfixes
+ depends = gtk3
+ depends = glibc
+ depends = libxdamage
+ depends = libxkbcommon
+ depends = cairo
+ depends = alsa-lib
+ depends = expat
+ depends = libdrm
+ depends = gcc-libs
+ depends = nspr
+ depends = libxcomposite
+ depends = libcups
+ depends = pango
+ provides = saberfy
+ conflicts = saberfy
+ source = saberfy-2.1.0.tar.gz::https://github.com/LoliE1ON/Saberfy/archive/refs/tags/v2.1.0.tar.gz
+ sha256sums = 286f7e66f345d9b62d7b8fd1ec06e26911009907b6a1e91cafc6e9cfb0a7dfbf
+
+pkgname = saberfy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa0d6020989d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=saberfy
+_pkgname=Saberfy
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Application for match and import your Spotify favorite songs to BeatSaber"
+arch=('x86_64')
+url="https://github.com/LoliE1ON/Saberfy"
+license=('MIT')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+depends=('mesa' 'nss' 'libx11' 'glib2' 'gdk-pixbuf2' 'dbus' 'at-spi2-core' 'libxrandr' 'libxext' 'libxcb' 'libxfixes' 'gtk3' \
+ 'glibc' 'libxdamage' 'libxkbcommon' 'cairo' 'alsa-lib' 'expat' 'libdrm' 'gcc-libs' 'nspr' 'libxcomposite' 'libcups' 'pango')
+makedepends=('gendesk' 'npm>=8' 'nodejs>=16')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('286f7e66f345d9b62d7b8fd1ec06e26911009907b6a1e91cafc6e9cfb0a7dfbf')
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ npm install
+ npm run package
+}
+package() {
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}
+ cp -r "${srcdir}/${_pkgname}-${pkgver}/out/${_pkgname}-linux-x64/"* "${pkgdir}/opt/${pkgname%-bin}"
+ ln -sf "/opt/${pkgname%-bin}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ gendesk -f -n --categories "Utility" --name "${_pkgname}" --exec "${pkgname} --no-sandbox %U"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/LICENSE.md" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file