summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Gallet2024-03-25 14:56:15 +0100
committerRomain Gallet2024-03-25 15:56:16 +0100
commitcf41af768b6d6ff73bcc2a1421e4d879ce2d981b (patch)
tree9e1dabe92cb5c5bb0863c539384fa5010c0380e1
parent508e979ae8f4fbe498302f23acbfb30d51f253c7 (diff)
downloadaur-cf41af768b6d6ff73bcc2a1421e4d879ce2d981b.tar.gz
Separate directories to each services
-rw-r--r--PKGBUILD1
-rw-r--r--Readme.md11
-rw-r--r--sabnzbd-docker-update.service1
-rw-r--r--sabnzbd-docker-update.timer2
4 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbd9ac1411c3..53c0e56e4375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,6 +5,7 @@ pkgver=0.3
pkgname=sabnzbd-docker
pkgrel=2
pkgdesc='Convenience launch service for Sabnzd, Nzbhydra2 and Sonarr in docker'
+url="https://github.com/grumlimited/sabnzbd-docker"
arch=('x86_64')
license=('MIT')
groups=()
diff --git a/Readme.md b/Readme.md
index 1fb7649868c6..308989533e31 100644
--- a/Readme.md
+++ b/Readme.md
@@ -4,6 +4,11 @@ Sabnzbd-docker
`sabnzbd-docker` is a service unit that starts `sabnzbd`, `nzbhydra2` and `sonarr` in their respective docker
containers.
+The services are provided as-is by linuxserver.io, direct from docker hub:
+* [sabnzbd](https://hub.docker.com/r/linuxserver/sabnzbd)
+* [nzbhydra2](https://hub.docker.com/r/linuxserver/nzbhydra2)
+* [sonarr](https://hub.docker.com/r/linuxserver/sonarr)
+
## Configuration
1. Create a user config file at `~/.docker-sabnzbd.env` with the following content:
@@ -14,8 +19,9 @@ containers.
NZBHYDRA2_PATH_PREFIX = /path/to/prefix
SONARR_PATH_PREFIX = /path/to/prefix
- For example, you can run it with something like:
-
+ <details>
+ For example, you can run it with something like:
+
cat ~/.docker-sabnzbd.env
TZ=Europe/Madrid
@@ -25,6 +31,7 @@ containers.
SABNZBD_PATH_DOWNLOADS=/data/banjo/Downloads # downloads will go one level up
NZBHYDRA2_PATH_PREFIX=/data/banjo/Downloads/nzbhydra2 # config, logs and everything
+ </details>
2. Create the following directories (for services you choose to run):
diff --git a/sabnzbd-docker-update.service b/sabnzbd-docker-update.service
index 52a227dad8af..e2308f3d4323 100644
--- a/sabnzbd-docker-update.service
+++ b/sabnzbd-docker-update.service
@@ -11,4 +11,3 @@ Environment="PUID=%U"
Environment="PGID=%G"
Type=oneshot
ExecStart=docker compose -f /opt/docker-sabnzbd/docker-compose.yaml pull
-
diff --git a/sabnzbd-docker-update.timer b/sabnzbd-docker-update.timer
index 4a679c226558..000fc11b422a 100644
--- a/sabnzbd-docker-update.timer
+++ b/sabnzbd-docker-update.timer
@@ -1,5 +1,5 @@
[Unit]
-Description=Run sabnzbd-docker update daily and on boot
+Description=Run sabnzbd-docker-update.service daily and on boot
After=docker.service
[Timer]