summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGereon Schomber2015-10-28 17:55:35 +0100
committerGereon Schomber2015-10-28 17:55:35 +0100
commit5bc251a7c3979c6319578d7fa1862a173e0510e3 (patch)
tree4ccac09bf694d5b34b9edb8f46eabee4730c0393
parent36a18d11eaf025176faadf0d7c89cab1331bbb8b (diff)
downloadaur-5bc251a7c3979c6319578d7fa1862a173e0510e3.tar.gz
stole changes from sabnzbd
-rw-r--r--.SRCINFO34
-rwxr-xr-xPKGBUILD89
-rwxr-xr-xsabnzbd.service2
-rwxr-xr-xsabnzbd.sh2
4 files changed, 55 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73969344c8e2..41b3b94d0a3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,28 @@
pkgbase = sabnzbd-git
pkgdesc = A web-interface based binary newsgrabber with NZB file support.
- pkgver = 0.7.20.r0.g1df2943
+ pkgver = 0.7.0.r1013.g56a89ce
pkgrel = 1
url = http://www.sabnzbd.org/
install = sabnzbd.install
arch = any
license = GPL
makedepends = git
+ depends = curl
depends = par2cmdline
depends = python2
depends = python2-cheetah
- depends = python2-feedparser
depends = python2-yenc
- depends = python2-pyopenssl
- depends = python2-gntp-git
+ depends = sqlite
depends = unrar
depends = unzip
- depends = sqlite
- depends = curl
- depends = zip
optdepends = xdg-utils: registration of .nzb files
optdepends = python2-feedparser: rss support
optdepends = python2-pyopenssl: ssl support
- provides = sabnzbd
conflicts = sabnzbd
conflicts = sabnzbd-bzr
conflicts = sabnzbd-develop-git
- replaces = sabnzbd-bzr
backup = etc/conf.d/sabnzbd
- source = git://github.com/sabnzbd/sabnzbd.git
+ source = git+https://github.com/sabnzbd/sabnzbd.git
source = sabnzbd.sh
source = sabnzbd.init
source = sabnzbd.confd
@@ -38,16 +32,16 @@ pkgbase = sabnzbd-git
source = sab2_64.png
source = x-nzb.xml
source = sabnzbd.service
- sha1sums = SKIP
- sha1sums = 04f871831cff6d986562a317eccf0f7d15bcf0ab
- sha1sums = d75132711c2abc21a75f7331efdf0e60d1917a38
- sha1sums = f9516105cf5a843ace52c92e7afcc5575507ecfc
- sha1sums = 72e985c195c93680cea3ae095dd4b02cbcf534db
- sha1sums = ffa58afabd773f7669070ef3597a90dbece3f045
- sha1sums = a77d34fd2222f060d77d121d56bbb94c85cf3f09
- sha1sums = 92c17637b360bb938b7000ea0c2dc81178ede130
- sha1sums = fd607d2431583320a8233cced780ed98aa074c4e
- sha1sums = fd35834076158e6d6455e89572fd2840c0b44675
+ sha256sums = SKIP
+ sha256sums = 411738ad4dcd761daeda3a97aedfbe39c71f70d7f91c29765f85fb2a5942522d
+ sha256sums = 35c7ec1bdaadeb1db3c0794254f99e8e44323ef1665d5f4ae2832d5367bd937c
+ sha256sums = 29190e47cf3140053b000b1bbc9a1f8f5a20e30db19fa065c03576bb5f8e15eb
+ sha256sums = 6ffe460bebea63faea39e1131131711fdfa3f744fee129f0cc2b3dffff261289
+ sha256sums = baea3351a40551a63b90b4a4c32719d4c27b5fff596e74e4a91f289964960eb6
+ sha256sums = 7fec4494a04ffd6a94644c8ef499ec1c92998a613b1fde5c3a46f38c53dfbc43
+ sha256sums = 099d625d6efc9e69e7c6a2833221928fb19e9e356e3aa8341c36ffdc281e567d
+ sha256sums = f53261d7578c67fb9fd6a639df94cd53604bcf37b9b03a926cb03e5214b496fe
+ sha256sums = 29e83913b7f66cb5ade8ab6682754c975323fc9905451a1e7147e04dc6ddcc12
pkgname = sabnzbd-git
diff --git a/PKGBUILD b/PKGBUILD
index 46fbf41b3fb3..0488f78f3bdb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,22 @@
# Contributor: dryes <joswiseman@gmail>
# Contributor: Revelation60, Lucky <https://aur.archlinux.org/packages.php?ID=13691>
# Contributor: Gordin <9ordin @t gmail dot com>
-_develop=true
-#_develop=false
pkgname="sabnzbd-git"
_gitname='sabnzbd'
-pkgver=1
+pkgver=0.7.0.r1013.g56a89ce
pkgrel=1
pkgdesc='A web-interface based binary newsgrabber with NZB file support.'
arch=('any')
url='http://www.sabnzbd.org/'
license=('GPL')
-depends=('par2cmdline' 'python2' 'python2-cheetah' 'python2-feedparser' 'python2-yenc' 'python2-pyopenssl' 'python2-gntp-git' 'unrar' 'unzip' 'sqlite' 'curl' 'zip')
+depends=("curl" "par2cmdline"
+ "python2" "python2-cheetah" "python2-yenc"
+ "sqlite" "unrar" "unzip")
makedepends=('git')
optdepends=("xdg-utils: registration of .nzb files"
"python2-feedparser: rss support"
"python2-pyopenssl: ssl support")
-backup=('etc/conf.d/sabnzbd')
-install=sabnzbd.install
-conflicts=('sabnzbd' 'sabnzbd-bzr' 'sabnzbd-develop-git')
-
-provides=('sabnzbd')
-replaces=('sabnzbd-bzr')
-source=("git://github.com/sabnzbd/sabnzbd.git$( $_develop && echo \#branch=develop)"
+source=("git+https://github.com/sabnzbd/sabnzbd.git"
'sabnzbd.sh'
'sabnzbd.init'
'sabnzbd.confd'
@@ -34,39 +28,34 @@ source=("git://github.com/sabnzbd/sabnzbd.git$( $_develop && echo \#branch=devel
'x-nzb.xml'
'sabnzbd.service'
)
+backup=('etc/conf.d/sabnzbd')
+install=sabnzbd.install
+conflicts=('sabnzbd' 'sabnzbd-bzr' 'sabnzbd-develop-git')
-prepare() {
- cd "${startdir}"
- if [ ! -d "bin" ]; then
- mkdir bin
- cd bin
- ln -s /usr/bin/python2 ./python
- fi
-}
+package() {
+ mkdir -p "${pkgdir}/opt/${_gitname}"
+ touch "${pkgdir}/opt/${_gitname}/${_gitname}.ini"
+ cp -r "${srcdir}/${_gitname}/"* "${pkgdir}/opt/${_gitname}"
-build() {
- export PATH="${startdir}"/bin:$PATH
- cd "${srcdir}/${_gitname}"
- python package.py source
-}
+ # remove Windows and OS X files
+ rm -r "${pkgdir}/opt/${_gitname}/win"
+ rm -r "${pkgdir}/opt/${_gitname}/osx"
-package() {
- mkdir -p "${pkgdir}/usr/share/doc/sabnzbd/examples/"
- cd "${srcdir}/${_gitname}/srcdist/"
- rm -rf win PKG-INFO Sample-PostProc.cmd
- mv licenses/ *.txt "${pkgdir}/usr/share/doc/sabnzbd/"
- mv Sample-PostProc.sh "${pkgdir}/usr/share/doc/sabnzbd/examples/"
- mv "${PWD}" "${pkgdir}/usr/share/sabnzbd/"
+ # Fix for issues with Python 3
+ find "${pkgdir}/opt/${_gitname}" -type f -exec sed -i 's/python/python2/g' {} \;
+ find "${pkgdir}/opt/${_gitname}" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/opt/${_gitname}" -type f -exec chmod 644 {} \;
+ chmod 755 "${pkgdir}/opt/${_gitname}/SABnzbd.py"
- install -Dm755 "${srcdir}/sabnzbd.sh" "${pkgdir}/usr/bin/sabnzbd"
- install -Dm755 "${srcdir}/sabnzbd.init" "${pkgdir}/etc/rc.d/sabnzbd"
- install -Dm644 "${srcdir}/sabnzbd.confd" "${pkgdir}/etc/conf.d/sabnzbd"
- install -Dm755 "${srcdir}/sabnzbd.desktop" "${pkgdir}/usr/share/applications/sabnzbd.desktop"
- install -Dm644 "${srcdir}/sabnzbd.service" "${pkgdir}/usr/lib/systemd/system/sabnzbd.service"
- install -Dm755 "${srcdir}/addnzb.sh" "${pkgdir}/usr/share/sabnzbd/addnzb.sh"
- install -Dm644 "${srcdir}/nzb-2.png" "${pkgdir}/usr/share/sabnzbd/nzb-2.png"
- install -Dm644 "${srcdir}/sab2_64.png" "${pkgdir}/usr/share/sabnzbd/sab2_64.png"
- install -Dm770 "${srcdir}/x-nzb.xml" "${pkgdir}/usr/share/sabnzbd/x-nzb.xml"
+ install -Dm755 "${srcdir}/${_gitname}.sh" "${pkgdir}/usr/bin/${_gitname}"
+ install -Dm644 "${srcdir}/${_gitname}.confd" "${pkgdir}/etc/conf.d/${_gitname}"
+ install -Dm644 "${srcdir}/${_gitname}.service" "${pkgdir}/usr/lib/systemd/system/${_gitname}.service"
+ install -Dm755 "${srcdir}/${_gitname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_gitname}.desktop"
+ install -Dm755 "${srcdir}/addnzb.sh" "${pkgdir}/opt/${_gitname}/addnzb.sh"
+ install -Dm644 "${srcdir}/nzb-2.png" "${pkgdir}/opt/${_gitname}/nzb-2.png"
+ install -Dm644 "${srcdir}/sab2_64.png" "${pkgdir}/opt/${_gitname}/sab2_64.png"
+ install -Dm770 "${srcdir}/x-nzb.xml" "${pkgdir}/opt/${_gitname}/x-nzb.xml"
}
pkgver() {
@@ -74,13 +63,13 @@ pkgver() {
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
-sha1sums=('SKIP'
- '04f871831cff6d986562a317eccf0f7d15bcf0ab'
- 'd75132711c2abc21a75f7331efdf0e60d1917a38'
- 'f9516105cf5a843ace52c92e7afcc5575507ecfc'
- '72e985c195c93680cea3ae095dd4b02cbcf534db'
- 'ffa58afabd773f7669070ef3597a90dbece3f045'
- 'a77d34fd2222f060d77d121d56bbb94c85cf3f09'
- '92c17637b360bb938b7000ea0c2dc81178ede130'
- 'fd607d2431583320a8233cced780ed98aa074c4e'
- 'fd35834076158e6d6455e89572fd2840c0b44675')
+sha256sums=('SKIP'
+ '411738ad4dcd761daeda3a97aedfbe39c71f70d7f91c29765f85fb2a5942522d'
+ '35c7ec1bdaadeb1db3c0794254f99e8e44323ef1665d5f4ae2832d5367bd937c'
+ '29190e47cf3140053b000b1bbc9a1f8f5a20e30db19fa065c03576bb5f8e15eb'
+ '6ffe460bebea63faea39e1131131711fdfa3f744fee129f0cc2b3dffff261289'
+ 'baea3351a40551a63b90b4a4c32719d4c27b5fff596e74e4a91f289964960eb6'
+ '7fec4494a04ffd6a94644c8ef499ec1c92998a613b1fde5c3a46f38c53dfbc43'
+ '099d625d6efc9e69e7c6a2833221928fb19e9e356e3aa8341c36ffdc281e567d'
+ 'f53261d7578c67fb9fd6a639df94cd53604bcf37b9b03a926cb03e5214b496fe'
+ '29e83913b7f66cb5ade8ab6682754c975323fc9905451a1e7147e04dc6ddcc12')
diff --git a/sabnzbd.service b/sabnzbd.service
index c1da198b8433..9890ebdd85ce 100755
--- a/sabnzbd.service
+++ b/sabnzbd.service
@@ -4,7 +4,7 @@ After=network.target
[Service]
Type=simple
-ExecStart=/bin/sh -c "python2 /usr/share/sabnzbd/SABnzbd.py -l0"
+ExecStart=/bin/sh -c "python2 /opt/sabnzbd/SABnzbd.py -l0"
User=sabnzbd
Group=sabnzbd
diff --git a/sabnzbd.sh b/sabnzbd.sh
index afbd95fd651f..ab7470322ff7 100755
--- a/sabnzbd.sh
+++ b/sabnzbd.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-python2 /usr/share/sabnzbd/SABnzbd.py -f "${HOME}/.sabnzbd.ini" "${@}"
+python2 /opt/sabnzbd/SABnzbd.py -f "${HOME}/.sabnzbd.ini" "${@}"