summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartiMcFly2016-08-19 15:34:38 +0200
committerMartiMcFly2016-08-19 15:34:38 +0200
commit8b88767ff074b631e7ee30637b08d0456bcfc1dd (patch)
tree4526f8619a83f0b01cccdfb6f6ec91b1b8d4ea9f
parent66ff6672520cf6c81f5d207753e670397aa5cf26 (diff)
downloadaur-8b88767ff074b631e7ee30637b08d0456bcfc1dd.tar.gz
update to zarafa 7.2.4
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--install23
3 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 727a8eab95d8..78603415fb94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Tue Aug 9 14:55:14 UTC 2016
+# Fri Aug 19 13:34:21 UTC 2016
pkgbase = sabre-zarafa
pkgdesc = provide a full CardDav backend for SabreDAV to connect with Zarafa groupware
pkgver = 0.23
- pkgrel = 95
+ pkgrel = 77
url = https://github.com/1afa/sabre-zarafa
install = install
arch = any
groups = zarafa
+ groups = kopano
license = AGPL3
makedepends = php-composer
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index cd3d13b49f35..557652b9f719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: MartiMcFly martimcfly@autorisation.de
+# Maintainer: MartiMcFly <martimcfly [at] autorisation.de>
pkgname=sabre-zarafa
-groups=('zarafa')
+groups=('zarafa'
+ 'kopano')
pkgver=0.23
-pkgrel=95
+pkgrel=77
pkgdesc="provide a full CardDav backend for SabreDAV to connect with Zarafa groupware"
arch=('any')
url="https://github.com/1afa/sabre-zarafa"
@@ -82,6 +83,6 @@ package() {
rm /tmp/composer.ini
# perform settings
- # => replace carddav_root_uri
- sed -i -e "s/\(CARDDAV_ROOT_URI', '\)\(.*\)\('.*$\)/\1\/carddav\3/" ${pkgdir}/etc/webapps/${pkgname}/config.example.inc.php
+ sed -i -e "s|\(CARDDAV_ROOT_URI', '\)\(.*\)\('.*$\)|\1/carddav\3|" ${pkgdir}/etc/webapps/${pkgname}/config.example.inc.php
+ sed -i -e "s|\(ZARAFA_SERVER', '\)\(.*\)\('.*$\)|\1file:///var/run/zarafad/server.sock\3|" ${pkgdir}/etc/webapps/${pkgname}/config.example.inc.php
}
diff --git a/install b/install
index 0d09933b09c2..7fbc5eddd850 100644
--- a/install
+++ b/install
@@ -1,6 +1,23 @@
+#!/bin/bash
+
+# care about existing files
+function installdir() {
+ local owner="$1"
+ local moddir="$2"
+ local modfile="$3"
+ local directory="$4"
+
+ mkdir -p "$directory"
+ find $directory -exec chown "$owner" {} \;
+ find $directory -type f -exec chmod "$modfile" {} \;
+ find $directory -type d -exec chmod "$moddir" {} \;
+}
+
+
post_install() {
- cp -n /etc/webapps/sabre-zarafa/config.example.inc.php /etc/webapps/sabre-zarafa/config.inc.php
- chown -R http:http /var/log/sabre-zarafa
- chown -R http:http /var/lib/sabre-zarafa
+ cp -n /etc/webapps/sabre-zarafa/config.example.inc.php /etc/webapps/sabre-zarafa/config.inc.php
+
+ installdir http:http 0700 0600 /var/log/sabre-zarafa
+ installdir http:http 0700 0600 /var/lib/sabre-zarafa
}