summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2019-09-02 23:48:21 +0200
committerHans-Nikolai Viessmann2019-09-02 23:48:21 +0200
commitcdd1f2187f06392c887d22ce560b83b3a3e21450 (patch)
tree76fa1d208d21ebe62d244cdbdfad69ee9a013d13
downloadaur-cdd1f2187f06392c887d22ce560b83b3a3e21450.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE.txt44
-rw-r--r--Makefile30
-rw-r--r--PKGBUILD71
4 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cbb6a6c9064
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sac-compiler-weekly
+ pkgdesc = Provides the compiler (sac2c) of the Single-Assignment C programming language (weekly build)
+ pkgver = 1.3.3.352
+ pkgrel = 1
+ url = http://www.sac-home.org/
+ arch = x86_64
+ license = custom:SAC
+ depends = gcc
+ depends = hwloc
+ depends = libutil-linux
+ depends = cuda
+ optdepends = sac-stdlib-weekly: StdLib for the SaC Compiler
+ source = http://www.sac-home.org/packages/weekly/Linux/1.3.3-352/sac2c-1.3.3-MijasCosta-352-g727db-omnibus.tar.gz
+ source = LICENSE.txt
+ source = Makefile
+ sha256sums = d73d69b7f9af388db953a92c16ebf8f78155b17a5ad559caa8a8b2767cb983e9
+ sha256sums = c7d6d43ee20a247fcdce954274f9ffd419bd92644af9ce09929b7bef54a33398
+ sha256sums = eb965cc10ff6d032627429b87c553c2eb962d92753a8e30cfebdf699d1f5504a
+
+pkgname = sac-compiler-weekly
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..53664aa3d530
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,44 @@
+---------------------------------------------------------------------------
+
+SAC - Single Assignment C
+
+---------------------------------------------------------------------------
+
+SAC COPYRIGHT NOTICE, LICENSE, AND DISCLAIMER
+
+(c) Copyright 1994 - 2019 by
+
+ SAC Development Team
+
+ web: http://www.sac-home.org
+ email: info@sac-home.org
+
+---------------------------------------------------------------------------
+
+The SAC compiler, the SAC standard library, and all accompanying
+software and documentation (in the following named this software)
+is developed by the SAC Development Team (in the following named
+the developer) which reserves all rights on this software.
+
+Permission to use this software is hereby granted free of charge
+for any non-profit purpose in a non-commercial environment, i.e. for
+educational or research purposes in a non-profit institute or for
+personal, non-commercial use. For this kind of use it is allowed to
+copy or redistribute this software under the condition that the
+complete distribution for a certain platform is copied or
+redistributed and this copyright notice, license agreement, and
+warranty disclaimer appears in each copy. ANY use of this software with
+a commercial purpose or in a commercial environment is not granted by
+this license.
+
+The developer disclaims all warranties with regard to this software,
+including all implied warranties of merchantability and fitness. In no
+event shall the developer be liable for any special, indirect or
+consequential damages or any damages whatsoever resulting from loss of
+use, data, or profits, whether in an action of contract, negligence, or
+other tortuous action, arising out of or in connection with the use or
+performance of this software. The entire risk as to the quality and
+performance of this software is with you. Should this software prove
+defective, you assume the cost of all servicing, repair, or correction.
+
+---------------------------------------------------------------------------
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..0209710b3873
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,30 @@
+# this makefile replaces the build script included with the .tar.gz
+# archive - the install script is not designed for 'packaging' use-cases
+
+CFLAGS+= -I. -DSHARED_LIB_EXT=\".so\"
+LDFLAGS+= -ldl
+
+.PHONY: all debug release
+
+all: debug release
+
+debug: CFLAGS += -DBUILD_TYPE_POSTFIX=\"_d\"
+debug: sac2c_d sac4c_d sac2tex_d
+
+release: CFLAGS += -DBUILD_TYPE_POSTFIX=\"_p\"
+release: sac2c_p sac4c_p sac2tex_p
+
+sac2c_%: sac2c.c sactools.h sacdirs_%.h
+ $(CC) $(CFLAGS) $< -o $@ $(LDFLAGS)
+
+sac4c_%: sac4c.c sactools.h sacdirs_%.h
+ $(CC) $(CFLAGS) $< -o $@ $(LDFLAGS)
+
+sac2tex_%: sac2tex.c sactools.h sacdirs_%.h
+ $(CC) $(CFLAGS) $< -o $@ $(LDFLAGS)
+
+sacdirs_d.h: sacdirs.h
+ @sed 's/SAC2C_POSTFIX "_p"/SAC2C_POSTFIX "_d"/' $^ > $@
+
+sacdirs_p.h: sacdirs.h
+ @sed 's/SAC2C_POSTFIX "_d"/SAC2C_POSTFIX "_p"/' $^ > $@
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b39cab45085
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
+# Contributors: SaC Development Team <info AT sac-home.org>
+
+pkgname=sac-compiler-weekly
+_version=1.3.3
+_changes=352
+_name=MijasCosta
+_commit=g727db
+pkgver="${_version}.${_changes}"
+pkgrel=1
+pkgdesc='Provides the compiler (sac2c) of the Single-Assignment C programming language (weekly build)'
+arch=('x86_64')
+url='http://www.sac-home.org/'
+license=('custom:SAC')
+depends=('gcc' 'hwloc' 'libutil-linux' 'cuda')
+optdepends=('sac-stdlib-weekly: StdLib for the SaC Compiler')
+#makedepends=('python' 'python-argparse') # XXX once sac-version-manager is running on python3
+source=("http://www.sac-home.org/packages/weekly/Linux/${_version}-${_changes}/sac2c-${_version}-${_name}-${_changes}-${_commit}-omnibus.tar.gz"
+ 'LICENSE.txt'
+ 'Makefile')
+sha256sums=('d73d69b7f9af388db953a92c16ebf8f78155b17a5ad559caa8a8b2767cb983e9'
+ 'c7d6d43ee20a247fcdce954274f9ffd419bd92644af9ce09929b7bef54a33398'
+ 'eb965cc10ff6d032627429b87c553c2eb962d92753a8e30cfebdf699d1f5504a')
+
+build () {
+ cd "$srcdir/src"
+
+ # build binaries
+ make -f "$srcdir/Makefile"
+}
+
+package() {
+ cd "$srcdir"
+
+ # install libraries
+ install -d "$pkgdir/usr/local"
+ cp -r share "$pkgdir/usr/local/"
+ cp -r include "$pkgdir/usr/local/"
+ cp -r lib "$pkgdir/usr/local/"
+ cp -r libexec "$pkgdir/usr/local/"
+
+ # install binaries
+ find "src" -type f -executable -exec cp {} "$pkgdir/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}" \;
+
+ # create symlinks
+ # XXX replace with sac-version-manager script (uses python2 with specific depends, I don't want to pull these in!)
+ install -d "$pkgdir/usr/local/bin"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac2c_d" "$pkgdir/usr/local/bin/sac2c_d"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac4c_d" "$pkgdir/usr/local/bin/sac4c_d"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac2tex_d" "$pkgdir/usr/local/bin/sac2tex_d"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac2c_p" "$pkgdir/usr/local/bin/sac2c_p"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac4c_p" "$pkgdir/usr/local/bin/sac4c_p"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac2tex_p" "$pkgdir/usr/local/bin/sac2tex_p"
+
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/saccc_p" "$pkgdir/usr/local/bin/saccc_p"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/saccc_d" "$pkgdir/usr/local/bin/saccc_d"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/csimt_p" "$pkgdir/usr/local/bin/csimt_p"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/csimt_d" "$pkgdir/usr/local/bin/csimt_d"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/csima_p" "$pkgdir/usr/local/bin/csima_p"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/csima_d" "$pkgdir/usr/local/bin/csima_d"
+
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac2c_p" "$pkgdir/usr/local/bin/sac2c"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac4c_p" "$pkgdir/usr/local/bin/sac4c"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/sac2tex_p" "$pkgdir/usr/local/bin/sac2tex"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/saccc_p" "$pkgdir/usr/local/bin/saccc"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/csimt_p" "$pkgdir/usr/local/bin/csimt"
+ ln -s "/usr/local/libexec/sac2c/${_version}-${_name}-${_changes}-${_commit}/csima_p" "$pkgdir/usr/local/bin/csima"
+
+ # install license file
+ install -Dm644 "${srcdir}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}