summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2021-01-16 18:33:02 +0200
committerMantas Mikulėnas2021-01-16 19:18:52 +0200
commit401bbfd49fa2d31196c3822a0b628e6b65553744 (patch)
treee01584be941e82a583a170551b83d517350c4ca3
parentc7096586785079df377b888902804debc084e57d (diff)
downloadaur-401bbfd49fa2d31196c3822a0b628e6b65553744.tar.gz
release 10.7.77 (untested)
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD77
-rw-r--r--sac-core.install11
3 files changed, 42 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f00fccfdd917..03e0fadb8778 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = sac-core
- pkgdesc = Safenet Authentication Client for Alladin eToken, stripped core package
- pkgver = 10.0.37
- pkgrel = 11
- url = https://data-protection-updates.gemalto.com/category/safenet-authentication-client/
- install = sac-core.install
+ pkgdesc = SafeNet Authentication Client for eToken 5110/5300 & IDPrime (core package with no GUI tools)
+ pkgver = 10.7.77
+ pkgrel = 1
+ url = https://cpl.thalesgroup.com/access-management/security-applications/authentication-client-token-management
arch = x86_64
license = custom
- makedepends = libarchive
depends = pcsclite
- depends = libusb-compat
- depends = openssh
- depends = nss
+ optdepends = sac-core-legacy: Support for eToken 32K/64K (CardOS 4.2)
+ source = https://installer.id.ee/media/etoken/SAC%2010.7%20Linux.zip
source = eToken.conf
+ sha256sums = 15c55b1faec11c460bd1b5a303a92b1667171d615b20967dccc753fcf8026051
sha256sums = 85b850b820610e029428e577ca0e48f6fb7b4148ae8d702ca20b191963046c6c
- source_x86_64 = https://storage.spidlas.cz/public/soft/safenet/SafenetAuthenticationClient-core-10.0.37-0_amd64.deb
- sha256sums_x86_64 = b4f8ffd030363693540bd494c3825ebd901937565cdd1c6455f95005571a27e5
pkgname = sac-core
-
diff --git a/PKGBUILD b/PKGBUILD
index bed591016c62..0b1c3d18baec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,44 @@
-pkgname='sac-core'
-pkgver='10.0.37'
-pkgrel='11'
-pkgdesc='Safenet Authentication Client for Alladin eToken, stripped core package'
-arch=('x86_64')
-depends=('pcsclite' 'libusb-compat' 'openssh' 'nss')
-makedepends=('libarchive')
-license=('custom')
-install=$pkgname.install
-url='https://data-protection-updates.gemalto.com/category/safenet-authentication-client/'
-source_x86_64=('https://storage.spidlas.cz/public/soft/safenet/SafenetAuthenticationClient-core-10.0.37-0_amd64.deb')
-sha256sums_x86_64=('b4f8ffd030363693540bd494c3825ebd901937565cdd1c6455f95005571a27e5')
-source+=('eToken.conf')
-sha256sums+=('85b850b820610e029428e577ca0e48f6fb7b4148ae8d702ca20b191963046c6c')
-
-build() {
- bsdtar -xf "$srcdir/data.tar.gz"
+pkgname=sac-core
+pkgver=10.7.77
+pkgrel=1
+pkgdesc='SafeNet Authentication Client for eToken 5110/5300 & IDPrime (core package with no GUI tools)'
+url='https://cpl.thalesgroup.com/access-management/security-applications/authentication-client-token-management'
+arch=(x86_64)
+depends=(pcsclite)
+optdepends=(
+ 'sac-core-legacy: Support for eToken 32K/64K (CardOS 4.2)'
+)
+license=(custom)
+source=('https://installer.id.ee/media/etoken/SAC%2010.7%20Linux.zip'
+ eToken.conf)
+sha256sums=('15c55b1faec11c460bd1b5a303a92b1667171d615b20967dccc753fcf8026051'
+ '85b850b820610e029428e577ca0e48f6fb7b4148ae8d702ca20b191963046c6c')
+
+prepare() {
+ ar x "GA - Build 77/Installation/withoutUI/DEB/safenetauthenticationclient-core_${pkgver}_amd64.deb"
+ bsdtar -xf data.tar.xz
}
package() {
- mkdir -p "$pkgdir/usr/lib/pcsc/drivers"
- cp -dpr --no-preserve=ownership "$srcdir/usr/share/eToken/drivers/aks-ifdh.bundle" "$pkgdir/usr/lib/pcsc/drivers"
- rm "$pkgdir/usr/lib/pcsc/drivers/aks-ifdh.bundle/Contents/Linux/readme.txt"
+ # Install libraries
+ install -dm755 "$pkgdir"/usr
+ cp -r usr/lib "$pkgdir"/usr/lib
- mkdir -p "$pkgdir/usr/lib"
- cp --no-preserve=ownership "$srcdir/lib/libeToken.so.10.0.37" "$pkgdir/usr/lib/libeToken.so.10.0.37"
- cp --no-preserve=ownership "$srcdir/lib/libcardosTokenEngine.so.10.0.37" "$pkgdir/usr/lib/libcardosTokenEngine.so.10.0.37"
+ # Create missing .so symlinks
+ ldconfig -N -r "$pkgdir"
- mkdir -p "$pkgdir/etc"
- cp "$srcdir/eToken.conf" "$pkgdir/etc/eToken.conf"
+ # PKCS#11 modules
+ install -dm755 "$pkgdir"/usr/lib/pkcs11
+ ln -s ../libeToken.so "$pkgdir"/usr/lib/pkcs11/
+ ln -s ../libIDPrimePKCS11.so "$pkgdir"/usr/lib/pkcs11/
- cd "$pkgdir/usr/lib/"
- ln -sf libeToken.so.10.0.37 libeTPkcs11.so
- ln -sf libeToken.so.10.0.37 libeToken.so.10.0
- ln -sf libeToken.so.10.0.37 libeToken.so.10
- ln -sf libeToken.so.10.0.37 libeToken.so
- ln -sf libcardosTokenEngine.so.10.0.37 libcardosTokenEngine.so.10.0
- ln -sf libcardosTokenEngine.so.10.0.37 libcardosTokenEngine.so.10
- ln -sf libcardosTokenEngine.so.10.0.37 libcardosTokenEngine.so
+ # Legacy name for the eToken PKCS#11 module -- not creating it here, since
+ # it's primarily associated with the old Alladin eToken and you should use
+ # sac-core-legacy for that.
+ #ln -s libeToken.so "$pkgdir"/usr/lib/libeTPkcs11.so
+ #ln -s ../libeToken.so "$pkgdir"/usr/lib/pkcs11/libeTPkcs11.so
- cd "$pkgdir/usr/lib/pcsc/drivers/aks-ifdh.bundle/Contents/Linux/"
- ln -sf libAksIfdh.so.10.0 libAksIfdh.so
- ln -sf libAksIfdh.so.10.0 libAksIfdh.so.10
+ install -Dm644 eToken.conf "$pkgdir"/etc/eToken.conf
}
-# To add eToken to Firefox eval output of this cmd:
-# find ~ -name secmod.db -type f -printf "modutil -dbdir %h -add eToken -libfile /usr/lib/libeToken.so -mechanisms RSA:DES -force\n"
-
-# To add eToken to Chromium run this cmd:
-# modutil -dbdir sql:.pki/nssdb/ -add "eToken" -libfile /usr/lib/libeToken.so
-# modutil -dbdir sql:.pki/nssdb/ -list
+# vim: ts=2:sw=2:et:
diff --git a/sac-core.install b/sac-core.install
deleted file mode 100644
index c547a6dffeb3..000000000000
--- a/sac-core.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- echo "Run 'sudo ldconfig && sudo systemctl restart pcscd.service' after (re)install"
-}
-
-post_upgrade() {
- echo "Run 'sudo ldconfig && sudo systemctl restart pcscd.service' after upgrade"
-}
-
-post_remove() {
- echo "Run 'sudo ldconfig && sudo systemctl restart pcscd.service' after remove"
-}