summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2019-09-02 23:58:31 +0200
committerHans-Nikolai Viessmann2019-09-02 23:58:31 +0200
commit83b5ce3d67336db1edad84be67b36741d0a703e1 (patch)
treecfb90f0376b4a5717b3a834fa1111fdab4d92d98
downloadaur-83b5ce3d67336db1edad84be67b36741d0a703e1.tar.gz
inital release
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE.txt44
-rw-r--r--PKGBUILD32
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93eb04cc8384
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sac-stdlib-weekly
+ pkgdesc = The standard library for the Single-Assignment C programming language (weekly build)
+ pkgver = 1.3.66
+ pkgrel = 1
+ url = http://www.sac-home.org/
+ arch = x86_64
+ license = custom:SAC
+ depends = sac-compiler-weekly==1.3.3.352
+ provides = sac-stdlib
+ conflicts = sac-stdlib
+ replaces = sac-stdlib
+ source = http://www.sac-home.org/packages/weekly/Linux/1.3.3-352/sac-stdlib-1.3-66-g58e8.tar.gz
+ source = LICENSE.txt
+ sha256sums = eda7d378723018f7276bc9b6c598761a961ba2647cc5b61cb3bd8e8f067cce04
+ sha256sums = c7d6d43ee20a247fcdce954274f9ffd419bd92644af9ce09929b7bef54a33398
+
+pkgname = sac-stdlib-weekly
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..53664aa3d530
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,44 @@
+---------------------------------------------------------------------------
+
+SAC - Single Assignment C
+
+---------------------------------------------------------------------------
+
+SAC COPYRIGHT NOTICE, LICENSE, AND DISCLAIMER
+
+(c) Copyright 1994 - 2019 by
+
+ SAC Development Team
+
+ web: http://www.sac-home.org
+ email: info@sac-home.org
+
+---------------------------------------------------------------------------
+
+The SAC compiler, the SAC standard library, and all accompanying
+software and documentation (in the following named this software)
+is developed by the SAC Development Team (in the following named
+the developer) which reserves all rights on this software.
+
+Permission to use this software is hereby granted free of charge
+for any non-profit purpose in a non-commercial environment, i.e. for
+educational or research purposes in a non-profit institute or for
+personal, non-commercial use. For this kind of use it is allowed to
+copy or redistribute this software under the condition that the
+complete distribution for a certain platform is copied or
+redistributed and this copyright notice, license agreement, and
+warranty disclaimer appears in each copy. ANY use of this software with
+a commercial purpose or in a commercial environment is not granted by
+this license.
+
+The developer disclaims all warranties with regard to this software,
+including all implied warranties of merchantability and fitness. In no
+event shall the developer be liable for any special, indirect or
+consequential damages or any damages whatsoever resulting from loss of
+use, data, or profits, whether in an action of contract, negligence, or
+other tortuous action, arising out of or in connection with the use or
+performance of this software. The entire risk as to the quality and
+performance of this software is with you. Should this software prove
+defective, you assume the cost of all servicing, repair, or correction.
+
+---------------------------------------------------------------------------
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd02f5bb20e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
+# Contributors: SaC Development Team <info AT sac-home.org>
+
+pkgname=sac-stdlib-weekly
+_version=1.3
+_changes=66
+_commit=g58e8
+_sac_version="1.3.3-352"
+pkgver="${_version}.${_changes}"
+pkgrel=1
+pkgdesc='The standard library for the Single-Assignment C programming language (weekly build)'
+arch=('x86_64')
+url='http://www.sac-home.org/'
+license=('custom:SAC')
+depends=("sac-compiler-weekly==1.3.3.352")
+provides=('sac-stdlib')
+replaces=('sac-stdlib')
+conflicts=('sac-stdlib')
+source=("http://www.sac-home.org/packages/weekly/Linux/${_sac_version}/sac-stdlib-${_version}-${_changes}-${_commit}.tar.gz"
+ 'LICENSE.txt')
+sha256sums=('eda7d378723018f7276bc9b6c598761a961ba2647cc5b61cb3bd8e8f067cce04'
+ 'c7d6d43ee20a247fcdce954274f9ffd419bd92644af9ce09929b7bef54a33398')
+
+package() {
+ cd "$srcdir/sac-stdlib-${_version}-${_changes}-${_commit}"
+
+ # install libraries
+ cp -r usr "$pkgdir/"
+
+ # install license file
+ install -Dm644 "${srcdir}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}