summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit54d8c0cb078bd8b206a4e98f0b0fc138a032d1d8 (patch)
treecb157b1762b0d09fbe57babb9416531221209156
downloadaur-54d8c0cb078bd8b206a4e98f0b0fc138a032d1d8.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--safekeep.install49
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5b950bc4883
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = safekeep
+ pkgdesc = A client/server backup system which enhances the power of rdiff-backup
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = http://safekeep.sourceforge.net
+ install = safekeep.install
+ arch = any
+ license = GPL
+ makedepends = asciidoc
+ makedepends = docbook-xsl
+ makedepends = xmlto
+ depends = python2
+ depends = rdiff-backup
+ depends = openssh
+ source = http://downloads.sourceforge.net/sourceforge/safekeep/safekeep-1.4.2.tar.gz
+ sha256sums = ab17c3b00248b99ba9015a75c0c816bf12f77108551f95da3de609112ab124dd
+
+pkgname = safekeep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4960ccfb81c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=safekeep
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="A client/server backup system which enhances the power of rdiff-backup"
+arch=('any')
+url="http://safekeep.sourceforge.net"
+license=('GPL')
+depends=('python2' 'rdiff-backup' 'openssh')
+makedepends=('asciidoc' 'docbook-xsl' 'xmlto')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('ab17c3b00248b99ba9015a75c0c816bf12f77108551f95da3de609112ab124dd')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ make docs
+}
+
+package () {
+ cd ${srcdir}/$pkgname-$pkgver
+
+#Python2 fix
+ sed -i 's_env python_env python2_' $pkgname
+
+ make DESTDIR=${pkgdir} install
+
+#installing files
+ install -D -m644 samples/sample.backup ${pkgdir}/etc/safekeep/backup.d/sample.backup
+ install -D -m644 samples/client-script-sample.sh ${pkgdir}/etc/safekeep/backup.d/client-script-sample.sh
+}
diff --git a/safekeep.install b/safekeep.install
new file mode 100644
index 000000000000..c15191407125
--- /dev/null
+++ b/safekeep.install
@@ -0,0 +1,49 @@
+post_install() {
+ /usr/sbin/groupadd safekeep 2>/dev/null || true
+ /usr/sbin/useradd -s /bin/bash -g safekeep -d /var/lib/safekeep -s /sbin/nologin \
+ -c "Used by SafeKeep to run and store backups." safekeep 2>/dev/null || true
+
+
+ if [ ! -d /var/lib/safekeep ]; then
+ mkdir /var/lib/safekeep
+ fi
+ chown -R safekeep:safekeep /var/lib/safekeep
+
+ cat << _EOF
+
+ NOTE: You will have to manually take care of a number of
+ steps such as installing the cron job script, creating the
+ safekeep user, and generating and deploying ssh keys on
+ the backup server machine.
+
+ To create a new user called "safekeep," issue:
+ useradd -g users -m -d /var/lib/safekeep -s /sbin/nologin
+ -c "Used by SafeKeep to run and store backups." safekeep
+
+ To install the cron job script, issue:
+ cp /usr/share/safekeep/safekeep.cron /etc/cron.daily/safekeep
+
+ Please see the following link for a quick setup example:
+ http://safekeep.sourceforge.net/documentation.shtml
+
+_EOF
+}
+
+post_remove() {
+ /usr/sbin/userdel safekeep
+ /usr/sbin/groupdel safekeep
+
+ cat << _EOF
+
+ NOTE: You will have to manually take care of a number of
+ steps such as removing the cron job script, removing the
+ safekeep user, and removing ssh keys.
+
+ To remove the user called "safekeep," issue:
+ userdel -r safekeep
+
+ To remove the cron job script, issue:
+ rm /etc/cron.daily/safekeep
+
+_EOF
+}