summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexdiaconescu2016-03-12 21:53:10 +0200
committeralexdiaconescu2016-03-12 21:53:10 +0200
commit902b19c9048a611db4e66522fcec39183aaf699d (patch)
tree8aef9a9ec8907a062477d186ee18562d2cfb8187
downloadaur-902b19c9048a611db4e66522fcec39183aaf699d.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD47
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb0cdf5afc71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Sat Mar 12 19:51:00 UTC 2016
+pkgbase = safeplugins-git
+ pkgdesc = Semantic Audio Feature Extraction VST plugins
+ pkgver = r111.f210498
+ pkgrel = 1
+ url = http://www.semanticaudio.co.uk
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = steinberg-vst36
+ depends = libglvnd
+ depends = curl
+ depends = freetype2
+ depends = libxtract
+ provides = safeplugins
+ conflicts = safeplugins
+ source = safeplugins::git://github.com/semanticaudio/SAFE.git
+ source = https://github.com/semanticaudio/SAFE/releases/download/v1.3/SAFE_User_Manual.pdf
+ md5sums = SKIP
+ md5sums = ac13d8d27c8a77f7baed3cface61b1f7
+
+pkgname = safeplugins-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ece56e8d7c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Joermungand <joermungand at gmail dot com>
+pkgname=safeplugins-git
+pkgver=r111.f210498
+pkgrel=1
+pkgdesc="Semantic Audio Feature Extraction VST plugins"
+arch=('i686' 'x86_64')
+url="http://www.semanticaudio.co.uk"
+license=('GPL3')
+depends=('libglvnd' 'curl' 'freetype2' 'libxtract')
+makedepends=('git' 'steinberg-vst36')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname%-*}"::'git://github.com/semanticaudio/SAFE.git'
+ 'https://github.com/semanticaudio/SAFE/releases/download/v1.3/SAFE_User_Manual.pdf')
+md5sums=('SKIP'
+ 'ac13d8d27c8a77f7baed3cface61b1f7')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-*}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-*}"
+ sed -i 's/public.sdk\/source\/vst2.x/vst36/' JuceModules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp
+}
+
+build() {
+ cd "$srcdir/${pkgname%-*}"
+ for plugin in Compressor Distortion Equaliser Reverb; do
+ cd "SAFE$plugin/Builds/Linux"
+ sed -i 's/\/usr\/local\/lib\/libxtract.a/-lxtract/' Makefile
+ make CONFIG=Release
+ cd "$srcdir/${pkgname%-*}"
+ done
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+ for plugin in Compressor Distortion Equaliser Reverb; do
+ cd "SAFE$plugin/Builds/Linux/build"
+ install -Dm755 "SAFE$plugin.so" "$pkgdir/usr/lib/vst/SAFE$plugin.so"
+ cd "$srcdir/${pkgname%-*}"
+ done
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname%-*}/README"
+ install -Dm644 ../SAFE_User_Manual.pdf "$pkgdir/usr/share/doc/${pkgname%-*}/SAFE_User_Manual.pdf"
+}