summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis A. Altoé Falqueto2023-10-20 22:12:26 -0300
committerDenis A. Altoé Falqueto2023-10-20 22:12:26 -0300
commit42fc4d05a2613feb29c2c1763f527e360e8cf774 (patch)
treeecba650fb038e83eb73ff9a4dd9b7825070a520f
parentce2827b8a135f0d51f7496fa10b5e9d1282d6445 (diff)
downloadaur-42fc4d05a2613feb29c2c1763f527e360e8cf774.tar.gz
Update to version 4.0.0.0 from RPM package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 23 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0af3a26b1e51..41d0e927d029 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = safesignidentityclient
pkgdesc = Smart card PKCS#11 provider and token manager
- pkgver = 3.7.0.0
- pkgrel = 4
+ pkgver = 4.0.0.0
+ pkgrel = 1
url = https://safesign.gdamericadosul.com.br/download
arch = x86_64
license = custom:copyright
@@ -10,13 +10,20 @@ pkgbase = safesignidentityclient
depends = glibc
depends = hicolor-icon-theme
depends = pcsclite
- depends = wxwidgets3.0
+ depends = libsm
+ depends = libx11
+ depends = cairo
+ depends = pango
+ depends = gdk-pixbuf2
+ depends = at-spi2-core
+ depends = gtk3
+ depends = libxxf86vm
depends = openssl-1.1
depends = gdbm
optdepends = ccid: Generic support for CCID devices,
optdepends = acsccid: ACS CCID PC/SC driver,
optdepends = scmccid: binary driver for the SCM Smart Card Readers
- source_x86_64 = https://safesign.gdamericadosul.com.br/content/SafeSign_IC_Standard_Linux_3.7.0.0_AET.000_ub2004_x86_64.rar
- sha256sums_x86_64 = cc250d03260d5d2af551c86f8e392452d55a8603426114bd7aabcaef04a3c85c
+ source_x86_64 = https://certificaat.kpn.com/files/drivers/SafeSign/SafeSign%20IC%20Standard%20Linux%204.0.0.0-AET.000%20redhat8%20x86_64.rpm
+ sha256sums_x86_64 = d78e8757afb61cc19424f2379c9cc7a7f187a096cc5ebb3445ccff3402403776
pkgname = safesignidentityclient
diff --git a/PKGBUILD b/PKGBUILD
index c58057f5de7b..c32ed986fffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
# Maintainer: Denis A. Altoé Falqueto <denisfalqueto@gmail.com>
# Contributor: Geyslan G. Bem <geyslan@gmail.com>
pkgname=safesignidentityclient
-pkgver=3.7.0.0
-pkgrel=4
+pkgver=4.0.0.0
+pkgrel=1
pkgdesc="Smart card PKCS#11 provider and token manager"
arch=('x86_64')
url="https://safesign.gdamericadosul.com.br/download"
license=('custom:copyright')
-depends=('gcc-libs' 'glib2' 'glibc' 'hicolor-icon-theme' 'pcsclite'
- 'wxwidgets3.0' 'openssl-1.1' 'gdbm')
+depends=('gcc-libs' 'glib2' 'glibc' 'hicolor-icon-theme' 'pcsclite' 'libsm' 'libx11' 'cairo' 'pango'
+ 'gdk-pixbuf2' 'at-spi2-core' 'gtk3' 'libxxf86vm' 'openssl-1.1' 'gdbm')
optdepends=('ccid: Generic support for CCID devices',
'acsccid: ACS CCID PC/SC driver',
'scmccid: binary driver for the SCM Smart Card Readers')
_aet_version="AET.000_ub2004"
-source_x86_64=("https://safesign.gdamericadosul.com.br/content/SafeSign_IC_Standard_Linux_${pkgver}_${_aet_version}_${arch}.rar")
-sha256sums_x86_64=('cc250d03260d5d2af551c86f8e392452d55a8603426114bd7aabcaef04a3c85c')
-
-prepare() {
- ar -x SafeSign_IC_Standard_Linux_${pkgver}_${_aet_version}_${arch}.deb
- tar xvf data.tar.xz
-}
+source_x86_64=("https://certificaat.kpn.com/files/drivers/SafeSign/SafeSign%20IC%20Standard%20Linux%204.0.0.0-AET.000%20redhat8%20x86_64.rpm")
+sha256sums_x86_64=('d78e8757afb61cc19424f2379c9cc7a7f187a096cc5ebb3445ccff3402403776')
package() {
- cp -R ${srcdir}/usr ${pkgdir}
+ install -d ${pkgdir}/usr
+ cp -R ${srcdir}/usr/{bin,share} ${pkgdir}/usr/
+
+ install -d ${pkgdir}/usr/lib
+ install -m 744 ${srcdir}/usr/lib64/* ${pkgdir}/usr/lib/
install -d ${pkgdir}/usr/share/licenses/${pkgname}
install -m 644 ${srcdir}/usr/share/doc/${pkgname}/copyright ${pkgdir}/usr/share/licenses/${pkgname}/copyright