summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSantiago Torres2018-10-23 22:24:13 -0400
committerSantiago Torres2018-10-23 22:24:13 -0400
commit2ee4b5d8454969634630294787e35fcef682740b (patch)
tree9035e0b894ac27107e7914c53582b084c56a90e5
downloadaur-2ee4b5d8454969634630294787e35fcef682740b.tar.gz
ENH: add initial version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58c94067a551
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = safetynets-git
+ pkgdesc = A framework to outsource machine-learning inference to
+ pkgver = d193964
+ pkgrel = 1
+ url = https://github.com/zghodsi/safetynests
+ arch = x86_64
+ arch = i686
+ license = custom:CC-BY-NC
+ source = git+https://github.com/zghodsi/safetynets
+ sha256sums = SKIP
+
+pkgname = safetynets-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..507cd1982ff4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Santiago Torres-Arias <santiago@archlinux.org>
+pkgname=safetynets-git
+pkgver=d193964
+pkgrel=1
+pkgdesc="A framework to outsource machine-learning inference to "
+arch=("x86_64" "i686")
+url="https://github.com/zghodsi/safetynests"
+license=('custom:CC-BY-NC')
+depends=()
+source=("git+https://github.com/zghodsi/safetynets")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd safetynets
+ git log -n1 --format=%h
+}
+
+build() {
+ cd safetynets
+ make
+}
+
+check() {
+ cd safetynets
+ ./safetynets.o timit_arch.txt
+}
+
+package() {
+ install -Dm755 "${srcdir}/safetynets/safetynets.o" "${pkgdir}/usr/bin/safetynets"
+}
+
+# vim:set ts=2 sw=2 et: