summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-05-22 12:57:46 +0200
committerAntonio Rojas2022-05-22 12:57:46 +0200
commit0471ccdac851d3d4a9c4c56a550fea068ecaab7f (patch)
tree66f7868ac699d7cc22d8e9b60c733f671214a59e
parent882a8074265dd9c1f275d726542c1ae74a95707c (diff)
downloadaur-0471ccdac851d3d4a9c4c56a550fea068ecaab7f.tar.gz
Sync with stable
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--sagemath-tachyon-0.99.patch77
3 files changed, 90 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 286b8eb48664..8e0afea9b13b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sagemath-git
pkgdesc = Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab
- pkgver = 9.6.rc4.r0.g888d18eb851
+ pkgver = 9.7.beta0.r0.g6f4efb0bf37
pkgrel = 1
url = http://www.sagemath.org
arch = x86_64
@@ -94,6 +94,7 @@ pkgbase = sagemath-git
optdepends = sage-notebook-exporter: convert flask notebooks to Jupyter
optdepends = python-database-knotinfo: interface to the KnotInfo and LinkInfo databases
optdepends = python-phitigra: graph editor
+ optdepends = topcom: to compute triangulations of point configurations
provides = sagemath
conflicts = sagemath
source = git://git.sagemath.org/sage.git#branch=develop
@@ -102,11 +103,13 @@ pkgbase = sagemath-git
source = test-optional.patch
source = sagemath-linbox-1.7.patch
source = sagemath-bliss-0.77.patch
+ source = sagemath-tachyon-0.99.patch
sha256sums = SKIP
sha256sums = eee5fa15d8c7be7e009166dbde3ea24bb10d7793dc12880516f278f86b1a6694
sha256sums = bd188af45ce31579b82407adee8e9bf6033a996f7ea6e328fabca526f31c08ba
sha256sums = 9d042070df3dfd53a1248659677798da888f733548eda91a6d5169c7aa1907e1
sha256sums = eacea27b214d32cb886a75695153dfc36b5bad2fd2517e8e4eee18e74220e9e3
sha256sums = b467a41e1e0a0850f7722d875a743233751966a206c2f61401c7582aa722f84e
+ sha256sums = 4ee8071efd7b9ad66ac5bbfe081fe670cc58cfcac8fb783d5a40b6da3593cbf4
pkgname = sagemath-git
diff --git a/PKGBUILD b/PKGBUILD
index 75be6f427f28..4b9fb5f81da7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
pkgname=sagemath-git
-pkgver=9.6.rc4.r0.g888d18eb851
+pkgver=9.7.beta0.r0.g6f4efb0bf37
pkgrel=1
pkgdesc='Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab'
arch=(x86_64)
@@ -47,7 +47,8 @@ optdepends=('cython: to compile cython code'
'python-pip: to install optional packages with sage -pip'
'sage-notebook-exporter: convert flask notebooks to Jupyter'
'python-database-knotinfo: interface to the KnotInfo and LinkInfo databases'
- 'python-phitigra: graph editor')
+ 'python-phitigra: graph editor'
+ 'topcom: to compute triangulations of point configurations')
makedepends=(cython boost python-jinja sirocco mcqd coxeter bliss tdlib python-pkgconfig shared_meataxe git)
conflicts=(sagemath)
provides=(sagemath)
@@ -56,13 +57,15 @@ source=(git://git.sagemath.org/sage.git#branch=develop
latte-count.patch
test-optional.patch
sagemath-linbox-1.7.patch
- sagemath-bliss-0.77.patch)
+ sagemath-bliss-0.77.patch
+ sagemath-tachyon-0.99.patch)
sha256sums=('SKIP'
'eee5fa15d8c7be7e009166dbde3ea24bb10d7793dc12880516f278f86b1a6694'
'bd188af45ce31579b82407adee8e9bf6033a996f7ea6e328fabca526f31c08ba'
'9d042070df3dfd53a1248659677798da888f733548eda91a6d5169c7aa1907e1'
'eacea27b214d32cb886a75695153dfc36b5bad2fd2517e8e4eee18e74220e9e3'
- 'b467a41e1e0a0850f7722d875a743233751966a206c2f61401c7582aa722f84e')
+ 'b467a41e1e0a0850f7722d875a743233751966a206c2f61401c7582aa722f84e'
+ '4ee8071efd7b9ad66ac5bbfe081fe670cc58cfcac8fb783d5a40b6da3593cbf4')
pkgver() {
cd sage
@@ -77,6 +80,8 @@ prepare(){
patch -p1 -i ../sagemath-linbox-1.7.patch
# Fix build with bliss 0.77 https://trac.sagemath.org/ticket/33010
patch -p1 -i ../sagemath-bliss-0.77.patch
+# Fix tests with tachyon 0.99 https://trac.sagemath.org/ticket/23712
+ patch -p1 -i ../sagemath-tachyon-0.99.patch
# Arch-specific patches
# assume all optional packages are installed
diff --git a/sagemath-tachyon-0.99.patch b/sagemath-tachyon-0.99.patch
new file mode 100644
index 000000000000..e5a98ab5e87b
--- /dev/null
+++ b/sagemath-tachyon-0.99.patch
@@ -0,0 +1,77 @@
+--- a/src/sage/interfaces/tachyon.py
++++ b/src/sage/interfaces/tachyon.py
+@@ -261,13 +261,13 @@ written in the sequence they are listed in the examples in this section.
+ The {\bf PROJECTION} keyword must be followed by one of the supported
+ camera projection mode identifiers {\bf PERSPECTIVE}, {\bf PERSPECTIVE_DOF},
+ {\bf ORTHOGRAPHIC}, or {\bf FISHEYE}. The {\bf FISHEYE} projection mode
+-requires two extra parameters {\bf FOCALLENGTH} and {\bf APERTURE}
++requires two extra parameters {\bf FOCALDIST} and {\bf APERTURE}
+ which precede the regular camera options.
+
+ \begin{verbatim}
+ Camera
+ projection perspective_dof
+- focallength 0.75
++ FOCALDIST 0.75
+ aperture 0.02
+ Zoom 0.666667
+ Aspectratio 1.000000
+--- a/src/sage/plot/plot3d/tachyon.py
++++ b/src/sage/plot/plot3d/tachyon.py
+@@ -92,7 +92,7 @@ angle, right angle)::
+ Finally there is the ``projection='perspective_dof'`` option. ::
+
+ sage: T = Tachyon(xres=800, antialiasing=4, raydepth=10,
+- ....: projection='perspective_dof', focallength='1.0', aperture='.0025')
++ ....: projection='perspective_dof', FOCALDIST='1.0', aperture='.0025')
+ sage: T.light((0,5,7), 1.0, (1,1,1))
+ sage: T.texture('t1', opacity=1, specular=.3)
+ sage: T.texture('t2', opacity=1, specular=.3, color=(0,0,1))
+@@ -186,7 +186,7 @@ class Tachyon(WithEqualityById, SageObject):
+ or ``'fisheye'``.
+ - ``frustum`` - (default ''), otherwise list of four numbers. Only
+ used with projection='fisheye'.
+- - ``focallength`` - (default ''), otherwise a number. Only used
++ - ``FOCALDIST`` - (default ''), otherwise a number. Only used
+ with projection='perspective_dof'.
+ - ``aperture`` - (default ''), otherwise a number. Only used
+ with projection='perspective_dof'.
+@@ -331,7 +331,7 @@ class Tachyon(WithEqualityById, SageObject):
+ Use of the ``projection='perspective_dof'`` option. This may not be
+ implemented correctly. ::
+
+- sage: T = Tachyon(xres=800,antialiasing=4, raydepth=10, projection='perspective_dof', focallength='1.0', aperture='.0025')
++ sage: T = Tachyon(xres=800,antialiasing=4, raydepth=10, projection='perspective_dof', FOCALDIST='1.0', aperture='.0025')
+ sage: T.light((0,5,7), 1.0, (1,1,1))
+ sage: T.texture('t1', opacity=1, specular=.3)
+ sage: T.texture('t2', opacity=1, specular=.3, color=(0,0,1))
+@@ -365,7 +365,7 @@ class Tachyon(WithEqualityById, SageObject):
+ look_at=[0, 0, 0],
+ viewdir=None,
+ projection='PERSPECTIVE',
+- focallength='',
++ FOCALDIST='',
+ aperture='',
+ frustum=''):
+ r"""
+@@ -391,7 +391,7 @@ class Tachyon(WithEqualityById, SageObject):
+ self._camera_position = (-3, 0, 0) # default value
+ self._updir = updir
+ self._projection = projection
+- self._focallength = focallength
++ self._FOCALDIST = FOCALDIST
+ self._aperture = aperture
+ self._frustum = frustum
+ self._objects = []
+@@ -624,9 +624,9 @@ class Tachyon(WithEqualityById, SageObject):
+ camera_out = r"""
+ camera
+ projection %s""" % (tostr(self._projection))
+- if self._focallength != '':
++ if self._FOCALDIST != '':
+ camera_out = camera_out + r"""
+- focallength %s""" % (float(self._focallength))
++ FOCALDIST %s""" % (float(self._FOCALDIST))
+ if self._aperture != '':
+ camera_out = camera_out + r"""
+ aperture %s""" % (float(self._aperture))