summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-09-18 21:54:30 +0200
committerAntonio Rojas2015-09-18 21:54:30 +0200
commit14269c7f108a2b4542f8cdcbf59ccbaac12cf4ae (patch)
treede456feed04d8f0b99c9ee6c366225794adb4f78
parentffaf73e42c3207f5e1ef9714f884de75183ad5ec (diff)
downloadaur-14269c7f108a2b4542f8cdcbf59ccbaac12cf4ae.tar.gz
Update patches
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--ipython-4.patch13
-rw-r--r--package.patch2
4 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eab2ac24ebb6..9a2bbe2fb809 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sagemath-git
pkgdesc = Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab
- pkgver = 6.9.beta4.r0.g78e0fc5
+ pkgver = 6.9.beta7.r0.gaeeddeb
pkgrel = 1
url = http://www.sagemath.org
arch = i686
@@ -63,8 +63,8 @@ pkgbase = sagemath-git
optdepends = jmol: 3D plots
optdepends = sage-notebook: Browser-based (flask) notebook interface
optdepends = sagemath-doc: Documentation and inline help
- optdepends = ipython2-notebook: IPython notebook interface
- optdepends = mathjax: IPython notebook interface
+ optdepends = ipython2-notebook: Jupyter notebook interface
+ optdepends = mathjax: Jupyter notebook interface
optdepends = coin-or-cbc: COIN backend for numerical computations
optdepends = nauty: for generating some classes of graphs
optdepends = buckygen: for generating fullerene graphs
@@ -90,11 +90,10 @@ pkgbase = sagemath-git
source = pexpect-env.patch
source = pexpect-del.patch
source = disable-fes.patch
- source = ipython-4.patch
md5sums = SKIP
md5sums = d9a3e113ed147dcee8f89962a8dccd43
md5sums = a906a180d198186a39820b0a2f9a9c63
- md5sums = f72e544032b1a3f952b7ddafc3a49d63
+ md5sums = 9ba81f717ffd4e20b8b2f2a318307488
md5sums = 5ebdb6e6ac541f040a39f8d3fd9c8ee1
md5sums = fd8e3e07f5b7318e6a7200a3c64f5bc2
md5sums = 23e972753be1e5d0f761a7f82a95cebf
diff --git a/PKGBUILD b/PKGBUILD
index ceee004145ff..c68d60c90351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Special thanks to Nareto for moving the compile from the .install to the PKGBUILD
pkgname=sagemath-git
-pkgver=6.9.beta4.r0.g78e0fc5
+pkgver=6.9.beta7.r0.gaeeddeb
pkgrel=1
pkgdesc="Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab"
arch=(i686 x86_64)
@@ -22,8 +22,8 @@ optdepends=('cython2: to compile cython code'
'jmol: 3D plots'
'sage-notebook: Browser-based (flask) notebook interface'
'sagemath-doc: Documentation and inline help'
- 'ipython2-notebook: IPython notebook interface'
- 'mathjax: IPython notebook interface'
+ 'ipython2-notebook: Jupyter notebook interface'
+ 'mathjax: Jupyter notebook interface'
'coin-or-cbc: COIN backend for numerical computations'
'nauty: for generating some classes of graphs'
'buckygen: for generating fullerene graphs'
@@ -42,19 +42,18 @@ provides=(sagemath sage-mathematics)
source=("git://git.sagemath.org/sage.git#branch=develop"
"http://mirrors.mit.edu/sage/spkg/upstream/pexpect/pexpect-2.0.tar.bz2" 'anal.h'
'package.patch' 'env.patch' 'paths.patch' 'clean.patch' 'skip-check.patch'
-'pexpect-env.patch' 'pexpect-del.patch' 'disable-fes.patch' 'ipython-4.patch')
+'pexpect-env.patch' 'pexpect-del.patch' 'disable-fes.patch')
md5sums=('SKIP'
'd9a3e113ed147dcee8f89962a8dccd43'
'a906a180d198186a39820b0a2f9a9c63'
- 'f72e544032b1a3f952b7ddafc3a49d63'
+ '9ba81f717ffd4e20b8b2f2a318307488'
'5ebdb6e6ac541f040a39f8d3fd9c8ee1'
'fd8e3e07f5b7318e6a7200a3c64f5bc2'
'23e972753be1e5d0f761a7f82a95cebf'
'5947a420a0b1483f0cbc74c76895789b'
'a83a3b1bc7fcb7cbf752a83a8311fc42'
'f333939ea6c41377b66407c81016cee4'
- '4eb23a3c7363258bc9ba764d6e5512ba'
- 'b21a2b0e4cb805bf61a5060c3ed97cb3')
+ '4eb23a3c7363258bc9ba764d6e5512ba')
pkgver() {
cd sage
@@ -89,8 +88,6 @@ prepare(){
-i src/sage/databases/cremona.py
# find bliss headers
sed -e 's|graph.hh|bliss/graph.hh|' -i src/sage/graphs/bliss.pyx
-# fix IPython 4 compatibility
- patch -p0 -i ../ipython-4.patch
# Upstream patches
# fix build against libfes 0.2 http://trac.sagemath.org/ticket/15209
diff --git a/ipython-4.patch b/ipython-4.patch
deleted file mode 100644
index be9daac09d80..000000000000
--- a/ipython-4.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/sage/repl/interpreter.py.orig 2015-08-16 14:57:55.571128473 +0200
-+++ src/sage/repl/interpreter.py 2015-08-16 14:58:06.647849803 +0200
-@@ -104,8 +104,8 @@
- import sys
- from sage.repl.preparse import preparse
-
--from IPython import Config
--from IPython.utils.traitlets import Bool, Type
-+from traitlets.config.loader import Config
-+from traitlets import Bool, Type
-
- from sage.env import SAGE_LOCAL
-
diff --git a/package.patch b/package.patch
index 0b219ddebe7a..b2a0d2dcfb3c 100644
--- a/package.patch
+++ b/package.patch
@@ -4,7 +4,7 @@
Otherwise, installing "pillow" will cause this function to think
that "pil" is installed, for example.
"""
-- return any(p.split('-')[0] == package for p in install_package())
+- return any(p.split('-')[0] == package for p in installed_packages())
+ return True
def package_versions(package_type, local=False):