summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2018-09-15 15:01:22 +0000
committerAntonio Rojas2018-09-15 15:01:22 +0000
commit1c114059ad03c15b9bcc784fd7a74fb4b7a028dc (patch)
tree8b6f1977f6dd294452951155fa1312f79598abdf
parentb7cc5cbdaaaafd59bd6a07ac5bf90f33dde808a8 (diff)
downloadaur-1c114059ad03c15b9bcc784fd7a74fb4b7a028dc.tar.gz
Sync patches with stable
-rw-r--r--PKGBUILD14
-rw-r--r--sagemath-no-doc-check.patch62
-rw-r--r--sagemath-sphinx-1.8.patch28
3 files changed, 101 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e806a9065a5f..f217f677c319 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=sagemath-git
pkgname=(sagemath-git sagemath-jupyter-git)
-pkgver=8.4.beta4.r0.gfc36a57a38
+pkgver=8.4.beta5.r0.gca26fcca0f
pkgrel=1
pkgdesc="Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab"
arch=(x86_64)
@@ -45,7 +45,9 @@ source=(git://git.sagemath.org/sage.git#branch=develop
sagemath-threejs.patch
sagemath-cremona.patch
sagemath-lcalc-c++11.patch
- sagemath-gap-4.8.patch)
+ sagemath-gap-4.8.patch
+ sagemath-no-doc-check.patch
+ sagemath-sphinx-1.8.patch)
sha256sums=('SKIP'
'f483a448c045aeff186bec4b402da8109fa12547ff36219a9aa427c2561ec8e5'
'960afe4fcbffe2762b66119b8f14355386ced0d8ee52b535d0dac1dba90d365b'
@@ -56,7 +58,9 @@ sha256sums=('SKIP'
'4722f9257f7b58a5dc8be2e9163ebba6d7b3ee011ff1ab9c0dbfb1330d367261'
'7efb38ba511037feb3abbd88576323320555ba50235ddc7e3d423ca294dd42ed'
'5114c912f821900e5bfae1e2cfeb7984de946d0b23e1182b0bf15be1d803dfd0'
- '3d02f6e349213ff4cea6a3acf5e7f8ec11a37b6ead61b338931f07073ebcb36e')
+ '3d02f6e349213ff4cea6a3acf5e7f8ec11a37b6ead61b338931f07073ebcb36e'
+ 'b0d30c0d26a3dc7aeb402f883e49db9ba9a0e9e029852b589ba77dcc1925a0b9'
+ '7dd2ab94fddda8e7c2cdd5250642c4cdd00b7702815d88762fbcd68416bacaee')
pkgver() {
cd sage
@@ -83,6 +87,10 @@ prepare(){
patch -p1 -i ../sagemath-lcalc-c++11.patch
# Adjust paths for gap-4.8
patch -p1 -i ../sagemath-gap-4.8.patch
+# don't check for doc presence in doc_search (Gentoo)
+ patch -p1 -i ../sagemath-no-doc-check.patch
+# fix introspection with sphinx 1.8
+ patch -p1 -i ../sagemath-sphinx-1.8.patch
# Upstream patches
# fix build against libfes 0.2 http://trac.sagemath.org/ticket/15209
diff --git a/sagemath-no-doc-check.patch b/sagemath-no-doc-check.patch
new file mode 100644
index 000000000000..9c2ffd2ceb0e
--- /dev/null
+++ b/sagemath-no-doc-check.patch
@@ -0,0 +1,62 @@
+diff --git a/sage/misc/sagedoc.py b/sage/misc/sagedoc.py
+index fdb5322..f44139c 100644
+--- a/src/sage/misc/sagedoc.py
++++ b/src/sage/misc/sagedoc.py
+@@ -846,57 +846,6 @@ def _search_src_or_doc(what, string, extra1='', extra2='', extra3='',
+ exts = ['html']
+ title = 'Documentation'
+ base_path = os.path.join(SAGE_DOC, 'html')
+- doc_path = SAGE_DOC_SRC
+-
+- from sage_setup.docbuild.build_options import LANGUAGES, OMIT
+- # List of languages
+- lang = LANGUAGES
+- # Documents in SAGE_DOC_SRC/LANG/ to omit
+- omit = OMIT
+-
+- # List of documents, minus the omitted ones
+- documents = []
+- for L in lang:
+- documents += [os.path.join(L, dir) for dir
+- in os.listdir(os.path.join(doc_path, L))
+- if dir not in omit]
+-
+- # Check to see if any documents are missing. This just
+- # checks to see if the appropriate output directory exists,
+- # not that it contains a complete build of the docs.
+- missing = [os.path.join(base_path, doc)
+- for doc in documents if not
+- os.path.exists(os.path.join(base_path, doc))]
+- num_missing = len(missing)
+- if num_missing > 0:
+- print("""Warning, the following Sage documentation hasn't been built,
+-so documentation search results may be incomplete:
+-""")
+- for s in missing:
+- print(s)
+- if num_missing > 1:
+- print("""
+-You can build these with 'sage -docbuild DOCUMENT html',
+-where DOCUMENT is one of""", end=' ')
+- for s in missing:
+- if s.find('en') != -1:
+- print("'{}',".format(os.path.split(s)[-1]), end=' ')
+- else:
+- print("'{}',".format(os.path.join(
+- os.path.split(os.path.split(s)[0])[-1],
+- os.path.split(s)[-1])), end=' ')
+- print("""
+-or you can use 'sage -docbuild all html' to build all of the missing documentation.""")
+- else:
+- s = missing[0]
+- if s.find('en') != -1:
+- s = os.path.split(s)[-1]
+- else:
+- s = os.path.join(
+- os.path.split(os.path.split(s)[0])[-1],
+- os.path.split(s)[-1])
+- print("""
+-You can build this with 'sage -docbuild {} html'.""".format(s))
+
+ strip = len(base_path)
+ results = []
diff --git a/sagemath-sphinx-1.8.patch b/sagemath-sphinx-1.8.patch
new file mode 100644
index 000000000000..f54439334a0d
--- /dev/null
+++ b/sagemath-sphinx-1.8.patch
@@ -0,0 +1,28 @@
+--- a/src/sage/misc/sphinxify.py 2018-09-14 20:13:32.788831484 +0200
++++ b/src/sage/misc/sphinxify.py 2018-09-14 20:14:07.142478667 +0200
+@@ -64,6 +64,7 @@
+ sage: assert n == len(sys.path)
+ """
+ srcdir = mkdtemp()
++ outdir = mkdtemp()
+ base_name = os.path.join(srcdir, 'docstring')
+ rst_name = base_name + '.rst'
+
+@@ -71,7 +72,7 @@
+ suffix = '.html'
+ else:
+ suffix = '.txt'
+- output_name = base_name + suffix
++ output_name = os.path.join(outdir, 'docstring') + suffix
+
+ with open(rst_name, 'w') as filed:
+ filed.write(docstring)
+@@ -89,7 +90,7 @@
+
+ import sys
+ old_sys_path = list(sys.path) # Sphinx modifies sys.path
+- sphinx_app = Sphinx(srcdir, confdir, srcdir, doctreedir, format,
++ sphinx_app = Sphinx(srcdir, confdir, outdir, doctreedir, format,
+ confoverrides, None, None, True)
+ sphinx_app.build(None, [rst_name])
+ sys.path = old_sys_path