summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-01-04 13:32:00 +0000
committerAntonio Rojas2020-01-04 13:32:00 +0000
commit2735723f0941c7b55748e9413329cce77fd20e62 (patch)
tree83698dcba13fbe58ece0940ac260ea3faadcf337
parent138b3db82d8d13f9c66bf8d7515aa37671710e0a (diff)
downloadaur-2735723f0941c7b55748e9413329cce77fd20e62.tar.gz
Remove fes module
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--fes02.patch57
3 files changed, 0 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65fe02d2b80f..2bdc0f57f1b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -97,7 +97,6 @@ pkgbase = sagemath-git
source = package.patch
source = latte-count.patch
source = test-optional.patch
- source = fes02.patch
source = sagemath-cremona.patch
source = sagemath-singular-4.1.2.patch
source = sagemath-ecl-sigfpe.patch
@@ -108,7 +107,6 @@ pkgbase = sagemath-git
sha256sums = 496da0fa42cdfc92b43f5d85610bb462ca9bdc2f4d80fd316e8e9d068dba3b0b
sha256sums = 6a5470d7044a50a35a6478f57c19adf72fe54aefebeea8a095915b63f9e219ac
sha256sums = 876fd1c0fc3471b56e54d960d79e5ce1d5fc49cebf6eed27043a7380854c792c
- sha256sums = 9b2d87990db3045a83776e1ff527a31ce60a3361b08f5ec85fb1d45106982faa
sha256sums = 937074fa7a8a4e2aba9ea77ec622fe937985a1a9176c48460d51325ee877a4f5
sha256sums = d2a065a36be3c011a257b8694111e267d9ce7cba867c53eeb464a4573dac9bbb
sha256sums = e44bbde87f3312548faad75b7383ef21fade55be251ab5804de41cd3842ca8a0
diff --git a/PKGBUILD b/PKGBUILD
index 8bb60b407997..c8b8942bc309 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,7 +37,6 @@ source=(git://git.sagemath.org/sage.git#branch=develop
package.patch
latte-count.patch
test-optional.patch
- fes02.patch
sagemath-cremona.patch
sagemath-singular-4.1.2.patch
sagemath-ecl-sigfpe.patch
@@ -48,7 +47,6 @@ sha256sums=('SKIP'
'496da0fa42cdfc92b43f5d85610bb462ca9bdc2f4d80fd316e8e9d068dba3b0b'
'6a5470d7044a50a35a6478f57c19adf72fe54aefebeea8a095915b63f9e219ac'
'876fd1c0fc3471b56e54d960d79e5ce1d5fc49cebf6eed27043a7380854c792c'
- '9b2d87990db3045a83776e1ff527a31ce60a3361b08f5ec85fb1d45106982faa'
'937074fa7a8a4e2aba9ea77ec622fe937985a1a9176c48460d51325ee877a4f5'
'd2a065a36be3c011a257b8694111e267d9ce7cba867c53eeb464a4573dac9bbb'
'e44bbde87f3312548faad75b7383ef21fade55be251ab5804de41cd3842ca8a0'
@@ -81,8 +79,6 @@ prepare(){
sed -e 's|mathjax|mathjax2|g' -i src/sage/env.py
# Upstream patches
-# fix build against libfes 0.2 http://trac.sagemath.org/ticket/15209
- patch -p1 -i ../fes02.patch
# use Features to detect Cremona databases https://trac.sagemath.org/ticket/25825
patch -p1 -i ../sagemath-cremona.patch
# Fixes for singular 4.1.2 https://trac.sagemath.org/ticket/25993
diff --git a/fes02.patch b/fes02.patch
deleted file mode 100644
index 3f7fe609642a..000000000000
--- a/fes02.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From b1f5e3ecc789db674fe17552812f2d0e2ab84be0 Mon Sep 17 00:00:00 2001
-From: Charles Bouillaguet <charles.bouillaguet@lifl.fr>
-Date: Thu, 19 Sep 2013 10:31:11 +0200
-Subject: updating the libFES binding to match a change in the interface
-
----
- src/sage/libs/fes.pyx | 12 +++++++-----
- 1 file changed, 7 insertions(+), 5 deletions(-)
-
-diff --git a/src/sage/libs/fes.pyx b/src/sage/libs/fes.pyx
-index 40b9c23..d188cf0 100644
---- a/src/sage/libs/fes.pyx
-+++ b/src/sage/libs/fes.pyx
-@@ -1,17 +1,19 @@
- """
--Binding for the FES library.
-+Binding for the libFES library.
-
- Finding solutions of systems of boolean equations by exhaustive
- search, via the fes library. This is usually (much) faster than
- computing a Groebner basis, except in special cases where the latter
- is particularly easy.
-
--The FES library is presently only able to deal with polynomials in 64
-+More information is available at [http://www.lifl.fr/~bouillag/fes].
-+
-+The libFES library is presently only able to deal with polynomials in 64
- variables. Performing a full exhaustive search over 64 variables will
- take a **long** time. The number of variables can be artificially
- reduced to 64 by specializing some of them.
-
--Note that the FES library **requires** at least of the equations to be
-+Note that the libFES library **requires** at least of the equations to be
- non-linear.
-
- AUTHORS:
-@@ -69,7 +71,7 @@ from libc.stdint cimport uint64_t
- cdef extern from "fes_interface.h":
- ctypedef int (*solution_callback_t)(void *, uint64_t)
-
-- void exhaustive_search_wrapper(int n, int n_eqs, int degree, int ***coeffs, solution_callback_t callback, void* callback_state, int verbose)
-+ void exhaustive_search_wrapper(int n, int n_eqs, int degree, int ***coeffs, solution_callback_t callback, void* callback_state, int verbose, int T)
-
-
- from sage.rings.integer import Integer
-@@ -215,7 +215,7 @@ def exhaustive_search(eqs, max_sols=Infinity, verbose=False):
-
- # ------- runs the library
- sig_on()
-- exhaustive_search_wrapper(n, len(eqs), degree, coeffs, report_solution, <void *> internal_state, verbose)
-+ exhaustive_search_wrapper(n, len(eqs), degree, coeffs, report_solution, <void *> internal_state, verbose, 0)
- sig_off()
-
- # ------- frees memory occupied by the dense representation of the equations
---
-cgit v1.0-1-gd88e
-