summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2018-06-29 16:34:10 +0000
committerAntonio Rojas2018-06-29 16:34:10 +0000
commit2c5d3aed39712565832fce8327b5935898be4369 (patch)
tree76d83b3ed3f5ad3d2c68b1d1fa97f7c626d6adde
parent1d5a2e10ebe0cfaa1115e283ed1cc673c2ce863d (diff)
downloadaur-2c5d3aed39712565832fce8327b5935898be4369.tar.gz
Sync Singular patch with stable
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--sagemath-singular-4.1.1.patch14
3 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3cd294dc5b2..80cf16726e7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -123,7 +123,7 @@ pkgbase = sagemath-git
sha256sums = 71cc42d168545d460bc7f67a30486ff1534093e2b4deeb83deda8ff5bd081e7b
sha256sums = c65d9259df0e416ab74fd8c269df7d10d620b973ffe5583038d3433316c67a32
sha256sums = 17397b8e1843b013ef5d2e083369109f0719651edd8ef0c8493cb49e2bc4324a
- sha256sums = 369f1483e0364031d73d43d9e63b7bf2b0929c8a1d470c1596f98f9f1aa80750
+ sha256sums = 11a68f156647ba9f38cb01b2a5e4f9a6a78f6297f2a5a65fbfdfe32d4be69d0c
sha256sums = 5114c912f821900e5bfae1e2cfeb7984de946d0b23e1182b0bf15be1d803dfd0
sha256sums = e24ad879f6b2eb970778fc5e867bcbe0a6d393feca8f11f5cb8d07da1f024be9
diff --git a/PKGBUILD b/PKGBUILD
index 0a72d37902d6..9b9c23d29d27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,7 +52,7 @@ sha256sums=('SKIP'
'71cc42d168545d460bc7f67a30486ff1534093e2b4deeb83deda8ff5bd081e7b'
'c65d9259df0e416ab74fd8c269df7d10d620b973ffe5583038d3433316c67a32'
'17397b8e1843b013ef5d2e083369109f0719651edd8ef0c8493cb49e2bc4324a'
- '369f1483e0364031d73d43d9e63b7bf2b0929c8a1d470c1596f98f9f1aa80750'
+ '11a68f156647ba9f38cb01b2a5e4f9a6a78f6297f2a5a65fbfdfe32d4be69d0c'
'5114c912f821900e5bfae1e2cfeb7984de946d0b23e1182b0bf15be1d803dfd0'
'e24ad879f6b2eb970778fc5e867bcbe0a6d393feca8f11f5cb8d07da1f024be9')
diff --git a/sagemath-singular-4.1.1.patch b/sagemath-singular-4.1.1.patch
index 5e5d3ba38d2a..6471d2499acd 100644
--- a/sagemath-singular-4.1.1.patch
+++ b/sagemath-singular-4.1.1.patch
@@ -92,3 +92,17 @@ index 3b45a38419..c0227fd364 100644
#p_SetCoeff(flt, n_Div( p_GetCoeff(f._poly, r) , p_GetCoeff((<NCPolynomial_plural>g)._poly, r), r), r)
p_SetCoeff(flt, n_Init(1, r), r)
return new_NCP(self,flt), g
+diff --git a/src/sage/rings/polynomial/multi_polynomial_libsingular.pyx b/src/sage/rings/polynomial/multi_polynomial_libsingular.pyx
+index 809ca72c76..9610ce125d 100644
+--- a/src/sage/rings/polynomial/multi_polynomial_libsingular.pyx
++++ b/src/sage/rings/polynomial/multi_polynomial_libsingular.pyx
+@@ -4888,7 +4888,7 @@ cdef class MPolynomial_libsingular(MPolynomial):
+ if right.is_zero():
+ raise ZeroDivisionError
+
+- if not self._parent._base.is_field() and not is_IntegerRing(self._parent._base):
++ if not self._parent._base.is_field():
+ py_quo = self//right
+ py_rem = self - right*py_quo
+ return py_quo, py_rem
+