summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-09-04 14:07:10 +0200
committerAntonio Rojas2022-09-04 14:07:10 +0200
commit5bba214093a3f96bf484d04627b6064575694bf5 (patch)
tree6d9d271a193fb59a92d8542131f7dc218e729a96
parentd24161cae72f097a27df1800fa6862208bee5f18 (diff)
downloadaur-5bba214093a3f96bf484d04627b6064575694bf5.tar.gz
Fix build with tdlib 0.9
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--sagemath-tdlib-0.9.patch28
3 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 633a5099907d..26a8ae8cadf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sagemath-git
pkgdesc = Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab
- pkgver = 9.7.beta8.r0.g12be2d94c86
+ pkgver = 9.7.rc0.r0.gcae9ee5177a
pkgrel = 1
url = http://www.sagemath.org
arch = x86_64
@@ -95,6 +95,7 @@ pkgbase = sagemath-git
optdepends = python-database-knotinfo: interface to the KnotInfo and LinkInfo databases
optdepends = python-phitigra: graph editor
optdepends = topcom: to compute triangulations of point configurations
+ optdepends = python-database-cubic-hecke: cubic Hecke algebras
provides = sagemath
conflicts = sagemath
source = git://git.sagemath.org/sage.git#branch=develop
@@ -106,6 +107,7 @@ pkgbase = sagemath-git
source = sagemath-tachyon-0.99.patch
source = sagemath-gap-4.12.patch
source = sagemath-ipywidgets-8.patch
+ source = sagemath-tdlib-0.9.patch
sha256sums = SKIP
sha256sums = eee5fa15d8c7be7e009166dbde3ea24bb10d7793dc12880516f278f86b1a6694
sha256sums = bd188af45ce31579b82407adee8e9bf6033a996f7ea6e328fabca526f31c08ba
@@ -115,5 +117,6 @@ pkgbase = sagemath-git
sha256sums = 9760db6c6ec40cc16ab8a0cbf3d019df7f6a69ff292e35622f282b7c888aac77
sha256sums = 84c1700e285ab1d94d16d0a602417a414447d8a23ac2e55a093285cc4bd2916d
sha256sums = bdf56f85b608da12074780271ae134b02a03278f7b53a183f6dd97d8d72073e0
+ sha256sums = 56a83abecf2ff5a500442adc7a50abbb70006037dd39c39dcdb04b3ca9fb51e2
pkgname = sagemath-git
diff --git a/PKGBUILD b/PKGBUILD
index 7101d423988f..55d2627fa105 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
pkgname=sagemath-git
-pkgver=9.7.beta8.r0.g12be2d94c86
+pkgver=9.7.rc0.r0.gcae9ee5177a
pkgrel=1
pkgdesc='Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab'
arch=(x86_64)
@@ -48,7 +48,8 @@ optdepends=('cython: to compile cython code'
'sage-notebook-exporter: convert flask notebooks to Jupyter'
'python-database-knotinfo: interface to the KnotInfo and LinkInfo databases'
'python-phitigra: graph editor'
- 'topcom: to compute triangulations of point configurations')
+ 'topcom: to compute triangulations of point configurations'
+ 'python-database-cubic-hecke: cubic Hecke algebras')
makedepends=(cython boost python-jinja sirocco mcqd coxeter bliss tdlib python-pkgconfig shared_meataxe git)
conflicts=(sagemath)
provides=(sagemath)
@@ -60,7 +61,8 @@ source=(git://git.sagemath.org/sage.git#branch=develop
sagemath-bliss-0.77.patch
sagemath-tachyon-0.99.patch
sagemath-gap-4.12.patch
- sagemath-ipywidgets-8.patch)
+ sagemath-ipywidgets-8.patch
+ sagemath-tdlib-0.9.patch)
sha256sums=('SKIP'
'eee5fa15d8c7be7e009166dbde3ea24bb10d7793dc12880516f278f86b1a6694'
'bd188af45ce31579b82407adee8e9bf6033a996f7ea6e328fabca526f31c08ba'
@@ -69,7 +71,8 @@ sha256sums=('SKIP'
'3e1f866944235b999d2d727ed1ced431bd67405b053701c21068607ec76f23c3'
'9760db6c6ec40cc16ab8a0cbf3d019df7f6a69ff292e35622f282b7c888aac77'
'84c1700e285ab1d94d16d0a602417a414447d8a23ac2e55a093285cc4bd2916d'
- 'bdf56f85b608da12074780271ae134b02a03278f7b53a183f6dd97d8d72073e0')
+ 'bdf56f85b608da12074780271ae134b02a03278f7b53a183f6dd97d8d72073e0'
+ '56a83abecf2ff5a500442adc7a50abbb70006037dd39c39dcdb04b3ca9fb51e2')
pkgver() {
cd sage
@@ -98,6 +101,8 @@ prepare(){
patch -p1 -i ../test-optional.patch
# use correct latte-count binary name
patch -p1 -i ../latte-count.patch
+# update to tdlib 0.9 (Fedora)
+ patch -p1 -i ../sagemath-tdlib-0.9.patch
cd build/pkgs/sagelib
./bootstrap
diff --git a/sagemath-tdlib-0.9.patch b/sagemath-tdlib-0.9.patch
new file mode 100644
index 000000000000..50e4ed3690a6
--- /dev/null
+++ b/sagemath-tdlib-0.9.patch
@@ -0,0 +1,28 @@
+diff -up src/sage/graphs/graph_decompositions/sage_tdlib.cpp.orig src/sage/graphs/graph_decompositions/sage_tdlib.cpp
+--- a/src/sage/graphs/graph_decompositions/sage_tdlib.cpp 2021-05-09 16:00:11.000000000 -0600
++++ b/src/sage/graphs/graph_decompositions/sage_tdlib.cpp 2021-06-16 08:33:47.325415307 -0600
+@@ -2,8 +2,8 @@
+ #include <map>
+
+ #include <boost/graph/adjacency_list.hpp>
+-#include "tdlib/TD_combinations.hpp"
+-#include "tdlib/TD_misc.hpp"
++#include <treedec/combinations.hpp>
++#include <treedec/misc.hpp>
+
+ #ifndef TD_STRUCT_VERTEX
+ #define TD_STRUCT_VERTEX
+@@ -16,13 +16,6 @@ struct Vertex{
+
+ typedef boost::adjacency_list<boost::setS, boost::vecS, boost::undirectedS, Vertex> TD_graph_t;
+
+-struct bag{
+- std::set<unsigned int> bag;
+-};
+-
+-typedef boost::adjacency_list<boost::vecS, boost::vecS, boost::undirectedS, bag> TD_tree_dec_t;
+-
+-
+ void make_tdlib_graph(TD_graph_t &G, std::vector<unsigned int> &V, std::vector<unsigned int> &E){
+ unsigned int max = 0;
+ for(unsigned int i = 0; i < V.size(); i++)