summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-06-13 09:26:07 +0200
committerAntonio Rojas2022-06-13 09:26:07 +0200
commit653d6ca499a87eeb5d3e7e6a29327292b5406215 (patch)
tree353116f4b3dc19c04504f474d559a24e7cfe78de
parent0471ccdac851d3d4a9c4c56a550fea068ecaab7f (diff)
downloadaur-653d6ca499a87eeb5d3e7e6a29327292b5406215.tar.gz
Rebase patches
-rw-r--r--PKGBUILD12
-rw-r--r--sage_docbuild.patch48
-rw-r--r--sagemath-bliss-0.77.patch73
3 files changed, 58 insertions, 75 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b9fb5f81da7..e76fd05e8215 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
pkgname=sagemath-git
-pkgver=9.7.beta0.r0.g6f4efb0bf37
+pkgver=9.7.beta2.r0.ga6e696e91d2
pkgrel=1
pkgdesc='Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab'
arch=(x86_64)
@@ -58,14 +58,16 @@ source=(git://git.sagemath.org/sage.git#branch=develop
test-optional.patch
sagemath-linbox-1.7.patch
sagemath-bliss-0.77.patch
- sagemath-tachyon-0.99.patch)
+ sagemath-tachyon-0.99.patch
+ sage_docbuild.patch)
sha256sums=('SKIP'
'eee5fa15d8c7be7e009166dbde3ea24bb10d7793dc12880516f278f86b1a6694'
'bd188af45ce31579b82407adee8e9bf6033a996f7ea6e328fabca526f31c08ba'
'9d042070df3dfd53a1248659677798da888f733548eda91a6d5169c7aa1907e1'
'eacea27b214d32cb886a75695153dfc36b5bad2fd2517e8e4eee18e74220e9e3'
- 'b467a41e1e0a0850f7722d875a743233751966a206c2f61401c7582aa722f84e'
- '4ee8071efd7b9ad66ac5bbfe081fe670cc58cfcac8fb783d5a40b6da3593cbf4')
+ '3d461a21b9e66cf1884b7cfa20205709ce90f761b7bb2909b6520ad9677494bd'
+ '4ee8071efd7b9ad66ac5bbfe081fe670cc58cfcac8fb783d5a40b6da3593cbf4'
+ '7e1b9caa70e882356cd1c5e7fa69b68e5c60550b6bc8b3c9753441b1ad63da3d')
pkgver() {
cd sage
@@ -82,6 +84,8 @@ prepare(){
patch -p1 -i ../sagemath-bliss-0.77.patch
# Fix tests with tachyon 0.99 https://trac.sagemath.org/ticket/23712
patch -p1 -i ../sagemath-tachyon-0.99.patch
+# Remove sage_docbuild runtime dependency
+ patch -p1 -i ../sage_docbuild.patch
# Arch-specific patches
# assume all optional packages are installed
diff --git a/sage_docbuild.patch b/sage_docbuild.patch
new file mode 100644
index 000000000000..3d019d96ae2f
--- /dev/null
+++ b/sage_docbuild.patch
@@ -0,0 +1,48 @@
+diff --git a/src/sage/misc/sagedoc_conf.py b/src/sage/misc/sagedoc_conf.py
+new file mode 100644
+index 00000000..323628a
+--- /dev/null
++++ b/src/sage/misc/sagedoc_conf.py
+@@ -0,0 +1,6 @@
++r"""
++Sphinx configuration shared by sage.misc.sphinxify and sage_docbuild
++"""
++
++# The reST default role (used for this markup: `text`) to use for all documents.
++default_role = 'math'
+diff --git a/src/sage/misc/sphinxify.py b/src/sage/misc/sphinxify.py
+index d196965..8cfa8af 100644
+--- a/src/sage/misc/sphinxify.py
++++ b/src/sage/misc/sphinxify.py
+@@ -87,7 +87,7 @@ def sphinxify(docstring, format='html'):
+ os.makedirs(confdir)
+ with open(os.path.join(confdir, 'conf.py'), 'w') as filed:
+ filed.write(r"""
+-from sage_docbuild.conf import *
++from sage.misc.sagedoc_conf import *
+ extensions = ['sphinx.ext.autodoc', 'sphinx.ext.mathjax', 'sphinx.ext.todo', 'sphinx.ext.extlinks']
+
+ templates_path = ['templates']
+diff --git a/src/sage_docbuild/conf.py b/src/sage_docbuild/conf.py
+index c0866c0..12a76ac 100644
+--- a/src/sage_docbuild/conf.py
++++ b/src/sage_docbuild/conf.py
+@@ -14,6 +14,8 @@ from sphinx import highlighting
+ import sphinx.ext.intersphinx as intersphinx
+ from IPython.lib.lexers import IPythonConsoleLexer, IPyLexer
+
++# Load configuration shared with sage.misc.sphinxify
++from sage.misc.sagedoc_conf import *
+
+ # General configuration
+ # ---------------------
+@@ -149,9 +151,6 @@ release = sage.version.version
+ # separators on all platforms.
+ exclude_patterns = ['.build']
+
+-# The reST default role (used for this markup: `text`) to use for all documents.
+-default_role = 'math'
+-
+ # If true, '()' will be appended to :func: etc. cross-reference text.
+ #add_function_parentheses = True
+
diff --git a/sagemath-bliss-0.77.patch b/sagemath-bliss-0.77.patch
index 4f95bcedf635..769befdc8eb5 100644
--- a/sagemath-bliss-0.77.patch
+++ b/sagemath-bliss-0.77.patch
@@ -1,34 +1,3 @@
-diff --git a/build/pkgs/bliss/SPKG.rst b/build/pkgs/bliss/SPKG.rst
-index 236b87a199..77407f16ac 100644
---- a/build/pkgs/bliss/SPKG.rst
-+++ b/build/pkgs/bliss/SPKG.rst
-@@ -10,20 +10,19 @@ canonical forms of graphs.
- License
- -------
-
--LGPL
-+LGPL3
-
-
- Upstream Contact
- ----------------
-
--Bliss is currently being maintained by Tommi Junttila and Petteri Kaski.
-+Bliss is currently being maintained by Tommi Junttila at
-
--http://www.tcs.tkk.fi/Software/bliss/index.html
-+https://users.aalto.fi/~tjunttil/bliss/index.html
-+
-+Bliss used to be maintained by Tommi Junttila and Petteri Kaski up to version 0.73 at
-
--We apply patches generated from https://github.com/mkoeppe/bliss (branch
--apply_debian_patches) as our upstream. This tracks the patches from the
--Debian package, adding an autotools build system and adjusting the
--include file locations.
-+http://www.tcs.tkk.fi/Software/bliss/index.html
-
- Dependencies
- ------------
diff --git a/build/pkgs/bliss/checksums.ini b/build/pkgs/bliss/checksums.ini
index e97d89587b..0c1ebf647b 100644
--- a/build/pkgs/bliss/checksums.ini
@@ -44,7 +13,7 @@ index e97d89587b..0c1ebf647b 100644
+cksum=1626493724
+upstream_url=https://users.aalto.fi/~tjunttil/bliss/downloads/bliss-VERSION.zip
diff --git a/build/pkgs/bliss/dependencies b/build/pkgs/bliss/dependencies
-index 3546cda461..66d6773d90 100644
+index 4f00de2037..c225c495cc 100644
--- a/build/pkgs/bliss/dependencies
+++ b/build/pkgs/bliss/dependencies
@@ -1,4 +1,4 @@
@@ -60,44 +29,6 @@ index e93ee1376f..9e1e206c41 100644
@@ -1 +1 @@
-0.73+debian-1+sage-2016-08-02.p0
+0.77
-diff --git a/build/pkgs/bliss/patches/bliss-0.77-install.patch b/build/pkgs/bliss/patches/bliss-0.77-install.patch
-new file mode 100644
-index 0000000000..caab14aa40
---- /dev/null
-+++ b/build/pkgs/bliss/patches/bliss-0.77-install.patch
-@@ -0,0 +1,32 @@
-+diff --git a/CMakeLists.txt b/CMakeLists.txt
-+index 01ed093..cfdb0a6 100644
-+--- a/CMakeLists.txt
-++++ b/CMakeLists.txt
-+@@ -62,3 +62,27 @@ if(USE_GMP)
-+ target_link_libraries(bliss-executable ${GMP_LIBRARIES})
-+ endif(USE_GMP)
-+ set_target_properties(bliss-executable PROPERTIES OUTPUT_NAME bliss)
-++
-++include(GNUInstallDirs)
-++
-++set(
-++ BLISS_HEADERS
-++ src/bliss_C.h
-++ src/uintseqhash.hh
-++ src/abstractgraph.hh
-++ src/stats.hh
-++ src/digraph.hh
-++ src/defs.hh
-++ src/heap.hh
-++ src/graph.hh
-++ src/partition.hh
-++ src/kqueue.hh
-++ src/utils.hh
-++ src/orbit.hh
-++ src/timer.hh
-++ src/bignum.hh
-++)
-++
-++install(TARGETS bliss-executable RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
-++install(TARGETS bliss LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
-++install(FILES ${BLISS_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/bliss)
diff --git a/build/pkgs/bliss/spkg-install.in b/build/pkgs/bliss/spkg-install.in
index aaf4c3037b..4124a2338e 100644
--- a/build/pkgs/bliss/spkg-install.in
@@ -143,7 +74,7 @@ index 90073233b7..0000000000
-
-
diff --git a/src/sage/graphs/bliss.pyx b/src/sage/graphs/bliss.pyx
-index bf15833664..4f4e0ee3ca 100644
+index 921bc6a765..1f1f502558 100644
--- a/src/sage/graphs/bliss.pyx
+++ b/src/sage/graphs/bliss.pyx
@@ -47,22 +47,23 @@ cdef extern from "bliss/graph.hh" namespace "bliss":