summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-07-24 22:24:50 +0200
committerAntonio Rojas2022-07-24 22:24:50 +0200
commit723ba0032a7188e9e201cd140a82f89b6289192c (patch)
tree6ea12e8a5aa8ac376bd9919d802ca6f9abac8fad
parent7acfaf8fc5b9851aea93bc69fbc20ae026c8c472 (diff)
downloadaur-723ba0032a7188e9e201cd140a82f89b6289192c.tar.gz
Rebase patches
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--sagemath-bliss-0.77.patch18
-rw-r--r--sagemath-tachyon-0.99.patch28
4 files changed, 30 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97c15eb5b9e4..3a1d38a799ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sagemath-git
pkgdesc = Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab
- pkgver = 9.7.beta5.r0.g625ac58151d
+ pkgver = 9.7.beta6.r0.g7f7149489cd
pkgrel = 1
url = http://www.sagemath.org
arch = x86_64
@@ -109,7 +109,7 @@ pkgbase = sagemath-git
sha256sums = bd188af45ce31579b82407adee8e9bf6033a996f7ea6e328fabca526f31c08ba
sha256sums = 9d042070df3dfd53a1248659677798da888f733548eda91a6d5169c7aa1907e1
sha256sums = eacea27b214d32cb886a75695153dfc36b5bad2fd2517e8e4eee18e74220e9e3
- sha256sums = 3d461a21b9e66cf1884b7cfa20205709ce90f761b7bb2909b6520ad9677494bd
- sha256sums = 1c5029a4abef9edd23b7b8197dafd1066420f3323485786c31b4e66cdf7906bd
+ sha256sums = 3e1f866944235b999d2d727ed1ced431bd67405b053701c21068607ec76f23c3
+ sha256sums = 9760db6c6ec40cc16ab8a0cbf3d019df7f6a69ff292e35622f282b7c888aac77
pkgname = sagemath-git
diff --git a/PKGBUILD b/PKGBUILD
index 1862ca020b49..2ccc0bafb9ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
pkgname=sagemath-git
-pkgver=9.7.beta5.r0.g625ac58151d
+pkgver=9.7.beta6.r0.g7f7149489cd
pkgrel=1
pkgdesc='Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab'
arch=(x86_64)
@@ -64,8 +64,8 @@ sha256sums=('SKIP'
'bd188af45ce31579b82407adee8e9bf6033a996f7ea6e328fabca526f31c08ba'
'9d042070df3dfd53a1248659677798da888f733548eda91a6d5169c7aa1907e1'
'eacea27b214d32cb886a75695153dfc36b5bad2fd2517e8e4eee18e74220e9e3'
- '3d461a21b9e66cf1884b7cfa20205709ce90f761b7bb2909b6520ad9677494bd'
- '1c5029a4abef9edd23b7b8197dafd1066420f3323485786c31b4e66cdf7906bd')
+ '3e1f866944235b999d2d727ed1ced431bd67405b053701c21068607ec76f23c3'
+ '9760db6c6ec40cc16ab8a0cbf3d019df7f6a69ff292e35622f282b7c888aac77')
pkgver() {
cd sage
@@ -82,7 +82,7 @@ prepare(){
patch -p1 -i ../sagemath-bliss-0.77.patch
# Fix tests with tachyon 0.99 https://trac.sagemath.org/ticket/23712
patch -p1 -i ../sagemath-tachyon-0.99.patch
-
+
# Arch-specific patches
# assume all optional packages are installed
patch -p1 -i ../sagemath-optional-packages.patch
diff --git a/sagemath-bliss-0.77.patch b/sagemath-bliss-0.77.patch
index 769befdc8eb5..ad4dbc6de3e2 100644
--- a/sagemath-bliss-0.77.patch
+++ b/sagemath-bliss-0.77.patch
@@ -81,11 +81,11 @@ index 921bc6a765..1f1f502558 100644
cdef cppclass Graph(AbstractGraph):
Graph(const unsigned int)
void add_edge(const unsigned int, const unsigned int)
-- void find_automorphisms(Stats&, void (*)(void* , unsigned int,
-- const unsigned int*), void*)
+- void find_automorphisms(Stats&, void (*)(void*, unsigned int,
+- const unsigned int*), void*)
void change_color(const unsigned int, const unsigned int)
-- const unsigned int* canonical_form(Stats&, void (*)(void*,unsigned int,
-- const unsigned int*), void*)
+- const unsigned int* canonical_form(Stats&, void (*)(void*, unsigned int,
+- const unsigned int*), void*)
+ const unsigned int* canonical_form(Stats&)
+
+cdef extern from "bliss/digraph.hh" namespace "bliss":
@@ -93,11 +93,11 @@ index 921bc6a765..1f1f502558 100644
cdef cppclass Digraph(AbstractGraph):
Digraph(const unsigned int)
void add_edge(const unsigned int, const unsigned int)
-- void find_automorphisms(Stats&, void (*)(void* , unsigned int,
-- const unsigned int*), void*)
+- void find_automorphisms(Stats&, void (*)(void*, unsigned int,
+- const unsigned int*), void*)
void change_color(const unsigned int, const unsigned int)
-- const unsigned int* canonical_form(Stats&, void (*)(void*,unsigned int,
-- const unsigned int*), void*)
+- const unsigned int* canonical_form(Stats&, void (*)(void*, unsigned int,
+- const unsigned int*), void*)
+ const unsigned int* canonical_form(Stats&)
unsigned int get_hash()
@@ -113,7 +113,7 @@ index 921bc6a765..1f1f502558 100644
sig_free(done)
--cdef void empty_hook(void *user_param , unsigned int n, const unsigned int *aut):
+-cdef void empty_hook(void *user_param, unsigned int n, const unsigned int *aut):
- return
-
#####################################################
diff --git a/sagemath-tachyon-0.99.patch b/sagemath-tachyon-0.99.patch
index 77f97c6fd54d..ac70a6614cdf 100644
--- a/sagemath-tachyon-0.99.patch
+++ b/sagemath-tachyon-0.99.patch
@@ -1,22 +1,22 @@
--- a/src/sage/interfaces/tachyon.py
+++ b/src/sage/interfaces/tachyon.py
@@ -140,14 +140,14 @@ written in the sequence they are listed in the examples in this section.
- The ``PROJECTION`` keyword must be followed by one of the supported
- camera projection mode identifiers ``PERSPECTIVE``, ``PERSPECTIVE_DOF``,
- ``ORTHOGRAPHIC``, or ``FISHEYE``. The ``FISHEYE`` projection mode
-- requires two extra parameters ``FOCALLENGTH`` and ``APERTURE`` which
-+ requires two extra parameters ``FOCALDIST`` and ``APERTURE`` which
- precede the regular camera options.
+ The ``PROJECTION`` keyword must be followed by one of the supported
+ camera projection mode identifiers ``PERSPECTIVE``, ``PERSPECTIVE_DOF``,
+ ``ORTHOGRAPHIC``, or ``FISHEYE``. The ``FISHEYE`` projection mode
+-requires two extra parameters ``FOCALLENGTH`` and ``APERTURE`` which
++requires two extra parameters ``FOCALDIST`` and ``APERTURE`` which
+ precede the regular camera options.
- ::
+ ::
- Camera
- projection perspective_dof
-- focallength 0.75
-+ FOCALDIST 0.75
- aperture 0.02
- Zoom 0.666667
- Aspectratio 1.000000
+ Camera
+ projection perspective_dof
+- focallength 0.75
++ FOCALDIST 0.75
+ aperture 0.02
+ Zoom 0.666667
+ Aspectratio 1.000000
--- a/src/sage/plot/plot3d/tachyon.py
+++ b/src/sage/plot/plot3d/tachyon.py
@@ -92,7 +92,7 @@ angle, right angle)::