summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-07-16 17:21:51 +0000
committerAntonio Rojas2019-07-16 17:21:51 +0000
commit966a158e1e31d2495000c4501402ff958a3fdfc9 (patch)
treea0b66075dc2f8d4fb9db48a4d3f65ff87a151b04
parent8fcd0c672a28c35da734313ffd1ab941365fabbd (diff)
downloadaur-966a158e1e31d2495000c4501402ff958a3fdfc9.tar.gz
Sync patches with stable
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--sagemath-python3-notebook.patch25
3 files changed, 11 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7756288c1f9a..dae9c5603e11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -108,10 +108,10 @@ pkgbase = sagemath-git
source = sagemath-ecl-sigfpe.patch
source = sagemath-linbox-1.6.patch
sha256sums = SKIP
- sha256sums = d894b241dbde0f201ce0d83329591820ca2471d7328d945aea0624f8bc22c000
+ sha256sums = 7177ff3e3f27939d45210e7e69da110441830a6e2279ee7d7e4fca26db99c3f4
sha256sums = 328e45e78065b5f6527174bda48cfff6828acbf107c2535b0a9a92c3ceb35842
sha256sums = 596d03daf53a76b04029b120619253250b0e58d530d69f14afa169e27e06f446
- sha256sums = 7be9f88975079d671eb3cde78e752e74741bcc29ba9b323bab5cddf50ce6dec9
+ sha256sums = e554cdf689100c787a5fbcb7fe281cd68bef081e08bd58df8be1d113a4665d7e
sha256sums = 1f2a34e15bf732ec8687c467a52e897615505dc3ddd792d811e8b6a7e19f1517
sha256sums = 7fcb52e96935dccb0f958d37c2f4e3918392480b9af53e08562f6cba6c68cb94
sha256sums = a8c1409f4b4f1553b4f7602d4a6f0f3c6297ed258feed079f6560b0ec2dc62c6
diff --git a/PKGBUILD b/PKGBUILD
index 8c030920b6c4..ef4d0c81d471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,7 +50,7 @@ sha256sums=('SKIP'
'7177ff3e3f27939d45210e7e69da110441830a6e2279ee7d7e4fca26db99c3f4'
'328e45e78065b5f6527174bda48cfff6828acbf107c2535b0a9a92c3ceb35842'
'596d03daf53a76b04029b120619253250b0e58d530d69f14afa169e27e06f446'
- '7be9f88975079d671eb3cde78e752e74741bcc29ba9b323bab5cddf50ce6dec9'
+ 'e554cdf689100c787a5fbcb7fe281cd68bef081e08bd58df8be1d113a4665d7e'
'1f2a34e15bf732ec8687c467a52e897615505dc3ddd792d811e8b6a7e19f1517'
'7fcb52e96935dccb0f958d37c2f4e3918392480b9af53e08562f6cba6c68cb94'
'a8c1409f4b4f1553b4f7602d4a6f0f3c6297ed258feed079f6560b0ec2dc62c6'
diff --git a/sagemath-python3-notebook.patch b/sagemath-python3-notebook.patch
index 1892e23c399e..9ca667817848 100644
--- a/sagemath-python3-notebook.patch
+++ b/sagemath-python3-notebook.patch
@@ -2,26 +2,17 @@ diff --git a/src/bin/sage-notebook b/src/bin/sage-notebook
index 74192da240..0ede281aad 100755
--- a/src/bin/sage-notebook
+++ b/src/bin/sage-notebook
-@@ -95,8 +95,7 @@ class NotebookJupyter(object):
- if not have_prerequisites():
- print(self.PREREQUISITE_ERROR)
- raise SystemExit(1)
+@@ -91,12 +91,7 @@ class NotebookJupyter(object):
+
+ def __init__(self, argv):
+ self.print_banner()
+- from sage.repl.ipython_kernel.install import have_prerequisites
+- if not have_prerequisites():
+- print(self.PREREQUISITE_ERROR)
+- raise SystemExit(1)
- from notebook.notebookapp import main
- main(argv)
+ os.execvp('jupyter-notebook', ['jupyter-notebook'] + argv)
class NotebookJupyterlab(object):
-diff --git a/src/sage/repl/ipython_kernel/install.py b/src/sage/repl/ipython_kernel/install.py
-index 3912b8cdf5..bd40cdadda 100644
---- a/src/sage/repl/ipython_kernel/install.py
-+++ b/src/sage/repl/ipython_kernel/install.py
-@@ -304,7 +304,6 @@ def have_prerequisites(debug=True):
- True
- """
- try:
-- from notebook.notebookapp import NotebookApp
- return True
- except ImportError:
- if debug:
-