summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-12-06 23:30:29 +0000
committerAntonio Rojas2017-12-06 23:30:29 +0000
commit9fa6f300d233124c2fd16d8f5fc3043c2eddb6aa (patch)
tree5094aa85a62e6cc724f80bd332b8a2871441fcfd
parent77b7fbd4cbff662b98c569f9d0ef44e381ecfdc4 (diff)
downloadaur-9fa6f300d233124c2fd16d8f5fc3043c2eddb6aa.tar.gz
Sync with stable
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--sagemath-pynac-0.7.14.patch167
3 files changed, 174 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00ed1c09b6e1..326d677ff77a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -104,6 +104,7 @@ pkgbase = sagemath-git
source = sagemath-detect-igraph.patch
source = sagemath-networkx2.patch
source = sagemath-linbox-1.5.patch
+ source = sagemath-pynac-0.7.14.patch
sha256sums = SKIP
sha256sums = 8c4ed4c1f3bb79fb279efa5267a78d0d093c718377b5aa0457b642e50f60811a
sha256sums = c41ae665499c6cd775d40bbe178f8786830b0931ee26bf11ee02f7d83bcc8107
@@ -118,6 +119,7 @@ pkgbase = sagemath-git
sha256sums = 28d7789b8d777922ab8871ca43b6afab751428cae875c0343d3962e6a2030b88
sha256sums = 37c5c1e694a2aca06c0f1c7d99622ff81fd2bc6a51e8745762294889fa4673f6
sha256sums = a52d03e04c9d64bb957a1f8dcdae3280ebb9450a7fd76aaf5ae5de5c6f74774f
+ sha256sums = 538f7b279d72f4b67edb445d386d267f3f7022c1079031ca7ea06f6ce392c906
pkgname = sagemath-git
optdepends = cython2: to compile cython code
diff --git a/PKGBUILD b/PKGBUILD
index 231bb05b791d..96477ee76442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,7 +37,7 @@ makedepends=(cython2 boost ratpoints symmetrica python2-jinja coin-or-cbc libhom
source=(git://git.sagemath.org/sage.git#branch=develop
env.patch package.patch latte-count.patch jupyter-path.patch sagemath-python3-notebook.patch test-optional.patch
r-no-readline.patch fes02.patch sagemath-ecl-no-sigfpe.patch sagemath-threejs.patch
- sagemath-detect-igraph.patch sagemath-networkx2.patch sagemath-linbox-1.5.patch)
+ sagemath-detect-igraph.patch sagemath-networkx2.patch sagemath-linbox-1.5.patch sagemath-pynac-0.7.14.patch)
sha256sums=('SKIP'
'8c4ed4c1f3bb79fb279efa5267a78d0d093c718377b5aa0457b642e50f60811a'
'c41ae665499c6cd775d40bbe178f8786830b0931ee26bf11ee02f7d83bcc8107'
@@ -51,7 +51,8 @@ sha256sums=('SKIP'
'514135b920a43f999571a15e97b41e14f5bed59f65b19643864dc23555a7b830'
'28d7789b8d777922ab8871ca43b6afab751428cae875c0343d3962e6a2030b88'
'37c5c1e694a2aca06c0f1c7d99622ff81fd2bc6a51e8745762294889fa4673f6'
- 'a52d03e04c9d64bb957a1f8dcdae3280ebb9450a7fd76aaf5ae5de5c6f74774f')
+ 'a52d03e04c9d64bb957a1f8dcdae3280ebb9450a7fd76aaf5ae5de5c6f74774f'
+ '538f7b279d72f4b67edb445d386d267f3f7022c1079031ca7ea06f6ce392c906')
pkgver() {
cd sage
@@ -93,6 +94,8 @@ prepare(){
# patch -p1 -i ../sagemath-ecl-no-sigfpe.patch
# fix build with linbox 1.5 https://trac.sagemath.org/ticket/24214
patch -p1 -i ../sagemath-linbox-1.5.patch
+# fix build with pynac 0.7.14 https://trac.sagemath.org/ticket/24329
+ patch -p1 -i ../sagemath-pynac-0.7.14.patch
# use python2
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' -e 's|exec python|exec python2|' -i src/bin/*
diff --git a/sagemath-pynac-0.7.14.patch b/sagemath-pynac-0.7.14.patch
new file mode 100644
index 000000000000..322b51e04efd
--- /dev/null
+++ b/sagemath-pynac-0.7.14.patch
@@ -0,0 +1,167 @@
+diff --git a/src/sage/libs/pynac/pynac.pxd b/src/sage/libs/pynac/pynac.pxd
+index d4afc4e..6d1fcac 100644
+--- a/src/sage/libs/pynac/pynac.pxd
++++ b/src/sage/libs/pynac/pynac.pxd
+@@ -481,22 +481,17 @@ cdef extern from "pynac_wrap.h":
+ ctypedef GParamSet const_paramset_ref "const GiNaC::paramset&"
+
+ ctypedef struct py_funcs_struct:
+- py_binomial(a, b)
+- py_binomial_int(int n, unsigned int k)
+ py_gcd(a, b)
+ py_lcm(a, b)
+ py_real(a)
+ py_imag(a)
+ py_numer(a)
+ py_denom(a)
+- py_conjugate(a)
+ bint py_is_rational(a)
+- bint py_is_crational(a)
+ bint py_is_real(a)
+ bint py_is_integer(a)
+ bint py_is_equal(a, b)
+ bint py_is_even(a)
+- bint py_is_cinteger(a)
+ bint py_is_prime(n)
+ bint py_is_exact(x)
+
+@@ -534,23 +529,14 @@ cdef extern from "pynac_wrap.h":
+ py_asinh(x)
+ py_acosh(x)
+ py_atanh(x)
+- py_tgamma(x)
+- py_lgamma(x)
+ py_isqrt(x)
+ py_sqrt(x)
+- py_abs(x)
+ py_mod(x, y)
+ py_smod(x, y)
+ py_irem(x, y)
+- py_iquo(x, y)
+- py_iquo2(x, y)
+- py_li(x, n, parent)
+- py_li2(x)
+ py_psi(x)
+ py_psi2(n, x)
+
+- int py_int_length(x) except -1
+-
+ py_eval_constant(unsigned serial, parent)
+ py_eval_unsigned_infinity()
+ py_eval_infinity()
+@@ -583,8 +569,6 @@ cdef extern from "pynac_wrap.h":
+ stdstring* py_latex_fderivative(unsigned id, params, args)
+ paramset_to_PyTuple(const_paramset_ref s)
+
+- py_rational_power_parts(basis, exp)
+-
+ py_funcs_struct py_funcs "GiNaC::py_funcs"
+
+ cdef extern from "pynac/order.h":
+diff --git a/src/sage/libs/pynac/pynac.pyx b/src/sage/libs/pynac/pynac.pyx
+index f303184..419cc47 100644
+--- a/src/sage/libs/pynac/pynac.pyx
++++ b/src/sage/libs/pynac/pynac.pyx
+@@ -2432,23 +2432,18 @@ def init_function_table():
+ called before Pynac is used; otherwise, there will be segfaults.
+ """
+
+- py_funcs.py_binomial_int = &py_binomial_int
+- py_funcs.py_binomial = &py_binomial
+ py_funcs.py_gcd = &py_gcd
+ py_funcs.py_lcm = &py_lcm
+ py_funcs.py_real = &py_real
+ py_funcs.py_imag = &py_imag
+ py_funcs.py_numer = &py_numer
+ py_funcs.py_denom = &py_denom
+- py_funcs.py_conjugate = &py_conjugate
+
+ py_funcs.py_is_rational = &py_is_rational
+- py_funcs.py_is_crational = &py_is_crational
+ py_funcs.py_is_real = &py_is_real
+ py_funcs.py_is_integer = &py_is_integer
+ py_funcs.py_is_equal = &py_is_equal
+ py_funcs.py_is_even = &py_is_even
+- py_funcs.py_is_cinteger = &py_is_cinteger
+ py_funcs.py_is_prime = &py_is_prime
+ py_funcs.py_is_exact = &py_is_exact
+
+@@ -2462,7 +2457,6 @@ def init_function_table():
+ py_funcs.py_mpq_from_rational = &py_mpq_from_rational
+
+ py_funcs.py_float = &py_float
+- py_funcs.py_RDF_from_double = &py_RDF_from_double
+
+ py_funcs.py_factorial = &py_factorial
+ py_funcs.py_doublefactorial = &py_doublefactorial
+@@ -2486,23 +2480,14 @@ def init_function_table():
+ py_funcs.py_asinh = &py_asinh
+ py_funcs.py_acosh = &py_acosh
+ py_funcs.py_atanh = &py_atanh
+- py_funcs.py_tgamma = &py_tgamma
+- py_funcs.py_lgamma = &py_lgamma
+ py_funcs.py_isqrt = &py_isqrt
+ py_funcs.py_sqrt = &py_sqrt
+- py_funcs.py_abs = &py_abs
+ py_funcs.py_mod = &py_mod
+ py_funcs.py_smod = &py_smod
+ py_funcs.py_irem = &py_irem
+- py_funcs.py_iquo = &py_iquo
+- py_funcs.py_iquo2 = &py_iquo2
+- py_funcs.py_li = &py_li
+- py_funcs.py_li2 = &py_li2
+ py_funcs.py_psi = &py_psi
+ py_funcs.py_psi2 = &py_psi2
+
+- py_funcs.py_int_length = &py_int_length
+-
+ py_funcs.py_eval_constant = &py_eval_constant
+ py_funcs.py_eval_unsigned_infinity = &py_eval_unsigned_infinity
+ py_funcs.py_eval_infinity = &py_eval_infinity
+@@ -2531,7 +2516,6 @@ def init_function_table():
+ py_funcs.py_print_fderivative = &py_print_fderivative
+ py_funcs.py_latex_fderivative = &py_latex_fderivative
+ py_funcs.paramset_to_PyTuple = &paramset_to_PyTuple
+- py_funcs.py_rational_power_parts = &py_rational_power_parts
+
+ init_function_table()
+ init_pynac_I()
+
+diff --git a/src/sage/functions/other.py b/src/sage/functions/other.py
+index 81cd485..931cecc 100644
+--- a/src/sage/functions/other.py
++++ b/src/sage/functions/other.py
+@@ -688,7 +688,6 @@ class Function_gamma(GinacFunction):
+ :meth:`sage.functions.other.gamma`
+ """
+ GinacFunction.__init__(self, 'gamma', latex_name=r"\Gamma",
+- ginac_name='tgamma',
+ conversions={'mathematica':'Gamma',
+ 'maple':'GAMMA',
+ 'sympy':'gamma',
+diff --git a/src/sage/libs/pynac/pynac.pxd b/src/sage/libs/pynac/pynac.pxd
+index 1739067..d4afc4e 100644
+--- a/src/sage/libs/pynac/pynac.pxd
++++ b/src/sage/libs/pynac/pynac.pxd
+@@ -362,7 +362,7 @@ cdef extern from "pynac_wrap.h":
+ GEx g_zeta2 "GiNaC::zeta" (GEx m, GEx s) except + # alternating Euler sum
+ GEx g_stieltjes "GiNaC::stieltjes" (GEx m) except + # Stieltjes constants
+ GEx g_zetaderiv "GiNaC::zetaderiv" (GEx n, GEx x) except + # derivatives of Riemann's zeta function
+- GEx g_tgamma "GiNaC::tgamma" (GEx x) except + # gamma function
++ GEx g_gamma "GiNaC::gamma" (GEx x) except + # gamma function
+ GEx g_lgamma "GiNaC::lgamma" (GEx x) except + # logarithm of gamma function
+ GEx g_beta "GiNaC::beta" (GEx x, GEx y) except + # beta function (tgamma(x)*tgamma(y)/tgamma(x+y))
+ GEx g_psi "GiNaC::psi" (GEx x) except + # psi (digamma) function
+diff --git a/src/sage/symbolic/expression.pyx b/src/sage/symbolic/expression.pyx
+index dfb8751..52303d1 100644
+--- a/src/sage/symbolic/expression.pyx
++++ b/src/sage/symbolic/expression.pyx
+@@ -8917,7 +8917,7 @@ cdef class Expression(CommutativeRingElement):
+ cdef GEx x
+ sig_on()
+ try:
+- x = g_hold_wrapper(g_tgamma, self._gobj, hold)
++ x = g_hold_wrapper(g_gamma, self._gobj, hold)
+ finally:
+ sig_off()
+ return new_Expression_from_GEx(self._parent, x)