summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-10-12 23:33:58 +0000
committerAntonio Rojas2019-10-12 23:33:58 +0000
commitbb8ad09bb6ef27ab63054753340f40fcff1b0e8d (patch)
treeddeff62b4b0ca0bb2373763b92ace82b767fcdd4
parente1c162f1d8ae499e686d0a43d8e2e58463c18b50 (diff)
downloadaur-bb8ad09bb6ef27ab63054753340f40fcff1b0e8d.tar.gz
Drop merged patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--sagemath-mathjax-dir.patch27
3 files changed, 9 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f88fab6da25..791fba319b58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sagemath-git
pkgdesc = Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab
- pkgver = 9.0.beta0.r0.g533fd5d6cd
+ pkgver = 9.0.beta1.r0.g0f20b37ca8
pkgrel = 1
url = http://www.sagemath.org
arch = x86_64
@@ -105,7 +105,6 @@ pkgbase = sagemath-git
source = sagemath-ecl-sigfpe.patch
source = sagemath-ipython7.patch
source = sagemath-rpy-3.patch
- source = sagemath-mathjax-dir.patch
sha256sums = SKIP
sha256sums = 328e45e78065b5f6527174bda48cfff6828acbf107c2535b0a9a92c3ceb35842
sha256sums = 1a82372a96ffd5e6d475b0e620935967ce5eb9b4484607d39da90824a77b07c4
@@ -116,7 +115,6 @@ pkgbase = sagemath-git
sha256sums = a42f3b152b1aedb8abf16bc70971419919d1fe30328574e7fef8305f9d07d938
sha256sums = 1336f8ce3ef2fbc7531da90b60b83cf8b7713cbf726cff6fdbbd30f085c31074
sha256sums = 9062b412595e81a5ca560a5ae789f8b7318981689cb8d076b30d8c54a4fc4495
- sha256sums = 388cd321fb8b73ae839bf2c150f7dd26ba34b0f6845f9761184db1dd5086b697
pkgname = sagemath-git
optdepends = cython: to compile cython code
@@ -154,5 +152,5 @@ pkgname = sagemath-jupyter-git
depends = sagemath
depends = python-jupyter_client
depends = python-ipywidgets
- depends = jsmol
+ optdepends = jsmol: alternative 3D plot engine
diff --git a/PKGBUILD b/PKGBUILD
index 14d94a2ad50a..0f0248b86ce7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=sagemath-git
pkgname=(sagemath-git sagemath-jupyter-git)
-pkgver=9.0.beta0.r0.g533fd5d6cd
+pkgver=9.0.beta1.r0.g0f20b37ca8
pkgrel=1
pkgdesc="Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab"
arch=(x86_64)
@@ -42,8 +42,7 @@ source=(git://git.sagemath.org/sage.git#branch=develop
sagemath-singular-4.1.2.patch
sagemath-ecl-sigfpe.patch
sagemath-ipython7.patch
- sagemath-rpy-3.patch
- sagemath-mathjax-dir.patch)
+ sagemath-rpy-3.patch)
sha256sums=('SKIP'
'328e45e78065b5f6527174bda48cfff6828acbf107c2535b0a9a92c3ceb35842'
'1a82372a96ffd5e6d475b0e620935967ce5eb9b4484607d39da90824a77b07c4'
@@ -53,8 +52,7 @@ sha256sums=('SKIP'
'961bfb5694b67d425d21240d71490cb71714b5207c23448c89be0966512ff8f9'
'a42f3b152b1aedb8abf16bc70971419919d1fe30328574e7fef8305f9d07d938'
'1336f8ce3ef2fbc7531da90b60b83cf8b7713cbf726cff6fdbbd30f085c31074'
- '9062b412595e81a5ca560a5ae789f8b7318981689cb8d076b30d8c54a4fc4495'
- '388cd321fb8b73ae839bf2c150f7dd26ba34b0f6845f9761184db1dd5086b697')
+ '9062b412595e81a5ca560a5ae789f8b7318981689cb8d076b30d8c54a4fc4495')
pkgver() {
cd sage
@@ -75,6 +73,8 @@ prepare(){
patch -p1 -i ../sagemath-ipython7.patch
# Adapt to rpy 3.0 changes
patch -p1 -i ../sagemath-rpy-3.patch
+# Fix mathjax path
+ sed -e 's|mathjax|mathjax2|g' -i src/sage/env.py
# Upstream patches
# fix build against libfes 0.2 http://trac.sagemath.org/ticket/15209
@@ -85,8 +85,6 @@ prepare(){
patch -p1 -i ../sagemath-singular-4.1.2.patch
# Fix SIGFPE crashes with ecl 16.1.3 https://trac.sagemath.org/ticket/22191
patch -p1 -i ../sagemath-ecl-sigfpe.patch
-# Don't hardcode mathjax path https://trac.sagemath.org/ticket/28547
- patch -p1 -i ../sagemath-mathjax-dir.patch
sed -e 's|sage-python23|python|' -i src/bin/*
sed -e 's|$SAGE_PYTHON3|yes|' -i src/bin/sage
@@ -140,7 +138,8 @@ package_sagemath-git() {
package_sagemath-jupyter-git() {
pkgdesc='Jupyter kernel for SageMath'
- depends=(sagemath python-jupyter_client python-ipywidgets jsmol)
+ depends=(sagemath python-jupyter_client python-ipywidgets)
+ optdepends=('jsmol: alternative 3D plot engine')
cd sage/src
diff --git a/sagemath-mathjax-dir.patch b/sagemath-mathjax-dir.patch
deleted file mode 100644
index f7f407fd9c7d..000000000000
--- a/sagemath-mathjax-dir.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/src/sage/docs/conf.py b/src/sage/docs/conf.py
-index 401342da5b..12c418ad93 100644
---- a/src/sage/docs/conf.py
-+++ b/src/sage/docs/conf.py
-@@ -1,5 +1,5 @@
- import sys, os, sphinx
--from sage.env import SAGE_DOC_SRC, SAGE_DOC, SAGE_SRC, THEBE_DIR, PPLPY_DOCS, SAGE_SHARE
-+from sage.env import SAGE_DOC_SRC, SAGE_DOC, SAGE_SRC, THEBE_DIR, PPLPY_DOCS, MATHJAX_DIR
- import sage.version
- from sage.misc.sagedoc import extlinks
- import dateutil.parser
-@@ -260,13 +260,12 @@ if (os.environ.get('SAGE_DOC_MATHJAX', 'no') != 'no'
- from sage.misc.latex_macros import sage_mathjax_macros
- html_theme_options['mathjax_macros'] = sage_mathjax_macros()
-
-- mathjax_relative = 'mathjax'
-+ mathjax_relative = os.path.basename(MATHJAX_DIR)
-
- # It would be really nice if sphinx would copy the entire mathjax directory,
- # (so we could have a _static/mathjax directory), rather than the contents of the directory
-
-- mathjax_static = os.path.join(SAGE_SHARE, mathjax_relative)
-- html_static_path.append(mathjax_static)
-+ html_static_path.append(MATHJAX_DIR)
- exclude_patterns += ['**/'+os.path.join(mathjax_relative, i)
- for i in ('docs', 'README*', 'test',
- 'unpacked', 'LICENSE')]