summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-12-05 07:42:58 +0000
committerAntonio Rojas2019-12-05 07:42:58 +0000
commitf3f8b96cd68377e78b039d3279142b23bde99e63 (patch)
tree149387ba55e39a15260563f9b3dae8e36d9bde31
parentaad054272d3ce7bd4fe56717fb646d41225e6a87 (diff)
downloadaur-f3f8b96cd68377e78b039d3279142b23bde99e63.tar.gz
DICT_IS_ORDERED is gone in ipython 7.10
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--sagemath-ipython7.patch20
3 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab4645516cee..90bb72871a4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -114,7 +114,7 @@ pkgbase = sagemath-git
sha256sums = 937074fa7a8a4e2aba9ea77ec622fe937985a1a9176c48460d51325ee877a4f5
sha256sums = 998e2c619d47849f977778906e2e492a09d8767b8f2e6d72a787368e7cf7b956
sha256sums = e44bbde87f3312548faad75b7383ef21fade55be251ab5804de41cd3842ca8a0
- sha256sums = 0eaf064df051852aa6601ec4fd93e076544a7f9bb4cef632f8ee07ac159a3097
+ sha256sums = a2688f139d53e7cd3bd4e4187571222463df7fdb55f574654e678fbaa86ac2f5
sha256sums = 9062b412595e81a5ca560a5ae789f8b7318981689cb8d076b30d8c54a4fc4495
sha256sums = bb1b0f45807c1badccd2f50d5ec6d0a8a98b35ab5ef0dbdfb4a6ec7efefbbd0e
diff --git a/PKGBUILD b/PKGBUILD
index 29ccb3517c2f..a600a37bc578 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,7 +52,7 @@ sha256sums=('SKIP'
'937074fa7a8a4e2aba9ea77ec622fe937985a1a9176c48460d51325ee877a4f5'
'998e2c619d47849f977778906e2e492a09d8767b8f2e6d72a787368e7cf7b956'
'e44bbde87f3312548faad75b7383ef21fade55be251ab5804de41cd3842ca8a0'
- '0eaf064df051852aa6601ec4fd93e076544a7f9bb4cef632f8ee07ac159a3097'
+ 'a2688f139d53e7cd3bd4e4187571222463df7fdb55f574654e678fbaa86ac2f5'
'9062b412595e81a5ca560a5ae789f8b7318981689cb8d076b30d8c54a4fc4495'
'bb1b0f45807c1badccd2f50d5ec6d0a8a98b35ab5ef0dbdfb4a6ec7efefbbd0e')
diff --git a/sagemath-ipython7.patch b/sagemath-ipython7.patch
index 03aa03d4cca4..2af60a47d285 100644
--- a/sagemath-ipython7.patch
+++ b/sagemath-ipython7.patch
@@ -1,3 +1,23 @@
+diff --git a/src/sage/doctest/forker.py b/src/sage/doctest/forker.py
+index d1e8bf7388..557fbb2942 100644
+--- a/src/sage/doctest/forker.py
++++ b/src/sage/doctest/forker.py
+@@ -183,15 +183,6 @@ def init_sage():
+ from sage.repl.rich_output.backend_doctest import BackendDoctest
+ dm.switch_backend(BackendDoctest())
+
+- # IPython's pretty printer sorts the repr of dicts by their keys by default
+- # (or their keys' str() if they are not otherwise orderable). However, it
+- # disables this for CPython 3.6+ opting to instead display dicts' "natural"
+- # insertion order, which is preserved in those versions). This makes for
+- # inconsistent results with Python 2 tests that return dicts, so here we
+- # force the Python 2 style dict printing
+- import IPython.lib.pretty
+- IPython.lib.pretty.DICT_IS_ORDERED = False
+-
+ # Switch on extra debugging
+ from sage.structure.debug_options import debug
+ debug.refine_category_hash_check = True
diff --git a/src/sage/algebras/cluster_algebra.py b/src/sage/algebras/cluster_algebra.py
index 4054bd5d9a..236b861c8a 100644
--- a/src/sage/algebras/cluster_algebra.py