summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-02-09 08:32:14 +0330
committerMohammadreza Abdollahzadeh2018-02-09 08:32:14 +0330
commit9cde299e2747b9b4215734ecb8e8c910de12e2ae (patch)
treeec4be3261edbfe334930f7cc794618b701d43881
parentdbe546e9821905e0acdcdf2c9c1e80db3be6b348 (diff)
downloadaur-9cde299e2747b9b4215734ecb8e8c910de12e2ae.tar.gz
update to v1.0.0_alpha14
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be692faecae5..5424bfe314d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
-# Generated by mksrcinfo v8
-# Fri Jan 27 09:15:19 UTC 2017
pkgbase = sahel-fonts
pkgdesc = A beautiful Persian font.
- pkgver = 1.0.0_alpha9
+ pkgver = 1.0.0_alpha14
pkgrel = 1
- url = https://rastikerdar.github.io/sahel-font/
+ url = https://github.com/rastikerdar/sahel-font
arch = any
license = OFL
depends = fontconfig
provides = ttf-sahel
- provides = sahel-fonts
conflicts = ttf-sahel
- conflicts = sahel-fonts
- replaces = ttf-sahel
- source = sahel-fonts-1.0.0_alpha9.zip::https://github.com/rastikerdar/sahel-font/releases/download/v1.0.0-alpha9/sahel-font-v1.0.0-alpha9.zip
- sha256sums = 07a5f04b23e86980d463c9e08267cc2e82eae59ab685ba5c584866c00311490b
+ source = sahel-fonts-1.0.0_alpha14.zip::https://github.com/rastikerdar/sahel-font/releases/download/v1.0.0-alpha14/sahel-font-v1.0.0-alpha14.zip
+ sha256sums = 04e63f6d1a0100b9c4fe09504d97cfabc66e4834003d2c8288f09fac0337728c
pkgname = sahel-fonts
diff --git a/PKGBUILD b/PKGBUILD
index b6b015d2317d..792e343c2d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,22 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=sahel-fonts
-pkgver=1.0.0_alpha9
+pkgver=1.0.0_alpha14
pkgrel=1
pkgdesc="A beautiful Persian font."
-url="https://rastikerdar.github.io/sahel-font/"
+url="https://github.com/rastikerdar/sahel-font"
arch=(any)
license=('OFL')
depends=('fontconfig')
-provides=('ttf-sahel' "$pkgname")
-conflicts=('ttf-sahel' "$pkgname")
-replaces=('ttf-sahel')
-source=("$pkgname-$pkgver.zip::https://github.com/rastikerdar/sahel-font/releases/download/v${pkgver//_/-}/sahel-font-v${pkgver//_/-}.zip")
-sha256sums=('07a5f04b23e86980d463c9e08267cc2e82eae59ab685ba5c584866c00311490b')
+provides=('ttf-sahel')
+conflicts=('ttf-sahel')
+source=("${pkgname}-${pkgver}.zip::${url}/releases/download/v${pkgver//_/-}/sahel-font-v${pkgver//_/-}.zip")
+sha256sums=('04e63f6d1a0100b9c4fe09504d97cfabc66e4834003d2c8288f09fac0337728c')
package() {
install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
- install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./Sahel*.{eot,ttf,woff}
- install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./{Farsi*,Without-Latin}/Sahel*.{eot,ttf,woff}
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./Sahel*.ttf
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./{Farsi*,Without-Latin}/Sahel*.ttf
install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
# vim:set ts=2 sw=2 et: