summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Fischer2016-09-18 17:12:30 +0200
committerFrank Fischer2016-09-18 17:12:30 +0200
commit965174bb8d1eaaf48c1ec66257c24a905f281aae (patch)
tree609b6e65ec534a810c0ef9dfc969c3326d7d500d
downloadaur-965174bb8d1eaaf48c1ec66257c24a905f281aae.tar.gz
Initial record
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--sailautossh.install14
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95978713cec6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sailautossh
+ pkgdesc = Automatic SSH Tunneling tool
+ pkgver = r120.5aaa9512be59
+ pkgrel = 1
+ url = http://bitbucket.org/lyro/sailautossh
+ install = sailautossh.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = mercurial
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ provides = sailautossh
+ source = hg+http://bitbucket.org/lyro/sailautossh
+ sha256sums = SKIP
+
+pkgname = sailautossh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f851e06b0e8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Frank Fischer <frank-fischer@shadow-soft.de>
+pkgname=sailautossh
+pkgver=r120.5aaa9512be59
+pkgrel=1
+pkgdesc="Automatic SSH Tunneling tool"
+arch=('i686' 'x86_64')
+url="http://bitbucket.org/lyro/sailautossh"
+license=('GPL3')
+depends=(qt5-base hicolor-icon-theme)
+makedepends=(mercurial)
+provides=('sailautossh')
+install=$pkgname.install
+source=("hg+http://bitbucket.org/lyro/sailautossh")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/sailautossh"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd "${srcdir}/sailautossh"
+ qmake PREFIX=/usr CONFIG+=BUILD_DESKTOP sailautossh.pro
+ make
+}
+
+package() {
+ cd "${srcdir}/sailautossh"
+ make INSTALL_ROOT="$pkgdir" install
+}
diff --git a/sailautossh.install b/sailautossh.install
new file mode 100644
index 000000000000..be2dfcf1b9c3
--- /dev/null
+++ b/sailautossh.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}
+