summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Manenti2022-03-31 19:59:57 +0200
committerAndrea Manenti2022-03-31 19:59:57 +0200
commit66433096dc81ff71326dd812555b869cdfb30064 (patch)
tree6bf08e9f65a43ec228a2408279fcf120c4cfd65a
parentd1557965e9db38dee96f000871428dac0e5dbd5f (diff)
downloadaur-66433096dc81ff71326dd812555b869cdfb30064.tar.gz
patch for new version of pyparsing
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
-rw-r--r--pyparsing_fix.patch16
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7219793fb1a5..d9708cdf9cbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = sailboot
pkgdesc = Highly customizable framework for performing numerical bootstrap computations
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/maneandrea/sailboot
arch = any
license = GPL
makedepends = python-setuptools
+ makedepends = git
depends = python-mpmath
depends = python-pyparsing
depends = sdpb-git
@@ -13,6 +14,8 @@ pkgbase = sailboot
optdepends = sagemath
optdepends = scalar_blocks-git
source = https://gitlab.com/maneandrea/sailboot/-/archive/v1.0/sailboot-v1.0.tar.gz
+ source = pyparsing_fix.patch
sha256sums = fcac6a42c2220220737d1274ec86afb2a33488737fb2a81d8ec3e8526b272bc7
+ sha256sums = ac4957d25c46651fc3a3341bacc24636bda1026910491e505fe023f00a45f120
pkgname = sailboot
diff --git a/PKGBUILD b/PKGBUILD
index efc236f7b8f1..06b09bdbd8d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,22 @@
pkgname=sailboot
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Highly customizable framework for performing numerical bootstrap computations"
arch=(any)
url='https://gitlab.com/maneandrea/sailboot'
license=('GPL')
depends=('python-mpmath' 'python-pyparsing' 'sdpb-git')
optdepends=('python-gmpy2' 'sagemath' 'scalar_blocks-git')
-makedepends=('python-setuptools')
-source=('https://gitlab.com/maneandrea/sailboot/-/archive/v1.0/sailboot-v1.0.tar.gz')
-sha256sums=('fcac6a42c2220220737d1274ec86afb2a33488737fb2a81d8ec3e8526b272bc7')
+makedepends=('python-setuptools' 'git')
+source=('https://gitlab.com/maneandrea/sailboot/-/archive/v1.0/sailboot-v1.0.tar.gz' 'pyparsing_fix.patch')
+sha256sums=('fcac6a42c2220220737d1274ec86afb2a33488737fb2a81d8ec3e8526b272bc7' 'ac4957d25c46651fc3a3341bacc24636bda1026910491e505fe023f00a45f120')
build() {
cd "$pkgname"-v"$pkgver"
+ git apply ../pyparsing_fix.patch
+
python setup.py build
}
diff --git a/pyparsing_fix.patch b/pyparsing_fix.patch
new file mode 100644
index 000000000000..94e04b4d84ec
--- /dev/null
+++ b/pyparsing_fix.patch
@@ -0,0 +1,16 @@
+diff --git a/src/makesdp/dumpsave.py b/src/makesdp/dumpsave.py
+index 73065f3..ef7ec0a 100644
+--- a/src/makesdp/dumpsave.py
++++ b/src/makesdp/dumpsave.py
+@@ -482,7 +482,10 @@ def make_dumpsave(args, do_identity=True, do_vectors=True):
+ for addend in matrix_entry['sum']:
+
+ # We replace the string contained in the coefficient with its internal representation
+- current_coeff = addend['block*coeff'].get('coeff', ['1'])[0]
++ current_coeff = addend['block*coeff'].get('coeff', ['1'])
++ if isinstance(current_coeff, list):
++ # Pyparsing 2.4 outputs coeff : ['...'] while Pyparsing 3.0 outputs coeff : '...'
++ current_coeff = current_coeff[0]
+ addend['block*coeff']['coeff'] = numericize_expr(current_coeff)
+
+ # We replace the block with a dictionary that has all the information ready to go