summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Manenti2021-12-02 02:33:32 +0100
committerAndrea Manenti2021-12-02 02:33:32 +0100
commit6892f2c323894162546c830841ab8aa4b5da3beb (patch)
tree3c9896b467db47cb61e913bb3a9772edbb7f5af2
downloadaur-6892f2c323894162546c830841ab8aa4b5da3beb.tar.gz
new package: sailboot
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7219793fb1a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sailboot
+ pkgdesc = Highly customizable framework for performing numerical bootstrap computations
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.com/maneandrea/sailboot
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python-mpmath
+ depends = python-pyparsing
+ depends = sdpb-git
+ optdepends = python-gmpy2
+ optdepends = sagemath
+ optdepends = scalar_blocks-git
+ source = https://gitlab.com/maneandrea/sailboot/-/archive/v1.0/sailboot-v1.0.tar.gz
+ sha256sums = fcac6a42c2220220737d1274ec86afb2a33488737fb2a81d8ec3e8526b272bc7
+
+pkgname = sailboot
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..98a9f71d6a36
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.zst
+*.log
+pkg
+src
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc236f7b8f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Andrea Manenti <andrea [dot] manenti [at] yahoo [dot] com>
+
+pkgname=sailboot
+pkgver=1.0
+pkgrel=1
+pkgdesc="Highly customizable framework for performing numerical bootstrap computations"
+arch=(any)
+url='https://gitlab.com/maneandrea/sailboot'
+license=('GPL')
+depends=('python-mpmath' 'python-pyparsing' 'sdpb-git')
+optdepends=('python-gmpy2' 'sagemath' 'scalar_blocks-git')
+makedepends=('python-setuptools')
+source=('https://gitlab.com/maneandrea/sailboot/-/archive/v1.0/sailboot-v1.0.tar.gz')
+sha256sums=('fcac6a42c2220220737d1274ec86afb2a33488737fb2a81d8ec3e8526b272bc7')
+
+build() {
+ cd "$pkgname"-v"$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"-v"$pkgver"
+
+ python setup.py install --root "$pkgdir" --optimize=1
+
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+
+ _pyver=$(python -V | sed -e 's/Python \([0-9]\.[0-9]\+\)\..*/\1/')
+
+ ln -sf /usr/lib/python$_pyver/site-packages/sailboot/main.py "$pkgdir"/usr/bin/sailboot
+ ln -sf /usr/lib/python$_pyver/site-packages/sailboot/launch.py "$pkgdir"/usr/bin/launch
+ ln -sf /usr/lib/python$_pyver/site-packages/sailboot/monitor.py "$pkgdir"/usr/bin/monitor
+}
+