summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Manenti2022-05-24 12:07:19 +0200
committerAndrea Manenti2022-05-24 12:07:19 +0200
commita492e7a9cf75d60eccca55a25b0e753c439ee17d (patch)
tree267139d61aee725a53ea7c643d0b99856ea8dddb
parentdc983f3e05e9f779dc2486f8d4172c7bec00cad9 (diff)
downloadaur-a492e7a9cf75d60eccca55a25b0e753c439ee17d.tar.gz
Version v1.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
-rw-r--r--pyparsing_fix.patch16
3 files changed, 10 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e06e15f8f6..373f647deec9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sailboot
pkgdesc = Highly customizable framework for performing numerical bootstrap computations
- pkgver = 1.0
- pkgrel = 2
+ pkgver = 1.1
+ pkgrel = 1
url = https://gitlab.com/maneandrea/sailboot
arch = any
license = GPL
@@ -12,9 +12,8 @@ pkgbase = sailboot
optdepends = python-gmpy2
optdepends = sagemath
optdepends = scalar_blocks-git
- source = https://gitlab.com/maneandrea/sailboot/-/archive/v1.0/sailboot-v1.0.tar.gz
- source = pyparsing_fix.patch
- sha256sums = fcac6a42c2220220737d1274ec86afb2a33488737fb2a81d8ec3e8526b272bc7
- sha256sums = ac4957d25c46651fc3a3341bacc24636bda1026910491e505fe023f00a45f120
+ optdepends = python-sympy
+ source = https://gitlab.com/maneandrea/sailboot/-/archive/v1.1/sailboot-v1.1.tar.gz
+ sha256sums = f024743e49296c23db48621e215ff9e979188e9d80d7cd30b5139cace90afaab
pkgname = sailboot
diff --git a/PKGBUILD b/PKGBUILD
index d56b6938af0a..3bc0e2dfe894 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: Andrea Manenti <andrea [dot] manenti [at] yahoo [dot] com>
pkgname=sailboot
-pkgver=1.0
-pkgrel=2
+pkgver=1.1
+pkgrel=1
pkgdesc="Highly customizable framework for performing numerical bootstrap computations"
arch=(any)
url='https://gitlab.com/maneandrea/sailboot'
license=('GPL')
depends=('python-mpmath' 'python-pyparsing' 'sdpb-git')
-optdepends=('python-gmpy2' 'sagemath' 'scalar_blocks-git')
+optdepends=('python-gmpy2' 'sagemath' 'scalar_blocks-git' 'python-sympy')
makedepends=('python-setuptools')
-source=('https://gitlab.com/maneandrea/sailboot/-/archive/v1.0/sailboot-v1.0.tar.gz' 'pyparsing_fix.patch')
-sha256sums=('fcac6a42c2220220737d1274ec86afb2a33488737fb2a81d8ec3e8526b272bc7' 'ac4957d25c46651fc3a3341bacc24636bda1026910491e505fe023f00a45f120')
+source=('https://gitlab.com/maneandrea/sailboot/-/archive/v1.1/sailboot-v1.1.tar.gz')
+sha256sums=('f024743e49296c23db48621e215ff9e979188e9d80d7cd30b5139cace90afaab')
build() {
cd "$pkgname"-v"$pkgver"
- patch -p1 < ../pyparsing_fix.patch
-
python setup.py build
}
diff --git a/pyparsing_fix.patch b/pyparsing_fix.patch
deleted file mode 100644
index 94e04b4d84ec..000000000000
--- a/pyparsing_fix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/src/makesdp/dumpsave.py b/src/makesdp/dumpsave.py
-index 73065f3..ef7ec0a 100644
---- a/src/makesdp/dumpsave.py
-+++ b/src/makesdp/dumpsave.py
-@@ -482,7 +482,10 @@ def make_dumpsave(args, do_identity=True, do_vectors=True):
- for addend in matrix_entry['sum']:
-
- # We replace the string contained in the coefficient with its internal representation
-- current_coeff = addend['block*coeff'].get('coeff', ['1'])[0]
-+ current_coeff = addend['block*coeff'].get('coeff', ['1'])
-+ if isinstance(current_coeff, list):
-+ # Pyparsing 2.4 outputs coeff : ['...'] while Pyparsing 3.0 outputs coeff : '...'
-+ current_coeff = current_coeff[0]
- addend['block*coeff']['coeff'] = numericize_expr(current_coeff)
-
- # We replace the block with a dictionary that has all the information ready to go